Quantcast

1.451 and EnvInject and conditional buildstep plugins

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

1.451 and EnvInject and conditional buildstep plugins

Matt Fair
After I upgraded Jenkins 1.451, I am now getting an error with
EnvInject and conditional buildstep plugins.  This was working fine
before the upgrade, so not exactly sure what has changed.  I have a
conditional buildstep that checks for certain build (i.e. debug or
release) as part of the matrix configuration and injects an
environment variable accordingly (i.e. foo=bar-debug  or foo=bar).

The error I get is:

Run condition [Strings match] enabling prebuild for step [Inject
environment variables]
Run condition [Strings match] enabling prebuild for step [Inject
environment variables]
[EnvInject] - Executing scripts and injecting environment variables
after the SCM step.
[EnvInject] - [ERROR] - [EnvInject] - [ERROR] - Problems occurs on
injecting env vars as a build wrap: hudson.matrix.MatrixConfiguration
cannot be cast to hudson.model.TopLevelItem

Has anything changed in Jenkins between 1.450 and 1.451 that would
cause this error?  So the problem is either caused by using a matrix
variable in conditional buildstep or injecting the variable.

Thanks,
Matt
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 1.451 and EnvInject and conditional buildstep plugins

Matt Fair
Just to let you know, after downgrading back to 1.450 this problem
went away again.  So the problem arises with a change in 1.451.
Thanks,
Matt

On Tue, Feb 21, 2012 at 10:57 AM, Matt Fair <[hidden email]> wrote:

> After I upgraded Jenkins 1.451, I am now getting an error with
> EnvInject and conditional buildstep plugins.  This was working fine
> before the upgrade, so not exactly sure what has changed.  I have a
> conditional buildstep that checks for certain build (i.e. debug or
> release) as part of the matrix configuration and injects an
> environment variable accordingly (i.e. foo=bar-debug  or foo=bar).
>
> The error I get is:
>
> Run condition [Strings match] enabling prebuild for step [Inject
> environment variables]
> Run condition [Strings match] enabling prebuild for step [Inject
> environment variables]
> [EnvInject] - Executing scripts and injecting environment variables
> after the SCM step.
> [EnvInject] - [ERROR] - [EnvInject] - [ERROR] - Problems occurs on
> injecting env vars as a build wrap: hudson.matrix.MatrixConfiguration
> cannot be cast to hudson.model.TopLevelItem
>
> Has anything changed in Jenkins between 1.450 and 1.451 that would
> cause this error?  So the problem is either caused by using a matrix
> variable in conditional buildstep or injecting the variable.
>
> Thanks,
> Matt
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 1.451 and EnvInject and conditional buildstep plugins

Gregory Boissinot
Issue is the same as https://issues.jenkins-ci.org/browse/JENKINS-12108

On Wed, Feb 22, 2012 at 6:10 AM, Matt Fair <[hidden email]> wrote:
Just to let you know, after downgrading back to 1.450 this problem
went away again.  So the problem arises with a change in 1.451.
Thanks,
Matt

On Tue, Feb 21, 2012 at 10:57 AM, Matt Fair <[hidden email]> wrote:
> After I upgraded Jenkins 1.451, I am now getting an error with
> EnvInject and conditional buildstep plugins.  This was working fine
> before the upgrade, so not exactly sure what has changed.  I have a
> conditional buildstep that checks for certain build (i.e. debug or
> release) as part of the matrix configuration and injects an
> environment variable accordingly (i.e. foo=bar-debug  or foo=bar).
>
> The error I get is:
>
> Run condition [Strings match] enabling prebuild for step [Inject
> environment variables]
> Run condition [Strings match] enabling prebuild for step [Inject
> environment variables]
> [EnvInject] - Executing scripts and injecting environment variables
> after the SCM step.
> [EnvInject] - [ERROR] - [EnvInject] - [ERROR] - Problems occurs on
> injecting env vars as a build wrap: hudson.matrix.MatrixConfiguration
> cannot be cast to hudson.model.TopLevelItem
>
> Has anything changed in Jenkins between 1.450 and 1.451 that would
> cause this error?  So the problem is either caused by using a matrix
> variable in conditional buildstep or injecting the variable.
>
> Thanks,
> Matt

Loading...