Building Javancss plugin from source using Maven

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Building Javancss plugin from source using Maven

Damian Skiedrzyński
Hello everyone,
I downloaded the JavaNCSS plugin from the repo
https://svn.java.net/svn/hudson~svn/trunk/hudson/plugins/javancss/.
Than I tried to build it using "mvn package" command but the build
stopps when the following text is displayed:
"Starting JavaNCSSPublisherTest.testOnSlave". No error is displayed
and the process hangs.

I am using Maven 3.0.1

Thanks a lot for your help.

Damian
Reply | Threaded
Open this post in threaded view
|

Re: Building Javancss plugin from source using Maven

Rob Petti-2
It's possible that the test depends on some environment configuration that you are missing. I would recommend reading the test code to find out where the problem is. Failing that, you can always disable tests if you aren't trying to release (-DskipTests=true).
Reply | Threaded
Open this post in threaded view
|

Re: Building Javancss plugin from source using Maven

Damian Skiedrzyński
After skiping the tests it works fine but after configuring the build
to use the example report (delivered with the JavaNCSS plugin) I can
see no results in Hudson.
This was also reported here http://wiki.hudson-ci.org/pages/viewpage.action?pageId=36603031.
Is there any other configuration that enables it?

Regards,
Damian

On 11 Jan., 16:30, Rob Petti <[hidden email]> wrote:
> It's possible that the test depends on some environment configuration that
> you are missing. I would recommend reading the test code to find out where
> the problem is. Failing that, you can always disable tests if you aren't
> trying to release (-DskipTests=true).
Reply | Threaded
Open this post in threaded view
|

Re: Building Javancss plugin from source using Maven

Damian Skiedrzyński
Ok. The problem was in providing the right xml input in the workspace
folder of the build.

On 12 Jan., 18:51, neutrino <[hidden email]> wrote:

> After skiping the tests it works fine but after configuring the build
> to use the example report (delivered with the JavaNCSS plugin) I can
> see no results in Hudson.
> This was also reported herehttp://wiki.hudson-ci.org/pages/viewpage.action?pageId=36603031.
> Is there any other configuration that enables it?
>
> Regards,
> Damian
>
> On 11 Jan., 16:30, Rob Petti <[hidden email]> wrote:
>
> > It's possible that the test depends on some environment configuration that
> > you are missing. I would recommend reading the test code to find out where
> > the problem is. Failing that, you can always disable tests if you aren't
> > trying to release (-DskipTests=true).