Quantcast

Caused by: java.lang.ClassNotFoundException: weblogic.Deployer

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Caused by: java.lang.ClassNotFoundException: weblogic.Deployer

mosman
I can deploy EAR using ant in Jdev 11.1.1.3 or at command line.
However, I cannot deploy EAR in Hudson.
I also run setDomainEmv.cmd. But I get the following errors in Hudson.

--------------------------------------------------------------------------------
deploy-app:
[java] java.lang.NoClassDefFoundError: weblogic/Deployer
[java] Caused by: java.lang.ClassNotFoundException: weblogic.Deployer
[java] at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
[java] at java.security.AccessController.doPrivileged(Native Method)
[java] at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
[java] at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
[java] at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
[java] at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
[java] Could not find the main class: weblogic.Deployer. Program will exit.
[java] Exception in thread "main"

--------------------------------
CLASSPATH=E:\JDEVEL~3\patch_wls1033\profiles\default\sys_manifest_classpath\webl
ogic_patch.jar;E:\JDEVEL~3\patch_jdev1111\profiles\default\sys_manifest_classpat
h\weblogic_patch.jar;E:\JDEVEL~3\JDK160~1\lib\tools.jar;E:\JDEVEL~3\WLSERV~1.3\s
erver\lib\weblogic_sp.jar;E:\JDEVEL~3\WLSERV~1.3\server\lib\weblogic.jar;E:\JDEV
EL~3\modules\features\weblogic.server.modules_10.3.3.0.jar;E:\JDEVEL~3\WLSERV~1.
3\server\lib\webservices.jar;E:\JDEVEL~3\modules\ORGAPA~1.1/lib/ant-all.jar;E:\J
DEVEL~3\modules\NETSFA~1.0_1/lib/ant-contrib.jar;E:\JDEVEL~3\patch_wls1033\profi
les\default\sys_manifest_classpath\webl
---------------------------------
Path=E:\JDEVEL~3\patch_wls1033\profiles\default\native;E:\JDEVEL~3\patch_jdev111
1\profiles\default\native;E:\JDEVEL~3\WLSERV~1.3\server\native\win\32;E:\JDEVEL~
3\WLSERV~1.3\server\bin;E:\JDEVEL~3\modules\ORGAPA~1.1\bin;E:\JDEVEL~3\JDK160~1\
jre\bin;E:\JDEVEL~3\JDK160~1\bin;E:\JDEVEL~3\patch_wls1033\profiles\default\nati
ve;E:\JDEVEL~3\patch_jdev111;E:\JDEVEL~3\WLSERV~1.3\server\native\win\32\oci920_
8
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Caused by: java.lang.ClassNotFoundException: weblogic.Deployer

mosman
Please help me
Loading...