Cobertura maven plugin incompatible with Hudson?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Cobertura maven plugin incompatible with Hudson?

Steele, Richard
I'm trying to run Cobertura, though the maven plugin, against my Hudson plugin, but when I run it I get an error:

[INFO] Error configuring: org.kohsuke.stapler:maven-stapler-plugin. Reason: ERROR: Cannot override read-only parameter: classesDirectory in goal: stapler:stapler

Anyone know what this means?  I'm not a big-time maven user, so this is gibberish to me.

Thanks,
Rich
ePlus Consulting
Reply | Threaded
Open this post in threaded view
|

Re: Cobertura maven plugin incompatible with Hudson?

Steele, Richard
Answering my own question: I was using maven-hpi-plugin:1.6; updating my pom.xml to specify 1.8 seems to have fixed whatever it was that was annoying the covertura plugin.

I really wish maven would let you know you're using what appears to be out of date dependencies.  Maybe it already does.  Anyone know?

Thanks,
Rich
ePlus Consulting.
Reply | Threaded
Open this post in threaded view
|

Re: Cobertura maven plugin incompatible with Hudson?

Kohsuke Kawaguchi
Administrator
Thanks for sharing your solution.

I wonder perhaps "LATEST" or "RELEASE" version number can be used to
indicate suitably up-to-date version.

When I tried it some time ago, it didn't work for me, but I thought
these things are supposed to be for this kind of needs.

2007/4/28, rsteele <[hidden email]>:

>
> Answering my own question: I was using maven-hpi-plugin:1.6; updating my
> pom.xml to specify 1.8 seems to have fixed whatever it was that was annoying
> the covertura plugin.
>
> I really wish maven would let you know you're using what appears to be out
> of date dependencies.  Maybe it already does.  Anyone know?
>
> Thanks,
> Rich
> ePlus Consulting.
>
> --
> View this message in context: http://www.nabble.com/Cobertura-maven-plugin-incompatible-with-Hudson--tf3662949.html#a10235189
> Sent from the Hudson users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Kohsuke Kawaguchi

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]