Dependencies are not being solved

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Dependencies are not being solved

test200891
Hi,

I am a very new user of Maven and Jenkins. I am trying to implement CI using Maven on Jenkins for my Java project. But I see that I am getting an error like package org.eclipse.emf.ecore not found does not exist.

It is the dependency and it is present in my library already and I have also defined it in my pom.xml. Yet still it is not detecting some of my dependencies. 

I have attached my pom.xml, please guide me if I am missing out something?

Here is my pom.xml:

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
    <modelVersion>4.0.0</modelVersion>
    
    <groupId>ADNCore</groupId>
    <artifactId>ADNCore</artifactId>
    <version>0.0.1-SNAPSHOT</version>
<packaging>war</packaging>
<properties>
<javaVersion>6</javaVersion>
<maven.compiler.source>1.${javaVersion}</maven.compiler.source>
<maven.compiler.target>1.${javaVersion}</maven.compiler.target>
<project.build.sourceEncoding>Cp1252</project.build.sourceEncoding>
<project.reporting.outputEncoding>Cp1252</project.reporting.outputEncoding>
</properties>  
<repositories>
       <repository>
        <id>localrepository</id>
        <url>file://${basedir}/WebContent/WEB-INF/lib</url>
         </repository>
        </repositories>
<dependencies>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>4.0</version>
<type>jar</type>
<scope>test</scope>
<optional>true</optional>
</dependency>
<dependency>
<groupId>org.hibernate</groupId>
<artifactId>hibernate-core</artifactId>
<version>3.3.2.GA</version>
</dependency>
<dependency>
<groupId>org.aspectj</groupId>
<artifactId>aspectjrt</artifactId>
<version>1.6.7</version>
<type>jar</type>
<scope>provided</scope>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-api</artifactId>
<version>1.7.5</version>
</dependency>
<dependency>
<groupId>org.slf4j</groupId>
<artifactId>slf4j-simple</artifactId>
<version>1.6.4</version>
</dependency>
<dependency> 
<groupId>org.slf4j</groupId>
<artifactId>slf4j-log4j12</artifactId>
<version>1.7.21</version>
</dependency>
<dependency>
<groupId>com.googlecode.slf4j-maven-plugin-log</groupId>
<artifactId>slf4j-maven-plugin-log</artifactId>
<version>1.0.0</version>
</dependency>
</dependencies>
<dependencyManagement>
<dependencies>
<dependency>
<groupId>org.eclipse.emf.ecore</groupId>
<artifactId>sdo</artifactId>
<version>2.3.0-v200706262000</version>
</dependency>
<dependency>
<groupId>org.eclipse.emf</groupId>
<artifactId>org.eclipse.emf.mwe.utils</artifactId>
<version>1.3.21.201705291010</version>
</dependency>
<dependency>
<groupId>AdnCriteriaAndRestrictions</groupId>
<artifactId>AdnCriteriaAndRestrictions</artifactId>
</dependency>
<dependency>
<groupId>AdnDaoGeneratorProcEx</groupId>
<artifactId>AdnDaoGeneratorProcEx</artifactId>
</dependency>
<dependency>
<groupId>ant-junit</groupId>
<artifactId>ant-junit</artifactId>
</dependency>
<dependency>
<groupId>antlr-2.7.6</groupId>
<artifactId>antlr-2.7.6</artifactId>
<version>2.7.6</version>
</dependency>
<dependency>
<groupId>aspectjrt</groupId>
<artifactId>aspectjrt</artifactId>
</dependency>
<dependency>
<groupId>aspectjtools1.6.11</groupId>
<artifactId>aspectjtools1.6.11</artifactId>
<version>1.6.11</version>
</dependency>
<dependency>
<groupId>bean-validator-2.3.0-b09</groupId>
<artifactId>bean-validator-2.3.0-b09</artifactId>
</dependency>
<dependency>
<groupId>c3p0-0.9.1.2</groupId>
<artifactId>c3p0-0.9.1.2</artifactId>
<version>0.9.1.2</version>
</dependency>
<dependency>
<groupId>cfgatewayadapter</groupId>
<artifactId>cfgatewayadapter</artifactId>
</dependency>
<dependency>
<groupId>classmate-0.8.0</groupId>
<artifactId>classmate-0.8.0</artifactId>
<version>0.8.0</version>
</dependency>
<dependency>
<groupId>com.microsoft.sqlserver.jdbc_3.0.1301.101</groupId>
<artifactId>com.microsoft.sqlserver.jdbc_3.0.1301.101</artifactId>
<version>3.0.1301.101</version>
</dependency>
<dependency>
<groupId>com.soyatec.cmengine.source_0.9.13.201310251702</groupId>
<artifactId>com.soyatec.cmengine.source_0.9.13.201310251702</artifactId>
<version>0.9.13.201310251702</version>
</dependency>
<dependency>
<groupId>com.soyatec.cmengine_0.9.13.201310251702</groupId>
<artifactId>com.soyatec.cmengine_0.9.13.201310251702</artifactId>
<version>0.9.13.201310251702</version>
</dependency>
<dependency>
<groupId>commons-codec-1.3</groupId>
<artifactId>commons-codec-1.3</artifactId>
<version>1.3</version>
</dependency>
<dependency>
<groupId>commons-collections-3.1</groupId>
<artifactId>commons-collections-3.1</artifactId>
<version>3.1</version>
</dependency>
<dependency>
<groupId>commons-collections-3.2.1</groupId>
<artifactId>commons-collections-3.2.1</artifactId>
<version>3.2.1</version>
</dependency>
<dependency>
<groupId>commons-fileupload-1.2.2</groupId>
<artifactId>commons-fileupload-1.2.2</artifactId>
<version>1.2.2</version>
</dependency>
<dependency>
<groupId>commons-httpclient-3.0.1</groupId>
<artifactId>commons-httpclient-3.0.1</artifactId>
<version>3.0.1</version>
</dependency>
<dependency>
<groupId>commons-io-2.3</groupId>
<artifactId>commons-io-2.3</artifactId>
<version>2.3</version>
</dependency>
<dependency>
<groupId>commons-io-2.3-javadoc</groupId>
<artifactId>commons-io-2.3-javadoc</artifactId>
<version>2.3</version>
</dependency>
<dependency>
<groupId>commons-io-2.3-sources</groupId>
<artifactId>commons-io-2.3-sources</artifactId>
<version>2.3</version>
</dependency>
<dependency>
<groupId>commons-io-2.3-tests</groupId>
<artifactId>commons-io-2.3-tests</artifactId>
<version>2.3</version>
</dependency>
<dependency>
<groupId>commons-io-2.3-test-sources</groupId>
<artifactId>commons-io-2.3-test-sources</artifactId>
<version>2.3</version>
</dependency>
<dependency>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
</dependency>
<dependency>
<groupId>commons-logging-api-1.1.1</groupId>
<artifactId>commons-logging-api-1.1.1</artifactId>
<version>1.1.1</version>
</dependency>
<dependency>
<groupId>dom4j-1.6.1</groupId>
<artifactId>dom4j-1.6.1</artifactId>
<version>1.6.1</version>
</dependency>
<dependency>
<groupId>easymock-3.2</groupId>
<artifactId>easymock-3.2</artifactId>
<version>3.2</version>
</dependency>
<dependency>
<groupId>fest-assert-1.4</groupId>
<artifactId>fest-assert-1.4</artifactId>
<version>1.4</version>
</dependency>
<dependency>
<groupId>fest-util-1.1.6</groupId>
<artifactId>fest-util-1.1.6</artifactId>
<version>1.1.6</version>
</dependency>
<dependency>
<groupId>flex-messaging-common</groupId>
<artifactId>flex-messaging-common</artifactId>
</dependency>
<dependency>
<groupId>flex-messaging-core</groupId>
<artifactId>flex-messaging-core</artifactId>
</dependency>
<dependency>
<groupId>flex-messaging-opt</groupId>
<artifactId>flex-messaging-opt</artifactId>
</dependency>
<dependency>
<groupId>flex-messaging-proxy</groupId>
<artifactId>flex-messaging-proxy</artifactId>
</dependency>
<dependency>
<groupId>flex-messaging-remoting</groupId>
<artifactId>flex-messaging-remoting</artifactId>
</dependency>
<dependency>
<groupId>flex-rds-server</groupId>
<artifactId>flex-rds-server</artifactId>
</dependency>
<dependency>
<groupId>groovy-2.1.0</groupId>
<artifactId>groovy-2.1.0</artifactId>
<version>2.1.0</version>
</dependency>
<dependency>
<groupId>groovy-jsr223-2.1.0</groupId>
<artifactId>groovy-jsr223-2.1.0</artifactId>
<version>2.1.0</version>
</dependency>
<dependency>
<groupId>hamcrest-core-1.3</groupId>
<artifactId>hamcrest-core-1.3</artifactId>
<version>1.3</version>
</dependency>
<dependency>
<groupId>hibernate3</groupId>
<artifactId>hibernate3</artifactId>
</dependency>
<dependency>
<groupId>hibernate-core-3.6.4.Final-sources</groupId>
<artifactId>hibernate-core-3.6.4.Final-sources</artifactId>
<version>3.6.4</version>
</dependency>
<dependency>
<groupId>jaas</groupId>
<artifactId>jaas</artifactId>
</dependency>
<dependency>
<groupId>javassist-3.12.0.GA</groupId>
<artifactId>javassist-3.12.0.GA</artifactId>
<version>3.12.0</version>
</dependency>
<dependency>
<groupId>java-uuid-generator-3.1.3</groupId>
<artifactId>java-uuid-generator-3.1.3</artifactId>
<version>3.1.3</version>
</dependency>
<dependency>
<groupId>javax.el-2.2.4</groupId>
<artifactId>javax.el-2.2.4</artifactId>
<version>2.2.4</version>
</dependency>
<dependency>
<groupId>javax.el-api-2.2.4</groupId>
<artifactId>javax.el-api-2.2.4</artifactId>
<version>2.2.4</version>
</dependency>
<dependency>
<groupId>javax.mail-1.3.3.01</groupId>
<artifactId>javax.mail-1.3.3.01</artifactId>
<version>1.3.3.01</version>
</dependency>
<dependency>
<groupId>javax.persistence_2.0.1</groupId>
<artifactId>javax.persistence_2.0.1</artifactId>
<version>2.0.1</version>
</dependency>
<dependency>
<groupId>javax.servlet-3.0</groupId>
<artifactId>javax.servlet-3.0</artifactId>
<version>3.0</version>
</dependency>
<dependency>
<groupId>jdom-1.1.2</groupId>
<artifactId>jdom-1.1.2</artifactId>
<version>1.1.2</version>
</dependency>
<dependency>
<groupId>joda-time-2.1</groupId>
<artifactId>joda-time-2.1</artifactId>
<version>2.1</version>
</dependency>
<dependency>
<groupId>jsoup-1.7.1</groupId>
<artifactId>jsoup-1.7.1</artifactId>
<version>1.7.1</version>
</dependency>
<dependency>
<groupId>jta-1.1</groupId>
<artifactId>jta-1.1</artifactId>
<version>1.1</version>
</dependency>
<dependency>
<groupId>junit-4.11</groupId>
<artifactId>junit-4.11</artifactId>
<version>4.11</version>
</dependency>
<dependency>
<groupId>KarrenLicenseUsage</groupId>
<artifactId>KarrenLicenseUsage</artifactId>
</dependency>
<dependency>
<groupId>licensing-core-1.1.0</groupId>
<artifactId>licensing-core-1.1.0</artifactId>
<version>1.1.0</version>
</dependency>
<dependency>
<groupId>log4j-1.2.17</groupId>
<artifactId>log4j-1.2.17</artifactId>
<version>1.2.17</version>
</dependency>
<dependency>
<groupId>mybatis-3.2.3</groupId>
<artifactId>mybatis-3.2.3</artifactId>
<version>3.2.3</version>
</dependency>
<dependency>
<groupId>mysql-connector-java-5.1.17-bin</groupId>
<artifactId>mysql-connector-java-5.1.17-bin</artifactId>
<version>5.1.17</version>
</dependency>
<dependency>
<groupId>org.apache.commons.logging_1.1.1</groupId>
<artifactId>org.apache.commons.logging_1.1.1</artifactId>
<version>1.1.1</version>
</dependency>
<dependency>
<groupId>org.apache.log4j_1.2.16</groupId>
<artifactId>org.apache.log4j_1.2.16</artifactId>
<version>1.2.16</version>
</dependency>
<dependency>
<groupId>org.dom4j_1.6.1</groupId>
<artifactId>org.dom4j_1.6.1</artifactId>
<version>1.6.1</version>
</dependency>
<dependency>
<groupId>org.eclipse.emf.common_2.7.0.v20120127-1122</groupId>
<artifactId>org.eclipse.emf.common_2.7.0.v20120127-1122</artifactId>
<version>2.7.0.v20120127-1122</version>
</dependency>
<dependency>
<groupId>org.eclipse.emf.ecore.source_2.7.0.v20120127-1122</groupId>
<artifactId>org.eclipse.emf.ecore.source_2.7.0.v20120127-1122</artifactId>
<version>2.7.0.v20120127-1122</version>
</dependency>
<dependency>
<groupId>org.eclipse.emf.ecore.xmi_2.7.0.v20120127-1122</groupId>
<artifactId>org.eclipse.emf.ecore.xmi_2.7.0.v20120127-1122</artifactId>
<version>2.7.0.v20120127-1122</version>
</dependency>
<dependency>
<groupId>org.eclipse.emf.ecore_2.7.0.v20120127-1122</groupId>
<artifactId>org.eclipse.emf.ecore_2.7.0.v20120127-1122</artifactId>
<version>2.7.0.v20120127-1122</version>
</dependency>
<dependency>
<groupId>org.eclipse.emf.teneo.annotations_1.2.0.v201107080556</groupId>
<artifactId>org.eclipse.emf.teneo.annotations_1.2.0.v201107080556</artifactId>
<version>1.2.0.v201107080556</version>
</dependency>
<dependency>
<groupId>org.eclipse.emf.teneo.hibernate.mapper_1.2.0.v201107080556</groupId>
<artifactId>org.eclipse.emf.teneo.hibernate.mapper_1.2.0.v201107080556</artifactId>
<version>1.2.0.v201107080556</version>
</dependency>
<dependency>
<groupId>org.eclipse.emf.teneo.hibernate_1.2.0.v201107080556</groupId>
<artifactId>org.eclipse.emf.teneo.hibernate_1.2.0.v201107080556</artifactId>
<version>1.2.0.v201107080556</version>
</dependency>
<dependency>
<groupId>org.eclipse.emf.teneo_1.2.0.v201107080556</groupId>
<artifactId>org.eclipse.emf.teneo_1.2.0.v201107080556</artifactId>
<version>1.2.0.v201107080556</version>
</dependency>
<dependency>
<groupId>org.hsqldb_1.8.1</groupId>
<artifactId>org.hsqldb_1.8.1</artifactId>
<version>1.8.1</version>
</dependency>
<dependency>
<groupId>org.postgresql_9.0.0.801</groupId>
<artifactId>org.postgresql_9.0.0.801</artifactId>
<version>9.0.0.801</version>
</dependency>
<dependency>
<groupId>poi-3.9-20121203</groupId>
<artifactId>poi-3.9-20121203</artifactId>
<version>3.9-20121203</version>
</dependency>
<dependency>
<groupId>poi-ooxml-3.9-20121203</groupId>
<artifactId>poi-ooxml-3.9-20121203</artifactId>
<version>3.9-20121203</version>
</dependency>
<dependency>
<groupId>poi-ooxml-schemas-3.9-20121203</groupId>
<artifactId>poi-ooxml-schemas-3.9-20121203</artifactId>
<version>3.9-20121203</version>
</dependency>
<dependency>
<groupId>slf4j-api-1.6.1</groupId>
<artifactId>slf4j-api-1.6.1</artifactId>
<version>1.6.1</version>
</dependency>
<dependency>
<groupId>spring-2.0.7</groupId>
<artifactId>spring-2.0.7</artifactId>
<version>2.0.7</version>
</dependency>
<dependency>
<groupId>testng-6.8</groupId>
<artifactId>testng-6.8</artifactId>
<version>6.8</version>
</dependency>
<dependency>
<groupId>uuid-3.3</groupId>
<artifactId>uuid-3.3</artifactId>
<version>3.3</version>
</dependency>
<dependency>
<groupId>xalan</groupId>
<artifactId>xalan</artifactId>
</dependency>
<dependency>
<groupId>xmlbeans-2.3.0</groupId>
<artifactId>xmlbeans-2.3.0</artifactId>
<version>2.3.0</version>
</dependency>
</dependencies>
</dependencyManagement>
<build>
<directory>${project.basedir}/target</directory>
<outputDirectory>${project.build.directory}/classes</outputDirectory>
<finalName>${project.artifactId}-${project.version}</finalName>
<testOutputDirectory>${project.build.directory}/test-classes</testOutputDirectory>
<resources>
<resource>
<directory>resources</directory>
</resource>
<resource>
<directory>WebContent\WEB-INF</directory>
</resource>
<resource>
<directory>WebContent\WEB-INF\lib</directory>
</resource>
</resources>
<pluginManagement>
<plugins>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>build-helper-maven-plugin</artifactId>
<version>3.0.0</version>
<executions>
<execution>
<phase>generate-sources</phase>
<goals>
<goal>add-source</goal>
</goals>
<configuration>
<sources>
<source>src_adnKCM</source>
<source>src_adnNotifications</source>
<source>src_adnRightsAccess</source>
<source>src_adnAccountController</source>
<source>src_adnException</source>
<source>src_cmd</source>
<source>src_cmengineadn</source>
<source>src_KBEConnector</source>
<source>src_adnCommon</source>
<source>src_adnWebServices</source>
<source>src_adnGenericDao</source>
<source>src_aspect_ordering</source>
<source>src_adnLogging</source>
<source>src_adnDbrepresentation</source>
<source>src_conflicts</source>
<source>src_licensing</source>
<source>src_rightsAccessCheck</source>
<source>src_excel</source>
<source>src_validation</source>
<source>src_hbSessionOnDemand</source>
<source>src_adnFilters</source>
</sources>
</configuration>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<version>3.7.0</version>
<configuration>
<excludes>
<exclude>**/*.java</exclude>
</excludes>
</configuration>
</plugin>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>aspectj-maven-plugin</artifactId>
<version>1.3</version>
<configuration>
<source>1.6</source>
<target>1.6</target>
<complianceLevel>1.6</complianceLevel>
</configuration>
<executions>
<execution>
<phase>process-sources</phase>
<goals>
<goal>compile</goal>       
<goal>test-compile</goal>  
</goals>
</execution>
</executions>
</plugin>
<plugin>            
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-war-plugin</artifactId>
<version>3.2.0</version>
<configuration>
<webXml>${basedir}/WebContent/WEB-INF/web.xml</webXml>        
</configuration>
</plugin>
<plugin>
<artifactId>maven-release-plugin</artifactId>
<configuration>
<autoVersionSubmodules>true</autoVersionSubmodules>
</configuration>
</plugin>

<plugin>
<artifactId>maven-site-plugin</artifactId>
<configuration>
<reportPlugins>
<plugin>
<artifactId>maven-checkstyle-plugin</artifactId>
</plugin>

<plugin>
<artifactId>maven-jxr-plugin</artifactId>
</plugin>

<plugin>
<artifactId>maven-javadoc-plugin</artifactId>
</plugin>

<plugin>
<artifactId>maven-pmd-plugin</artifactId>
</plugin>

<plugin>
<artifactId>maven-surefire-report-plugin</artifactId>
</plugin>

<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>findbugs-maven-plugin</artifactId>
</plugin>

<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>taglist-maven-plugin</artifactId>
</plugin>
</reportPlugins>
</configuration>
</plugin>
<plugin>
<artifactId>maven-checkstyle-plugin</artifactId>
<version>2.8</version>
</plugin>

<plugin>
<artifactId>maven-javadoc-plugin</artifactId>
<version>2.8</version>
</plugin>

<plugin>
<artifactId>maven-jxr-plugin</artifactId>
<version>2.3</version>
</plugin>

<plugin>
<artifactId>maven-pmd-plugin</artifactId>
<version>2.6</version>
</plugin>

<plugin>
<artifactId>maven-project-info-reports-plugin</artifactId>
<version>2.4</version>
</plugin>

<plugin>
<artifactId>maven-release-plugin</artifactId>
<version>2.2.1</version>
</plugin>

<plugin>
<artifactId>maven-resources-plugin</artifactId>
<version>2.5</version>
</plugin>

<plugin>
<artifactId>maven-site-plugin</artifactId>
<version>3.0</version>
</plugin>

<plugin>
<artifactId>maven-surefire-report-plugin</artifactId>
<version>2.11</version>
</plugin>

<plugin>
<artifactId>maven-surefire-plugin</artifactId>
<version>2.11</version>
</plugin>

<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>findbugs-maven-plugin</artifactId>
<version>2.3.3</version>
</plugin>

<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>taglist-maven-plugin</artifactId>
<version>2.4</version>
</plugin>

<plugin>
<groupId>org.mortbay.jetty</groupId>
<artifactId>jetty-maven-plugin</artifactId>
<version>8.0.0.M1</version>
</plugin>
</plugins>
</pluginManagement>
</build>
</project>


And these are errors I am getting while running on Jenkins:

[ERROR] COMPILATION ERROR : 
[INFO] -------------------------------------------------------------
[ERROR] /C:/Users/.../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/KnowledgeConfigurationInternalImpl.java:[13,37] package org.eclipse.emf.common.notify does not exist
[ERROR] /C:/Users/.../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/KnowledgeConfigurationInternalImpl.java:[14,37] package org.eclipse.emf.common.notify does not exist
[ERROR] /C:/User/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/KnowledgeConfigurationInternalImpl.java:[15,35] package org.eclipse.emf.common.util does not exist
[ERROR] /C:/Users/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/KnowledgeConfigurationInternalImpl.java:[16,29] package org.eclipse.emf.ecore does not exist
[ERROR] /C:/Users/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/KnowledgeConfigurationInternalImpl.java:[17,29] package org.eclipse.emf.ecore does not exist
[ERROR] /C:/Users/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/KnowledgeConfigurationInternalImpl.java:[18,34] package org.eclipse.emf.ecore.impl does not exist
[ERROR] /C:/Users/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/KnowledgeConfigurationInternalImpl.java:[20,34] package org.eclipse.emf.ecore.util does not exist
[ERROR] /C:/Users/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/KnowledgeConfigurationInternalImpl.java:[21,34] package org.eclipse.emf.ecore.util does not exist
[ERROR] /C:/Users/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/InternalObjectImpl.java:[9,37] package org.eclipse.emf.common.notify does not exist
[ERROR] /C:/Users/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/InternalObjectImpl.java:[10,29] package org.eclipse.emf.ecore does not exist
[ERROR] /C:/Users/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/InternalObjectImpl.java:[11,34] package org.eclipse.emf.ecore.impl does not exist
[ERROR] /C:/Users/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/InternalObjectImpl.java:[12,34] package org.eclipse.emf.ecore.impl does not exist
[ERROR] /C:/Users/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/impl/InternalObjectImpl.java:[33,50] cannot find symbol
symbol: class EObjectImpl [ERROR] /C:/Users/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/InternalObject.java:[9,29] package org.eclipse.emf.ecore does not exist
[ERROR] /C:/Users/..../Documents/MavenJ2/ADNCore026/src_adnKCM/com/dps/fr/adn/adnKCM/core/entitiesVersion/InternalObject.java:[31,41] cannot find symbol
symbol: class EObject
and so on...

I would be really thankful if someone could tell me what is that I am missing?

Thanking you in advance,

SD

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/7b572b58-28e2-4790-a058-a42182f1b0d2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.