Deploying to local Maven Repo problems

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Deploying to local Maven Repo problems

Gav-9
Hi All,

Not wanting to hijack Toms similar thread ....

I am using the 'Deploy to Maven Repository' feature, and
deploying to the local copy using the path /home/hudson/.m2/repository/

however I am getting builds fail using it, here is a snippet, showing I have
some kind of permissions problem, is it Maven themselves doing this, do I
need to get permission somehwere or do I set up my own permissions

Thanks

Deploying artifacts to /home/hudson/.m2/repository/
Deploying the main artifact shindig-common-1-SNAPSHOT.jar
[INFO ] Retrieving previous build number from
[INFO ] repository metadata for: 'snapshot org.apache.shindig:shindig-common:1-SNAPSHOT' could not be found on repository: , so will be created
ERROR: Error deploying artifact: Error executing command for transfer
org.apache.maven.artifact.deployer.ArtifactDeploymentException: Error deploying artifact: Error executing command for transfer
at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.deploy(DefaultArtifactDeployer.java:94)
at hudson.maven.reporters.MavenArtifactRecord.deploy(MavenArtifactRecord.java:97)
at hudson.maven.reporters.MavenAggregatedArtifactRecord.deploy(MavenAggregatedArtifactRecord.java:56)
at hudson.maven.RedeployPublisher.perform(RedeployPublisher.java:67)
at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:309)
at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:434)
at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:282)
at hudson.model.Run.run(Run.java:796)
at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:202)
at hudson.model.ResourceController.execute(ResourceController.java:70)
at hudson.model.Executor.run(Executor.java:85)
Caused by: org.apache.maven.wagon.TransferFailedException: Error executing command for transfer
at org.apache.maven.wagon.providers.ssh.external.ScpExternalWagon.put(ScpExternalWagon.java:290)
at org.apache.maven.artifact.manager.DefaultWagonManager.putRemoteFile(DefaultWagonManager.java:244)
at org.apache.maven.artifact.manager.DefaultWagonManager.putArtifact(DefaultWagonManager.java:160)
at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.deploy(DefaultArtifactDeployer.java:80)
... 10 more
Caused by: org.apache.maven.wagon.CommandExecutionException: Exit code 255 - Warning: Identity file /home/hudson/.ssh/id_rsa does not exist.
ssh: /home/hudson/.m2/repository/: Name or service not known

at org.apache.maven.wagon.providers.ssh.external.ScpExternalWagon.executeCommand(ScpExternalWagon.java:145)
at org.apache.maven.wagon.providers.ssh.external.ScpExternalWagon.executeCommand(ScpExternalWagon.java:326)
at org.apache.maven.wagon.providers.ssh.external.ScpExternalWagon.put(ScpExternalWagon.java:286)
... 13 more
finished: FAILURE


--
Gav...

www.minitutorials.com | www.brightoncomputers.com | www.iwdp.co.uk
Reply | Threaded
Open this post in threaded view
|

Re: Deploying to local Maven Repo problems

Kohsuke Kawaguchi
Administrator

I don't think this is a permission problem. Maven is complaining that
you don't seem to have a SSH private key.

Gav wrote:

> Hi All,
>
> Not wanting to hijack Toms similar thread ....
>
> I am using the 'Deploy to Maven Repository' feature, and
> deploying to the local copy using the path /home/hudson/.m2/repository/
>
> however I am getting builds fail using it, here is a snippet, showing I have
> some kind of permissions problem, is it Maven themselves doing this, do I
> need to get permission somehwere or do I set up my own permissions
>
> Thanks
>
> Deploying artifacts to /home/hudson/.m2/repository/
>
> Deploying the main artifact shindig-common-1-SNAPSHOT.jar
> [INFO ] Retrieving previous build number from
> [INFO ] repository metadata for: 'snapshot org.apache.shindig:shindig-common:1-SNAPSHOT' could not be found on repository: , so will be created
>
> ERROR: Error deploying artifact: Error executing command for transfer
> org.apache.maven.artifact.deployer.ArtifactDeploymentException: Error deploying artifact: Error executing command for transfer
> at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.deploy(DefaultArtifactDeployer.java:94)
>
> at hudson.maven.reporters.MavenArtifactRecord.deploy(MavenArtifactRecord.java:97)
> at hudson.maven.reporters.MavenAggregatedArtifactRecord.deploy(MavenAggregatedArtifactRecord.java:56)
> at hudson.maven.RedeployPublisher.perform(RedeployPublisher.java:67)
>
> at hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:309)
> at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:434)
> at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:282)
>
> at hudson.model.Run.run(Run.java:796)
> at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:202)
> at hudson.model.ResourceController.execute(ResourceController.java:70)
> at hudson.model.Executor.run(Executor.java:85)
>
> Caused by: org.apache.maven.wagon.TransferFailedException: Error executing command for transfer
> at org.apache.maven.wagon.providers.ssh.external.ScpExternalWagon.put(ScpExternalWagon.java:290)
> at org.apache.maven.artifact.manager.DefaultWagonManager.putRemoteFile(DefaultWagonManager.java:244)
>
> at org.apache.maven.artifact.manager.DefaultWagonManager.putArtifact(DefaultWagonManager.java:160)
> at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.deploy(DefaultArtifactDeployer.java:80)
> ... 10 more
>
> Caused by: org.apache.maven.wagon.CommandExecutionException: Exit code 255 - Warning: Identity file /home/hudson/.ssh/id_rsa does not exist.
> ssh: /home/hudson/.m2/repository/: Name or service not known
>
> at org.apache.maven.wagon.providers.ssh.external.ScpExternalWagon.executeCommand(ScpExternalWagon.java:145)
>
> at org.apache.maven.wagon.providers.ssh.external.ScpExternalWagon.executeCommand(ScpExternalWagon.java:326)
> at org.apache.maven.wagon.providers.ssh.external.ScpExternalWagon.put(ScpExternalWagon.java:286)
> ... 13 more
>
> finished: FAILURE
>
>
>
> --
> Gav...
>
> www.minitutorials.com <http://www.minitutorials.com> |
> www.brightoncomputers.com <http://www.brightoncomputers.com> |
> www.iwdp.co.uk <http://www.iwdp.co.uk>

--
Kohsuke Kawaguchi
Sun Microsystems                   [hidden email]

smime.p7s (4K) Download Attachment