Disappearing "Build with parameters" link for multi-branch pipeline job?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Disappearing "Build with parameters" link for multi-branch pipeline job?

ZillaYT
I know that this is a known bug where I have a multi-branch pipeline job that has the following properties block, and the "Build with parameters" link shows up, I run the job, it succeeds, and the the "Build with parameters" link disappears with only the "Build now" link, which I run, and fails, and then the "Build with parameters" link shows up again.

properties([

 parameters([

   string(name: 'GIT_BRANCH', defaultValue: 'feature/dev-26387-split-micro-deploy', description: 'zift-infrastructure branch to use'),

   booleanParam(name: 'RUN_TESTS', defaultValue: true, description: 'Boolean whether to run unit tests or not'),

   booleanParam(name: 'DEPLOY_TO_SANDBOX', defaultValue: true, description: 'Boolean whether to deploy to sandbox or not')

 ])

])


Any workaround for this bug? I have not seen one online, or maybe I missed it?

Thanks,
Chris

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/28273d69-c4d6-4ca5-bd5b-1a08cdf5d54a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.