Existing credentials are not available for multi-branch jobs

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Existing credentials are not available for multi-branch jobs

itchymuzzle

Don’t understand, do I need to create new ones? 

 

When creating pipeline job all the credentials which I have, are available to use.   The one named “git” in the screen shot is the one for Bitbucket.


But when I create a multi-branch project there are no credentials offered in the drop-down. 

 

          

Jenkins v2.79 AWS EC2 Linux instances for both master and node, Bitbucket for Git

 

I tried asking this question a couple of weeks ago here, but got myself off track so starting over.

[https://groups.google.com/d/msg/jenkinsci-users/1Y4bCyqfuF0/FYLAUc7iCgAJ]


Thanks

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/0dcfb475-ca20-4386-a145-d6660df77018%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Existing credentials are not available for multi-branch jobs

stephenconnolly
As before:

This only accepts username/password credentials as it accesses the Bitbucket api (which is https and http doesn’t understand ssh keys)

The password doesn’t have to be a password, it can be an api token... but the credentials must be of type username password


On Mon 20 Nov 2017 at 20:12, itchymuzzle <[hidden email]> wrote:

Don’t understand, do I need to create new ones? 

 

When creating pipeline job all the credentials which I have, are available to use.   The one named “git” in the screen shot is the one for Bitbucket.


But when I create a multi-branch project there are no credentials offered in the drop-down. 

 

          

Jenkins v2.79 AWS EC2 Linux instances for both master and node, Bitbucket for Git

 

I tried asking this question a couple of weeks ago here, but got myself off track so starting over.

[https://groups.google.com/d/msg/jenkinsci-users/1Y4bCyqfuF0/FYLAUc7iCgAJ]


Thanks

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/0dcfb475-ca20-4386-a145-d6660df77018%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
--
Sent from my phone

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CA%2BnPnMwybBAutABRSM2r3h1p7e7JQu_7TtRfRoHam%2Bf0tRQ%2BxQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Existing credentials are not available for multi-branch jobs

itchymuzzle
Ok, so attempting with my username and password I this message.  It appears under the Repo Name drop-down, and there are no selections in the drop-down.  I have admin permissions on this account.  

The selected credentials do not have permission to determine whether <username> does ordoes not exist.

And ya, there is no space in "ordoes".  

Atlassian does this thing where I login using my Google password.  Not sure it that could be confusing things.





--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/4344ac15-0f73-427d-bb3c-fd3e54d764fb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Existing credentials are not available for multi-branch jobs

itchymuzzle
Attempting to use username and app password I get the error.

 Could not find: <username>

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/0402aad5-652e-4b78-946d-8b5527211142%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Existing credentials are not available for multi-branch jobs

itchymuzzle
Looking at the documentation [https://go.cloudbees.com/docs/cloudbees-documentation/cje-user-guide/index.html#bitbucket]

It doesn't mention what permissions to select when creating an app password.  

It also says there are two credentials needed, one for scan and another for checkout.  And their screen shot shows that.  But that appears to be out of date.  I have the latest version of the plugin and it is only is asking for one credential.

Thanks.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/7973062c-c429-4e7d-83fa-d52da2f36031%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Existing credentials are not available for multi-branch jobs

stephenconnolly
On 21 November 2017 at 16:34, itchymuzzle <[hidden email]> wrote:
Looking at the documentation [https://go.cloudbees.com/docs/cloudbees-documentation/cje-user-guide/index.html#bitbucket]

It doesn't mention what permissions to select when creating an app password.  

Suck it and see... try with everything and then step back until you find something that doesn't work
 

It also says there are two credentials needed, one for scan and another for checkout.  And their screen shot shows that.  But that appears to be out of date.  I have the latest version of the plugin and it is only is asking for one credential.

The UI was updated in 2.2.0. What was "Scan credentials" is now just "Credentials"

What was "Checkout credentials" is now in the "Additional Behaviour" called "Checkout over SSH" (the reason for this change is that the only time you would specify different checkout credentials from the scan credentials is if you wanted to force the checkout to use SSH)

 

Thanks.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/7973062c-c429-4e7d-83fa-d52da2f36031%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CA%2BnPnMx%3DiyAu1DaCZKkkWXc%3DtJjqbnbkrmjN8MA4y0Dm9HwW-g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Existing credentials are not available for multi-branch jobs

itchymuzzle
> Suck it and see...
Ha!

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/4f225030-5f28-4eb0-832e-f4264f0850a9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Existing credentials are not available for multi-branch jobs

itchymuzzle
Still no luck using password or app password.  Guess I need to go back to Git plugin for now. 

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/65e0e945-f34b-4686-98c3-ba80df0b9388%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.