Getting issues with parent tag in pom.xml

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Getting issues with parent tag in pom.xml

phanikumar
Hello team,

I am developing a plugin where I have generated the source using maven command

mvn hpi:create

I have imported the project to eclipse using import option. When I observe the pom.xml it is showing error for

<parent>
    <groupId>org.jenkins-ci.plugins</groupId>
    <artifactId>plugin</artifactId>
    <version>2.28</version>
    <relativePath/>
</parent>

Plugin execution not covered by lifecycle configuration: org.apache.maven.plugins:maven-javadoc-plugin:2.10.4:javadoc (execution: default, phase: process-sources)


If I am changing the version to

<parent>
    <groupId>org.jenkins-ci.plugins</groupId>
    <artifactId>plugin</artifactId>
    <version>1.609</version>
    <relativePath/>
  </parent>

I am observing no error in the file. Can someone help me out on this?
Reply | Threaded
Open this post in threaded view
|

Re: Getting issues with parent tag in pom.xml

Jesse Glick-4
On Wed, Aug 16, 2017 at 11:18 AM, phanikumar
<[hidden email]> wrote:
> I have imported the project to eclipse using import option. When I observe
> the pom.xml it is showing error

Can you just ignore the error? That is some Eclipse thing.
Command-line builds should be fine, as should opening the project in
other IDEs (IDEA, NetBeans).

I know there are some Jenkins devs using Eclipse, perhaps they can
contribute a PR to `plugin-pom` to update the m2e configuration.

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/CANfRfr3yPJsm%3DwPfWdwA5Z9kzxtdxBTYVM1otv8bCta7GheO4Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Getting issues with parent tag in pom.xml

phanikumar
Thank you.