Grails plugin not available in new Jenkins versions?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Grails plugin not available in new Jenkins versions?

Carina Marban
Hi,


I'm currently trying to migrate our jobs from a Jenkins 1.650 instance
to a new one that we just updated to 2.56. Unfortunately, I seem unable 
to install the Grails plugin: https://wiki.jenkins-ci.org/display/JENKINS/Grails+Plugin 
because it is not in the list of available plugins. 
I also can't find it on https://plugins.jenkins.io

Am I correct to assume that the Grails plugin is not available anymore in more recent 
versions of Jenkins? Since it is quite central to our process, that would unfortunately 
mean that I will have to downgrade to an older version of Jenkins. Is there any way 
I can find out which is the most recent version of Jenkins that still supports the plugin?

I saw the discussions in the Jenkins Developers user group about the plugin 
not having any active maintainers anymore. Is it really dead? I know that there
is not a huge number of projects that are actively using Grails but I am 
still a bit surprised (and sad) about this.

Am I maybe just missing something?


Thanks in advance,
Carina

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/9501902e-3229-4c89-8bd8-d0ad95258f38%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails plugin not available in new Jenkins versions?

Chris Peck
I'm having the same issue with the current LTS release 2.46.2. Does anyone know how to install it?


On Monday, April 24, 2017 at 2:46:40 PM UTC-4, Carina Marban wrote:
Hi,


I'm currently trying to migrate our jobs from a Jenkins 1.650 instance
to a new one that we just updated to 2.56. Unfortunately, I seem unable 
to install the Grails plugin: <a href="https://wiki.jenkins-ci.org/display/JENKINS/Grails+Plugin" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwiki.jenkins-ci.org%2Fdisplay%2FJENKINS%2FGrails%2BPlugin\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGBsetqOvo39Vmy4kJNEZuTjpC-Jg&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwiki.jenkins-ci.org%2Fdisplay%2FJENKINS%2FGrails%2BPlugin\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGBsetqOvo39Vmy4kJNEZuTjpC-Jg&#39;;return true;">https://wiki.jenkins-ci.org/display/JENKINS/Grails+Plugin 
because it is not in the list of available plugins. 
I also can't find it on <a href="https://plugins.jenkins.io" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fplugins.jenkins.io\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEFWjxYHSOYqeMz8wdwR-JplzCSsQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fplugins.jenkins.io\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEFWjxYHSOYqeMz8wdwR-JplzCSsQ&#39;;return true;">https://plugins.jenkins.io

Am I correct to assume that the Grails plugin is not available anymore in more recent 
versions of Jenkins? Since it is quite central to our process, that would unfortunately 
mean that I will have to downgrade to an older version of Jenkins. Is there any way 
I can find out which is the most recent version of Jenkins that still supports the plugin?

I saw the discussions in the Jenkins Developers user group about the plugin 
not having any active maintainers anymore. Is it really dead? I know that there
is not a huge number of projects that are actively using Grails but I am 
still a bit surprised (and sad) about this.

Am I maybe just missing something?


Thanks in advance,
Carina

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/ca81a7aa-1059-4458-9791-b6f2755a2f63%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails plugin not available in new Jenkins versions?

Juan Camilo Marín
Hi.

The plugin is not available because the new version of Jenkins may not be safe to use it, as you can see it the plugin is a bit old, the latest updated was in 2013,  so what you need to do is manually install it, you only need to copy the gradle.jpi from the old "/jenkins-installation-path/plugins" directory to the new one and then restart jenkins, then you can disable it the "Arbitrary code execution vulnerability" security warning in jenkins "configure global security" option.



On Friday, May 19, 2017 at 9:38:34 AM UTC-5, Chris Peck wrote:
I'm having the same issue with the current LTS release 2.46.2. Does anyone know how to install it?


On Monday, April 24, 2017 at 2:46:40 PM UTC-4, Carina Marban wrote:
Hi,


I'm currently trying to migrate our jobs from a Jenkins 1.650 instance
to a new one that we just updated to 2.56. Unfortunately, I seem unable 
to install the Grails plugin: <a href="https://wiki.jenkins-ci.org/display/JENKINS/Grails+Plugin" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwiki.jenkins-ci.org%2Fdisplay%2FJENKINS%2FGrails%2BPlugin\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGBsetqOvo39Vmy4kJNEZuTjpC-Jg&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwiki.jenkins-ci.org%2Fdisplay%2FJENKINS%2FGrails%2BPlugin\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGBsetqOvo39Vmy4kJNEZuTjpC-Jg&#39;;return true;">https://wiki.jenkins-ci.org/display/JENKINS/Grails+Plugin 
because it is not in the list of available plugins. 
I also can't find it on <a href="https://plugins.jenkins.io" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fplugins.jenkins.io\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEFWjxYHSOYqeMz8wdwR-JplzCSsQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fplugins.jenkins.io\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEFWjxYHSOYqeMz8wdwR-JplzCSsQ&#39;;return true;">https://plugins.jenkins.io

Am I correct to assume that the Grails plugin is not available anymore in more recent 
versions of Jenkins? Since it is quite central to our process, that would unfortunately 
mean that I will have to downgrade to an older version of Jenkins. Is there any way 
I can find out which is the most recent version of Jenkins that still supports the plugin?

I saw the discussions in the Jenkins Developers user group about the plugin 
not having any active maintainers anymore. Is it really dead? I know that there
is not a huge number of projects that are actively using Grails but I am 
still a bit surprised (and sad) about this.

Am I maybe just missing something?


Thanks in advance,
Carina

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/79815510-446c-4f9f-999d-b64ce5fe6b89%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Grails plugin not available in new Jenkins versions?

Mark Waite-2
Isn't grails a command line program that you could switch to invoke from a command line, rather than risking the security risks which come with you enable the grails plugin?

Mark Waite

On Fri, Jun 2, 2017 at 5:59 PM Juan Camilo Marín <[hidden email]> wrote:
Hi.

The plugin is not available because the new version of Jenkins may not be safe to use it, as you can see it the plugin is a bit old, the latest updated was in 2013,  so what you need to do is manually install it, you only need to copy the gradle.jpi from the old "/jenkins-installation-path/plugins" directory to the new one and then restart jenkins, then you can disable it the "Arbitrary code execution vulnerability" security warning in jenkins "configure global security" option.



On Friday, May 19, 2017 at 9:38:34 AM UTC-5, Chris Peck wrote:
I'm having the same issue with the current LTS release 2.46.2. Does anyone know how to install it?


On Monday, April 24, 2017 at 2:46:40 PM UTC-4, Carina Marban wrote:
Hi,


I'm currently trying to migrate our jobs from a Jenkins 1.650 instance
to a new one that we just updated to 2.56. Unfortunately, I seem unable 
because it is not in the list of available plugins. 
I also can't find it on https://plugins.jenkins.io

Am I correct to assume that the Grails plugin is not available anymore in more recent 
versions of Jenkins? Since it is quite central to our process, that would unfortunately 
mean that I will have to downgrade to an older version of Jenkins. Is there any way 
I can find out which is the most recent version of Jenkins that still supports the plugin?

I saw the discussions in the Jenkins Developers user group about the plugin 
not having any active maintainers anymore. Is it really dead? I know that there
is not a huge number of projects that are actively using Grails but I am 
still a bit surprised (and sad) about this.

Am I maybe just missing something?


Thanks in advance,
Carina

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/79815510-446c-4f9f-999d-b64ce5fe6b89%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CAO49JtFQObt9-%3DPZz14Qy_oHosgV7sJBHKBPMiQWH3p%3DKneV_Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.