Hudson Sonar Plugin

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

Hudson Sonar Plugin

Benjamin Lauener
Hey guys!

I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
The console output looks like this:  



D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
[INFO] Scanning for projects...
[WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).


Project ID: org.kohsuke.stapler:maven-stapler-plugin
POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom

Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom


[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2 seconds
[INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
[INFO] Final Memory: 5M/11M
[INFO] ------------------------------------------------------------------------



Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
Does anybody know what the problem is? I hope you can help me.
Thanks!

Greetings beni


Freundliche Grüsse
Benjamin Lauener
Praktikant

--
Unic AG | Eigerstrasse 60 | CH-3007 Bern
Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
* http://www.unic.com | [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Hudson Sonar Plugin

Evgeny Mandrikov
Hi,

It's a problem not with hudson-sonar-plugin. So I think it would be
better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
And ask questions in dev mailing list of Hudson:
[hidden email]

On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
<[hidden email]> wrote:

> Hey guys!
>
> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
> The console output looks like this:
>
>
>
> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
> [INFO] Scanning for projects...
> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>
> Its dependencies (if any) will NOT be available to the current build.
> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>
> Its dependencies (if any) will NOT be available to the current build.
> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>
> Its dependencies (if any) will NOT be available to the current build.
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Error building POM (may not be this project's POM).
>
>
> Project ID: org.kohsuke.stapler:maven-stapler-plugin
> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>
> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>
>
> [INFO] ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 2 seconds
> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
> [INFO] Final Memory: 5M/11M
> [INFO] ------------------------------------------------------------------------
>
>
>
> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
> Does anybody know what the problem is? I hope you can help me.
> Thanks!
>
> Greetings beni
>
>
> Freundliche Grüsse
> Benjamin Lauener
> Praktikant
>
> --
> Unic AG | Eigerstrasse 60 | CH-3007 Bern
> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
> * http://www.unic.com | [hidden email]
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>



--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Hudson Sonar Plugin

Evgeny Mandrikov
Oh, sorry - I've missed that you're already here :)

You have an issue with local maven repository, so could you please try
to remove incorrect.POMs before build in order to download them again?

On Tue, Jul 20, 2010 at 1:51 PM, Evgeny Mandrikov <[hidden email]> wrote:

> Hi,
>
> It's a problem not with hudson-sonar-plugin. So I think it would be
> better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
> And ask questions in dev mailing list of Hudson:
> [hidden email]
>
> On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
> <[hidden email]> wrote:
>> Hey guys!
>>
>> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
>> The console output looks like this:
>>
>>
>>
>> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>> [INFO] Scanning for projects...
>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [INFO] ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Error building POM (may not be this project's POM).
>>
>>
>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>>
>> [INFO] ------------------------------------------------------------------------
>> [INFO] For more information, run Maven with the -e switch
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Total time: 2 seconds
>> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
>> [INFO] Final Memory: 5M/11M
>> [INFO] ------------------------------------------------------------------------
>>
>>
>>
>> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
>> Does anybody know what the problem is? I hope you can help me.
>> Thanks!
>>
>> Greetings beni
>>
>>
>> Freundliche Grüsse
>> Benjamin Lauener
>> Praktikant
>>
>> --
>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>> * http://www.unic.com | [hidden email]
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>
>
>
> --
> Best regards,
> Evgeny Mandrikov aka Godin <http://godin.net.ru>
> http://twitter.com/_godin_
>



--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: Hudson Sonar Plugin

Benjamin Lauener
I deleted all incorrect POMs:

maven-stapler-plugin
wagon-svn
javanettasks

but after downloading them again I get the same error.
Do you have another idea what could be wrong here?

Thanks!


Freundliche Grüsse
Benjamin Lauener
Praktikant

--
Unic AG | Eigerstrasse 60 | CH-3007 Bern
Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
* http://www.unic.com | [hidden email]

-----Original Message-----
From: Evgeny Mandrikov [mailto:[hidden email]]
Sent: Dienstag, 20. Juli 2010 11:55
To: [hidden email]
Subject: Re: Hudson Sonar Plugin

Oh, sorry - I've missed that you're already here :)

You have an issue with local maven repository, so could you please try
to remove incorrect.POMs before build in order to download them again?

On Tue, Jul 20, 2010 at 1:51 PM, Evgeny Mandrikov <[hidden email]> wrote:

> Hi,
>
> It's a problem not with hudson-sonar-plugin. So I think it would be
> better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
> And ask questions in dev mailing list of Hudson:
> [hidden email]
>
> On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
> <[hidden email]> wrote:
>> Hey guys!
>>
>> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
>> The console output looks like this:
>>
>>
>>
>> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>> [INFO] Scanning for projects...
>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [INFO] ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Error building POM (may not be this project's POM).
>>
>>
>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>>
>> [INFO] ------------------------------------------------------------------------
>> [INFO] For more information, run Maven with the -e switch
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Total time: 2 seconds
>> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
>> [INFO] Final Memory: 5M/11M
>> [INFO] ------------------------------------------------------------------------
>>
>>
>>
>> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
>> Does anybody know what the problem is? I hope you can help me.
>> Thanks!
>>
>> Greetings beni
>>
>>
>> Freundliche Grüsse
>> Benjamin Lauener
>> Praktikant
>>
>> --
>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>> * http://www.unic.com | [hidden email]
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>
>
>
> --
> Best regards,
> Evgeny Mandrikov aka Godin <http://godin.net.ru>
> http://twitter.com/_godin_
>



--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

FW: Hudson Sonar Plugin

Benjamin Lauener
In reply to this post by Benjamin Lauener
Here ist he console output with stacktraces turned on, maybe you get any idea what is wrong ;)


D:\svn\external\Hudson\Plugins\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
+ Error stacktraces are turned on.
[INFO] Scanning for projects...
[WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.

Its dependencies (if any) will NOT be available to the current build.
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).


Project ID: org.kohsuke.stapler:maven-stapler-plugin
POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom

Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom


[INFO] ------------------------------------------------------------------------
[INFO] Trace
org.apache.maven.lifecycle.LifecycleExecutionException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1599)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findArtifactTypeHandlersInPlugins(DefaultLifecycleExecutor.java:1468)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:222)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:178)
        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:293)
        at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:205)
        at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:184)
        at org.apache.maven.plugin.DefaultPluginManager.loadPluginFully(DefaultPluginManager.java:1626)
        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1582)
        ... 15 more
Caused by: org.apache.maven.project.InvalidProjectModelException: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1599)
        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1571)
        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:562)
        at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)
        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:277)
        ... 19 more
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2 seconds
[INFO] Finished at: Tue Jul 20 13:05:24 CEST 2010
[INFO] Final Memory: 5M/12M
[INFO] ------------------------------------------------------------------------



Greetings beni

Freundliche Grüsse
Benjamin Lauener
Praktikant

--
Unic AG | Eigerstrasse 60 | CH-3007 Bern
Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
* http://www.unic.com | [hidden email]

-----Original Message-----
From: Benjamin Lauener
Sent: Dienstag, 20. Juli 2010 12:02
To: '[hidden email]'
Subject: RE: Hudson Sonar Plugin

I deleted all incorrect POMs:

maven-stapler-plugin
wagon-svn
javanettasks

but after downloading them again I get the same error.
Do you have another idea what could be wrong here?

Thanks!


Freundliche Grüsse
Benjamin Lauener
Praktikant

--
Unic AG | Eigerstrasse 60 | CH-3007 Bern
Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
* http://www.unic.com | [hidden email]

-----Original Message-----
From: Evgeny Mandrikov [mailto:[hidden email]]
Sent: Dienstag, 20. Juli 2010 11:55
To: [hidden email]
Subject: Re: Hudson Sonar Plugin

Oh, sorry - I've missed that you're already here :)

You have an issue with local maven repository, so could you please try
to remove incorrect.POMs before build in order to download them again?

On Tue, Jul 20, 2010 at 1:51 PM, Evgeny Mandrikov <[hidden email]> wrote:

> Hi,
>
> It's a problem not with hudson-sonar-plugin. So I think it would be
> better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
> And ask questions in dev mailing list of Hudson:
> [hidden email]
>
> On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
> <[hidden email]> wrote:
>> Hey guys!
>>
>> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
>> The console output looks like this:
>>
>>
>>
>> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>> [INFO] Scanning for projects...
>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [INFO] ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Error building POM (may not be this project's POM).
>>
>>
>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>>
>> [INFO] ------------------------------------------------------------------------
>> [INFO] For more information, run Maven with the -e switch
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Total time: 2 seconds
>> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
>> [INFO] Final Memory: 5M/11M
>> [INFO] ------------------------------------------------------------------------
>>
>>
>>
>> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
>> Does anybody know what the problem is? I hope you can help me.
>> Thanks!
>>
>> Greetings beni
>>
>>
>> Freundliche Grüsse
>> Benjamin Lauener
>> Praktikant
>>
>> --
>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>> * http://www.unic.com | [hidden email]
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>
>
>
> --
> Best regards,
> Evgeny Mandrikov aka Godin <http://godin.net.ru>
> http://twitter.com/_godin_
>



--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: FW: Hudson Sonar Plugin

Evgeny Mandrikov
Could you please provide content of one of this POMs?

On Tue, Jul 20, 2010 at 3:07 PM, Benjamin Lauener
<[hidden email]> wrote:

> Here ist he console output with stacktraces turned on, maybe you get any idea what is wrong ;)
>
>
> D:\svn\external\Hudson\Plugins\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
> + Error stacktraces are turned on.
> [INFO] Scanning for projects...
> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>
> Its dependencies (if any) will NOT be available to the current build.
> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>
> Its dependencies (if any) will NOT be available to the current build.
> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>
> Its dependencies (if any) will NOT be available to the current build.
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Error building POM (may not be this project's POM).
>
>
> Project ID: org.kohsuke.stapler:maven-stapler-plugin
> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>
> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>
>
> [INFO] ------------------------------------------------------------------------
> [INFO] Trace
> org.apache.maven.lifecycle.LifecycleExecutionException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1599)
>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findArtifactTypeHandlersInPlugins(DefaultLifecycleExecutor.java:1468)
>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:222)
>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:178)
>        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
>        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
>        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
>        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>        at java.lang.reflect.Method.invoke(Method.java:597)
>        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:293)
>        at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:205)
>        at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:184)
>        at org.apache.maven.plugin.DefaultPluginManager.loadPluginFully(DefaultPluginManager.java:1626)
>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1582)
>        ... 15 more
> Caused by: org.apache.maven.project.InvalidProjectModelException: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1599)
>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1571)
>        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:562)
>        at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)
>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:277)
>        ... 19 more
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 2 seconds
> [INFO] Finished at: Tue Jul 20 13:05:24 CEST 2010
> [INFO] Final Memory: 5M/12M
> [INFO] ------------------------------------------------------------------------
>
>
>
> Greetings beni
>
> Freundliche Grüsse
> Benjamin Lauener
> Praktikant
>
> --
> Unic AG | Eigerstrasse 60 | CH-3007 Bern
> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
> * http://www.unic.com | [hidden email]
>
> -----Original Message-----
> From: Benjamin Lauener
> Sent: Dienstag, 20. Juli 2010 12:02
> To: '[hidden email]'
> Subject: RE: Hudson Sonar Plugin
>
> I deleted all incorrect POMs:
>
> maven-stapler-plugin
> wagon-svn
> javanettasks
>
> but after downloading them again I get the same error.
> Do you have another idea what could be wrong here?
>
> Thanks!
>
>
> Freundliche Grüsse
> Benjamin Lauener
> Praktikant
>
> --
> Unic AG | Eigerstrasse 60 | CH-3007 Bern
> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
> * http://www.unic.com | [hidden email]
>
> -----Original Message-----
> From: Evgeny Mandrikov [mailto:[hidden email]]
> Sent: Dienstag, 20. Juli 2010 11:55
> To: [hidden email]
> Subject: Re: Hudson Sonar Plugin
>
> Oh, sorry - I've missed that you're already here :)
>
> You have an issue with local maven repository, so could you please try
> to remove incorrect.POMs before build in order to download them again?
>
> On Tue, Jul 20, 2010 at 1:51 PM, Evgeny Mandrikov <[hidden email]> wrote:
>> Hi,
>>
>> It's a problem not with hudson-sonar-plugin. So I think it would be
>> better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
>> And ask questions in dev mailing list of Hudson:
>> [hidden email]
>>
>> On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
>> <[hidden email]> wrote:
>>> Hey guys!
>>>
>>> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
>>> The console output looks like this:
>>>
>>>
>>>
>>> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>> [INFO] Scanning for projects...
>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>
>>> Its dependencies (if any) will NOT be available to the current build.
>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>
>>> Its dependencies (if any) will NOT be available to the current build.
>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>
>>> Its dependencies (if any) will NOT be available to the current build.
>>> [INFO] ------------------------------------------------------------------------
>>> [ERROR] BUILD ERROR
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Error building POM (may not be this project's POM).
>>>
>>>
>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>
>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>
>>>
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] For more information, run Maven with the -e switch
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Total time: 2 seconds
>>> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
>>> [INFO] Final Memory: 5M/11M
>>> [INFO] ------------------------------------------------------------------------
>>>
>>>
>>>
>>> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
>>> Does anybody know what the problem is? I hope you can help me.
>>> Thanks!
>>>
>>> Greetings beni
>>>
>>>
>>> Freundliche Grüsse
>>> Benjamin Lauener
>>> Praktikant
>>>
>>> --
>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>> * http://www.unic.com | [hidden email]
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>>
>>
>>
>>
>> --
>> Best regards,
>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>> http://twitter.com/_godin_
>>
>
>
>
> --
> Best regards,
> Evgeny Mandrikov aka Godin <http://godin.net.ru>
> http://twitter.com/_godin_
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>



--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: FW: Hudson Sonar Plugin

Benjamin Lauener
Sure, i attached three poms.
Sonar_pom
Plugins_pom is parent of sonar_pom.
Main_pom is parent of plugins_pom.

But the strange thing is that I already setup a new Hudson plugin with: "mvn -cpu hpi:create" and tried to do a mvn install after that. But that gave me the same error. I think it is a configurations problem. What do you think?

Freundliche Grüsse
Benjamin Lauener
Praktikant

--
Unic AG | Eigerstrasse 60 | CH-3007 Bern
Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
* http://www.unic.com | [hidden email]

-----Original Message-----
From: Evgeny Mandrikov [mailto:[hidden email]]
Sent: Dienstag, 20. Juli 2010 13:24
To: [hidden email]
Subject: Re: FW: Hudson Sonar Plugin

Could you please provide content of one of this POMs?

On Tue, Jul 20, 2010 at 3:07 PM, Benjamin Lauener
<[hidden email]> wrote:

> Here ist he console output with stacktraces turned on, maybe you get any idea what is wrong ;)
>
>
> D:\svn\external\Hudson\Plugins\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
> + Error stacktraces are turned on.
> [INFO] Scanning for projects...
> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>
> Its dependencies (if any) will NOT be available to the current build.
> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>
> Its dependencies (if any) will NOT be available to the current build.
> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>
> Its dependencies (if any) will NOT be available to the current build.
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Error building POM (may not be this project's POM).
>
>
> Project ID: org.kohsuke.stapler:maven-stapler-plugin
> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>
> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>
>
> [INFO] ------------------------------------------------------------------------
> [INFO] Trace
> org.apache.maven.lifecycle.LifecycleExecutionException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1599)
>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findArtifactTypeHandlersInPlugins(DefaultLifecycleExecutor.java:1468)
>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:222)
>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:178)
>        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
>        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
>        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
>        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>        at java.lang.reflect.Method.invoke(Method.java:597)
>        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:293)
>        at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:205)
>        at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:184)
>        at org.apache.maven.plugin.DefaultPluginManager.loadPluginFully(DefaultPluginManager.java:1626)
>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1582)
>        ... 15 more
> Caused by: org.apache.maven.project.InvalidProjectModelException: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1599)
>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1571)
>        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:562)
>        at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)
>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:277)
>        ... 19 more
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 2 seconds
> [INFO] Finished at: Tue Jul 20 13:05:24 CEST 2010
> [INFO] Final Memory: 5M/12M
> [INFO] ------------------------------------------------------------------------
>
>
>
> Greetings beni
>
> Freundliche Grüsse
> Benjamin Lauener
> Praktikant
>
> --
> Unic AG | Eigerstrasse 60 | CH-3007 Bern
> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
> * http://www.unic.com | [hidden email]
>
> -----Original Message-----
> From: Benjamin Lauener
> Sent: Dienstag, 20. Juli 2010 12:02
> To: '[hidden email]'
> Subject: RE: Hudson Sonar Plugin
>
> I deleted all incorrect POMs:
>
> maven-stapler-plugin
> wagon-svn
> javanettasks
>
> but after downloading them again I get the same error.
> Do you have another idea what could be wrong here?
>
> Thanks!
>
>
> Freundliche Grüsse
> Benjamin Lauener
> Praktikant
>
> --
> Unic AG | Eigerstrasse 60 | CH-3007 Bern
> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
> * http://www.unic.com | [hidden email]
>
> -----Original Message-----
> From: Evgeny Mandrikov [mailto:[hidden email]]
> Sent: Dienstag, 20. Juli 2010 11:55
> To: [hidden email]
> Subject: Re: Hudson Sonar Plugin
>
> Oh, sorry - I've missed that you're already here :)
>
> You have an issue with local maven repository, so could you please try
> to remove incorrect.POMs before build in order to download them again?
>
> On Tue, Jul 20, 2010 at 1:51 PM, Evgeny Mandrikov <[hidden email]> wrote:
>> Hi,
>>
>> It's a problem not with hudson-sonar-plugin. So I think it would be
>> better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
>> And ask questions in dev mailing list of Hudson:
>> [hidden email]
>>
>> On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
>> <[hidden email]> wrote:
>>> Hey guys!
>>>
>>> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
>>> The console output looks like this:
>>>
>>>
>>>
>>> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>> [INFO] Scanning for projects...
>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>
>>> Its dependencies (if any) will NOT be available to the current build.
>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>
>>> Its dependencies (if any) will NOT be available to the current build.
>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>
>>> Its dependencies (if any) will NOT be available to the current build.
>>> [INFO] ------------------------------------------------------------------------
>>> [ERROR] BUILD ERROR
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Error building POM (may not be this project's POM).
>>>
>>>
>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>
>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>
>>>
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] For more information, run Maven with the -e switch
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Total time: 2 seconds
>>> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
>>> [INFO] Final Memory: 5M/11M
>>> [INFO] ------------------------------------------------------------------------
>>>
>>>
>>>
>>> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
>>> Does anybody know what the problem is? I hope you can help me.
>>> Thanks!
>>>
>>> Greetings beni
>>>
>>>
>>> Freundliche Grüsse
>>> Benjamin Lauener
>>> Praktikant
>>>
>>> --
>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>> * http://www.unic.com | [hidden email]
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>>
>>
>>
>>
>> --
>> Best regards,
>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>> http://twitter.com/_godin_
>>
>
>
>
> --
> Best regards,
> Evgeny Mandrikov aka Godin <http://godin.net.ru>
> http://twitter.com/_godin_
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

main_pom.xml (7K) Download Attachment
plugins_pom.xml (17K) Download Attachment
sonar_pom.xml (6K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: FW: Hudson Sonar Plugin

Evgeny Mandrikov
Actually I've asked about this file:
d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom

On Tue, Jul 20, 2010 at 3:30 PM, Benjamin Lauener
<[hidden email]> wrote:

> Sure, i attached three poms.
> Sonar_pom
> Plugins_pom is parent of sonar_pom.
> Main_pom is parent of plugins_pom.
>
> But the strange thing is that I already setup a new Hudson plugin with: "mvn -cpu hpi:create" and tried to do a mvn install after that. But that gave me the same error. I think it is a configurations problem. What do you think?
>
> Freundliche Grüsse
> Benjamin Lauener
> Praktikant
>
> --
> Unic AG | Eigerstrasse 60 | CH-3007 Bern
> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
> * http://www.unic.com | [hidden email]
>
> -----Original Message-----
> From: Evgeny Mandrikov [mailto:[hidden email]]
> Sent: Dienstag, 20. Juli 2010 13:24
> To: [hidden email]
> Subject: Re: FW: Hudson Sonar Plugin
>
> Could you please provide content of one of this POMs?
>
> On Tue, Jul 20, 2010 at 3:07 PM, Benjamin Lauener
> <[hidden email]> wrote:
>> Here ist he console output with stacktraces turned on, maybe you get any idea what is wrong ;)
>>
>>
>> D:\svn\external\Hudson\Plugins\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>> + Error stacktraces are turned on.
>> [INFO] Scanning for projects...
>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [INFO] ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Error building POM (may not be this project's POM).
>>
>>
>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>>
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Trace
>> org.apache.maven.lifecycle.LifecycleExecutionException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1599)
>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findArtifactTypeHandlersInPlugins(DefaultLifecycleExecutor.java:1468)
>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:222)
>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:178)
>>        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
>>        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
>>        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
>>        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
>>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>        at java.lang.reflect.Method.invoke(Method.java:597)
>>        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>>        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>>        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>>        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
>> Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:293)
>>        at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:205)
>>        at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:184)
>>        at org.apache.maven.plugin.DefaultPluginManager.loadPluginFully(DefaultPluginManager.java:1626)
>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1582)
>>        ... 15 more
>> Caused by: org.apache.maven.project.InvalidProjectModelException: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1599)
>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1571)
>>        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:562)
>>        at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)
>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:277)
>>        ... 19 more
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Total time: 2 seconds
>> [INFO] Finished at: Tue Jul 20 13:05:24 CEST 2010
>> [INFO] Final Memory: 5M/12M
>> [INFO] ------------------------------------------------------------------------
>>
>>
>>
>> Greetings beni
>>
>> Freundliche Grüsse
>> Benjamin Lauener
>> Praktikant
>>
>> --
>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>> * http://www.unic.com | [hidden email]
>>
>> -----Original Message-----
>> From: Benjamin Lauener
>> Sent: Dienstag, 20. Juli 2010 12:02
>> To: '[hidden email]'
>> Subject: RE: Hudson Sonar Plugin
>>
>> I deleted all incorrect POMs:
>>
>> maven-stapler-plugin
>> wagon-svn
>> javanettasks
>>
>> but after downloading them again I get the same error.
>> Do you have another idea what could be wrong here?
>>
>> Thanks!
>>
>>
>> Freundliche Grüsse
>> Benjamin Lauener
>> Praktikant
>>
>> --
>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>> * http://www.unic.com | [hidden email]
>>
>> -----Original Message-----
>> From: Evgeny Mandrikov [mailto:[hidden email]]
>> Sent: Dienstag, 20. Juli 2010 11:55
>> To: [hidden email]
>> Subject: Re: Hudson Sonar Plugin
>>
>> Oh, sorry - I've missed that you're already here :)
>>
>> You have an issue with local maven repository, so could you please try
>> to remove incorrect.POMs before build in order to download them again?
>>
>> On Tue, Jul 20, 2010 at 1:51 PM, Evgeny Mandrikov <[hidden email]> wrote:
>>> Hi,
>>>
>>> It's a problem not with hudson-sonar-plugin. So I think it would be
>>> better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
>>> And ask questions in dev mailing list of Hudson:
>>> [hidden email]
>>>
>>> On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
>>> <[hidden email]> wrote:
>>>> Hey guys!
>>>>
>>>> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
>>>> The console output looks like this:
>>>>
>>>>
>>>>
>>>> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>>> [INFO] Scanning for projects...
>>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [INFO] ------------------------------------------------------------------------
>>>> [ERROR] BUILD ERROR
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Error building POM (may not be this project's POM).
>>>>
>>>>
>>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>
>>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>
>>>>
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] For more information, run Maven with the -e switch
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Total time: 2 seconds
>>>> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
>>>> [INFO] Final Memory: 5M/11M
>>>> [INFO] ------------------------------------------------------------------------
>>>>
>>>>
>>>>
>>>> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
>>>> Does anybody know what the problem is? I hope you can help me.
>>>> Thanks!
>>>>
>>>> Greetings beni
>>>>
>>>>
>>>> Freundliche Grüsse
>>>> Benjamin Lauener
>>>> Praktikant
>>>>
>>>> --
>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>> * http://www.unic.com | [hidden email]
>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>>>
>>>
>>>
>>>
>>> --
>>> Best regards,
>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>> http://twitter.com/_godin_
>>>
>>
>>
>>
>> --
>> Best regards,
>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>> http://twitter.com/_godin_
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>
>
>
> --
> Best regards,
> Evgeny Mandrikov aka Godin <http://godin.net.ru>
> http://twitter.com/_godin_
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>



--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: FW: Hudson Sonar Plugin

Benjamin Lauener
Ah ok sorry :)

I also tried to extract the jar file but it seems that the jar is corrupt. Anyway, I attached the maven-stapler-plugin-1.12.pom

Thanks man!


Freundliche Grüsse
Benjamin Lauener
Praktikant

--
Unic AG | Eigerstrasse 60 | CH-3007 Bern
Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
* http://www.unic.com | [hidden email]

-----Original Message-----
From: Evgeny Mandrikov [mailto:[hidden email]]
Sent: Dienstag, 20. Juli 2010 13:32
To: [hidden email]
Subject: Re: FW: Hudson Sonar Plugin

Actually I've asked about this file:
d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom

On Tue, Jul 20, 2010 at 3:30 PM, Benjamin Lauener
<[hidden email]> wrote:

> Sure, i attached three poms.
> Sonar_pom
> Plugins_pom is parent of sonar_pom.
> Main_pom is parent of plugins_pom.
>
> But the strange thing is that I already setup a new Hudson plugin with: "mvn -cpu hpi:create" and tried to do a mvn install after that. But that gave me the same error. I think it is a configurations problem. What do you think?
>
> Freundliche Grüsse
> Benjamin Lauener
> Praktikant
>
> --
> Unic AG | Eigerstrasse 60 | CH-3007 Bern
> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
> * http://www.unic.com | [hidden email]
>
> -----Original Message-----
> From: Evgeny Mandrikov [mailto:[hidden email]]
> Sent: Dienstag, 20. Juli 2010 13:24
> To: [hidden email]
> Subject: Re: FW: Hudson Sonar Plugin
>
> Could you please provide content of one of this POMs?
>
> On Tue, Jul 20, 2010 at 3:07 PM, Benjamin Lauener
> <[hidden email]> wrote:
>> Here ist he console output with stacktraces turned on, maybe you get any idea what is wrong ;)
>>
>>
>> D:\svn\external\Hudson\Plugins\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>> + Error stacktraces are turned on.
>> [INFO] Scanning for projects...
>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>
>> Its dependencies (if any) will NOT be available to the current build.
>> [INFO] ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Error building POM (may not be this project's POM).
>>
>>
>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>>
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Trace
>> org.apache.maven.lifecycle.LifecycleExecutionException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1599)
>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findArtifactTypeHandlersInPlugins(DefaultLifecycleExecutor.java:1468)
>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:222)
>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:178)
>>        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
>>        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
>>        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
>>        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
>>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>        at java.lang.reflect.Method.invoke(Method.java:597)
>>        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>>        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>>        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>>        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
>> Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:293)
>>        at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:205)
>>        at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:184)
>>        at org.apache.maven.plugin.DefaultPluginManager.loadPluginFully(DefaultPluginManager.java:1626)
>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1582)
>>        ... 15 more
>> Caused by: org.apache.maven.project.InvalidProjectModelException: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1599)
>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1571)
>>        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:562)
>>        at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)
>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:277)
>>        ... 19 more
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Total time: 2 seconds
>> [INFO] Finished at: Tue Jul 20 13:05:24 CEST 2010
>> [INFO] Final Memory: 5M/12M
>> [INFO] ------------------------------------------------------------------------
>>
>>
>>
>> Greetings beni
>>
>> Freundliche Grüsse
>> Benjamin Lauener
>> Praktikant
>>
>> --
>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>> * http://www.unic.com | [hidden email]
>>
>> -----Original Message-----
>> From: Benjamin Lauener
>> Sent: Dienstag, 20. Juli 2010 12:02
>> To: '[hidden email]'
>> Subject: RE: Hudson Sonar Plugin
>>
>> I deleted all incorrect POMs:
>>
>> maven-stapler-plugin
>> wagon-svn
>> javanettasks
>>
>> but after downloading them again I get the same error.
>> Do you have another idea what could be wrong here?
>>
>> Thanks!
>>
>>
>> Freundliche Grüsse
>> Benjamin Lauener
>> Praktikant
>>
>> --
>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>> * http://www.unic.com | [hidden email]
>>
>> -----Original Message-----
>> From: Evgeny Mandrikov [mailto:[hidden email]]
>> Sent: Dienstag, 20. Juli 2010 11:55
>> To: [hidden email]
>> Subject: Re: Hudson Sonar Plugin
>>
>> Oh, sorry - I've missed that you're already here :)
>>
>> You have an issue with local maven repository, so could you please try
>> to remove incorrect.POMs before build in order to download them again?
>>
>> On Tue, Jul 20, 2010 at 1:51 PM, Evgeny Mandrikov <[hidden email]> wrote:
>>> Hi,
>>>
>>> It's a problem not with hudson-sonar-plugin. So I think it would be
>>> better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
>>> And ask questions in dev mailing list of Hudson:
>>> [hidden email]
>>>
>>> On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
>>> <[hidden email]> wrote:
>>>> Hey guys!
>>>>
>>>> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
>>>> The console output looks like this:
>>>>
>>>>
>>>>
>>>> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>>> [INFO] Scanning for projects...
>>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [INFO] ------------------------------------------------------------------------
>>>> [ERROR] BUILD ERROR
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Error building POM (may not be this project's POM).
>>>>
>>>>
>>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>
>>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>
>>>>
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] For more information, run Maven with the -e switch
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Total time: 2 seconds
>>>> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
>>>> [INFO] Final Memory: 5M/11M
>>>> [INFO] ------------------------------------------------------------------------
>>>>
>>>>
>>>>
>>>> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
>>>> Does anybody know what the problem is? I hope you can help me.
>>>> Thanks!
>>>>
>>>> Greetings beni
>>>>
>>>>
>>>> Freundliche Grüsse
>>>> Benjamin Lauener
>>>> Praktikant
>>>>
>>>> --
>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>> * http://www.unic.com | [hidden email]
>>>>
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>>>
>>>
>>>
>>>
>>> --
>>> Best regards,
>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>> http://twitter.com/_godin_
>>>
>>
>>
>>
>> --
>> Best regards,
>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>> http://twitter.com/_godin_
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>
>
>
> --
> Best regards,
> Evgeny Mandrikov aka Godin <http://godin.net.ru>
> http://twitter.com/_godin_
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

maven-stapler-plugin-1.12.pom (3K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: FW: Hudson Sonar Plugin

Evgeny Mandrikov
You can have a look at this file by yourself - it's not a pom.xml,
it's a html file. So, I wonder how this file was downloaded by your
maven.

On Tue, Jul 20, 2010 at 3:38 PM, Benjamin Lauener
<[hidden email]> wrote:

> Ah ok sorry :)
>
> I also tried to extract the jar file but it seems that the jar is corrupt. Anyway, I attached the maven-stapler-plugin-1.12.pom
>
> Thanks man!
>
>
> Freundliche Grüsse
> Benjamin Lauener
> Praktikant
>
> --
> Unic AG | Eigerstrasse 60 | CH-3007 Bern
> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
> * http://www.unic.com | [hidden email]
>
> -----Original Message-----
> From: Evgeny Mandrikov [mailto:[hidden email]]
> Sent: Dienstag, 20. Juli 2010 13:32
> To: [hidden email]
> Subject: Re: FW: Hudson Sonar Plugin
>
> Actually I've asked about this file:
> d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>
> On Tue, Jul 20, 2010 at 3:30 PM, Benjamin Lauener
> <[hidden email]> wrote:
>> Sure, i attached three poms.
>> Sonar_pom
>> Plugins_pom is parent of sonar_pom.
>> Main_pom is parent of plugins_pom.
>>
>> But the strange thing is that I already setup a new Hudson plugin with: "mvn -cpu hpi:create" and tried to do a mvn install after that. But that gave me the same error. I think it is a configurations problem. What do you think?
>>
>> Freundliche Grüsse
>> Benjamin Lauener
>> Praktikant
>>
>> --
>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>> * http://www.unic.com | [hidden email]
>>
>> -----Original Message-----
>> From: Evgeny Mandrikov [mailto:[hidden email]]
>> Sent: Dienstag, 20. Juli 2010 13:24
>> To: [hidden email]
>> Subject: Re: FW: Hudson Sonar Plugin
>>
>> Could you please provide content of one of this POMs?
>>
>> On Tue, Jul 20, 2010 at 3:07 PM, Benjamin Lauener
>> <[hidden email]> wrote:
>>> Here ist he console output with stacktraces turned on, maybe you get any idea what is wrong ;)
>>>
>>>
>>> D:\svn\external\Hudson\Plugins\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>> + Error stacktraces are turned on.
>>> [INFO] Scanning for projects...
>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>
>>> Its dependencies (if any) will NOT be available to the current build.
>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>
>>> Its dependencies (if any) will NOT be available to the current build.
>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>
>>> Its dependencies (if any) will NOT be available to the current build.
>>> [INFO] ------------------------------------------------------------------------
>>> [ERROR] BUILD ERROR
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Error building POM (may not be this project's POM).
>>>
>>>
>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>
>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>
>>>
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Trace
>>> org.apache.maven.lifecycle.LifecycleExecutionException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1599)
>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findArtifactTypeHandlersInPlugins(DefaultLifecycleExecutor.java:1468)
>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:222)
>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:178)
>>>        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
>>>        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
>>>        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
>>>        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
>>>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>        at java.lang.reflect.Method.invoke(Method.java:597)
>>>        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>>>        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>>>        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>>>        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
>>> Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:293)
>>>        at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:205)
>>>        at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:184)
>>>        at org.apache.maven.plugin.DefaultPluginManager.loadPluginFully(DefaultPluginManager.java:1626)
>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1582)
>>>        ... 15 more
>>> Caused by: org.apache.maven.project.InvalidProjectModelException: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1599)
>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1571)
>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:562)
>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)
>>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:277)
>>>        ... 19 more
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Total time: 2 seconds
>>> [INFO] Finished at: Tue Jul 20 13:05:24 CEST 2010
>>> [INFO] Final Memory: 5M/12M
>>> [INFO] ------------------------------------------------------------------------
>>>
>>>
>>>
>>> Greetings beni
>>>
>>> Freundliche Grüsse
>>> Benjamin Lauener
>>> Praktikant
>>>
>>> --
>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>> * http://www.unic.com | [hidden email]
>>>
>>> -----Original Message-----
>>> From: Benjamin Lauener
>>> Sent: Dienstag, 20. Juli 2010 12:02
>>> To: '[hidden email]'
>>> Subject: RE: Hudson Sonar Plugin
>>>
>>> I deleted all incorrect POMs:
>>>
>>> maven-stapler-plugin
>>> wagon-svn
>>> javanettasks
>>>
>>> but after downloading them again I get the same error.
>>> Do you have another idea what could be wrong here?
>>>
>>> Thanks!
>>>
>>>
>>> Freundliche Grüsse
>>> Benjamin Lauener
>>> Praktikant
>>>
>>> --
>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>> * http://www.unic.com | [hidden email]
>>>
>>> -----Original Message-----
>>> From: Evgeny Mandrikov [mailto:[hidden email]]
>>> Sent: Dienstag, 20. Juli 2010 11:55
>>> To: [hidden email]
>>> Subject: Re: Hudson Sonar Plugin
>>>
>>> Oh, sorry - I've missed that you're already here :)
>>>
>>> You have an issue with local maven repository, so could you please try
>>> to remove incorrect.POMs before build in order to download them again?
>>>
>>> On Tue, Jul 20, 2010 at 1:51 PM, Evgeny Mandrikov <[hidden email]> wrote:
>>>> Hi,
>>>>
>>>> It's a problem not with hudson-sonar-plugin. So I think it would be
>>>> better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
>>>> And ask questions in dev mailing list of Hudson:
>>>> [hidden email]
>>>>
>>>> On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
>>>> <[hidden email]> wrote:
>>>>> Hey guys!
>>>>>
>>>>> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
>>>>> The console output looks like this:
>>>>>
>>>>>
>>>>>
>>>>> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>>>> [INFO] Scanning for projects...
>>>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>>>
>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>>>
>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>>>
>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>> [INFO] ------------------------------------------------------------------------
>>>>> [ERROR] BUILD ERROR
>>>>> [INFO] ------------------------------------------------------------------------
>>>>> [INFO] Error building POM (may not be this project's POM).
>>>>>
>>>>>
>>>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>>
>>>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>>
>>>>>
>>>>> [INFO] ------------------------------------------------------------------------
>>>>> [INFO] For more information, run Maven with the -e switch
>>>>> [INFO] ------------------------------------------------------------------------
>>>>> [INFO] Total time: 2 seconds
>>>>> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
>>>>> [INFO] Final Memory: 5M/11M
>>>>> [INFO] ------------------------------------------------------------------------
>>>>>
>>>>>
>>>>>
>>>>> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
>>>>> Does anybody know what the problem is? I hope you can help me.
>>>>> Thanks!
>>>>>
>>>>> Greetings beni
>>>>>
>>>>>
>>>>> Freundliche Grüsse
>>>>> Benjamin Lauener
>>>>> Praktikant
>>>>>
>>>>> --
>>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>>> * http://www.unic.com | [hidden email]
>>>>>
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: [hidden email]
>>>>> For additional commands, e-mail: [hidden email]
>>>>>
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> Best regards,
>>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>>> http://twitter.com/_godin_
>>>>
>>>
>>>
>>>
>>> --
>>> Best regards,
>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>> http://twitter.com/_godin_
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>>
>>
>>
>>
>> --
>> Best regards,
>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>> http://twitter.com/_godin_
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
>
>
> --
> Best regards,
> Evgeny Mandrikov aka Godin <http://godin.net.ru>
> http://twitter.com/_godin_
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>



--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: FW: Hudson Sonar Plugin

Benjamin Lauener
You're right, but Maven always downloads the same file when I delete this. I don't know what to do to get a right file.

Freundliche Grüsse
Benjamin Lauener
Praktikant

--
Unic AG | Eigerstrasse 60 | CH-3007 Bern
Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
* http://www.unic.com | [hidden email]

-----Original Message-----
From: Evgeny Mandrikov [mailto:[hidden email]]
Sent: Dienstag, 20. Juli 2010 13:41
To: [hidden email]
Subject: Re: FW: Hudson Sonar Plugin

You can have a look at this file by yourself - it's not a pom.xml,
it's a html file. So, I wonder how this file was downloaded by your
maven.

On Tue, Jul 20, 2010 at 3:38 PM, Benjamin Lauener
<[hidden email]> wrote:

> Ah ok sorry :)
>
> I also tried to extract the jar file but it seems that the jar is corrupt. Anyway, I attached the maven-stapler-plugin-1.12.pom
>
> Thanks man!
>
>
> Freundliche Grüsse
> Benjamin Lauener
> Praktikant
>
> --
> Unic AG | Eigerstrasse 60 | CH-3007 Bern
> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
> * http://www.unic.com | [hidden email]
>
> -----Original Message-----
> From: Evgeny Mandrikov [mailto:[hidden email]]
> Sent: Dienstag, 20. Juli 2010 13:32
> To: [hidden email]
> Subject: Re: FW: Hudson Sonar Plugin
>
> Actually I've asked about this file:
> d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>
> On Tue, Jul 20, 2010 at 3:30 PM, Benjamin Lauener
> <[hidden email]> wrote:
>> Sure, i attached three poms.
>> Sonar_pom
>> Plugins_pom is parent of sonar_pom.
>> Main_pom is parent of plugins_pom.
>>
>> But the strange thing is that I already setup a new Hudson plugin with: "mvn -cpu hpi:create" and tried to do a mvn install after that. But that gave me the same error. I think it is a configurations problem. What do you think?
>>
>> Freundliche Grüsse
>> Benjamin Lauener
>> Praktikant
>>
>> --
>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>> * http://www.unic.com | [hidden email]
>>
>> -----Original Message-----
>> From: Evgeny Mandrikov [mailto:[hidden email]]
>> Sent: Dienstag, 20. Juli 2010 13:24
>> To: [hidden email]
>> Subject: Re: FW: Hudson Sonar Plugin
>>
>> Could you please provide content of one of this POMs?
>>
>> On Tue, Jul 20, 2010 at 3:07 PM, Benjamin Lauener
>> <[hidden email]> wrote:
>>> Here ist he console output with stacktraces turned on, maybe you get any idea what is wrong ;)
>>>
>>>
>>> D:\svn\external\Hudson\Plugins\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>> + Error stacktraces are turned on.
>>> [INFO] Scanning for projects...
>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>
>>> Its dependencies (if any) will NOT be available to the current build.
>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>
>>> Its dependencies (if any) will NOT be available to the current build.
>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>
>>> Its dependencies (if any) will NOT be available to the current build.
>>> [INFO] ------------------------------------------------------------------------
>>> [ERROR] BUILD ERROR
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Error building POM (may not be this project's POM).
>>>
>>>
>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>
>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>
>>>
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Trace
>>> org.apache.maven.lifecycle.LifecycleExecutionException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1599)
>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findArtifactTypeHandlersInPlugins(DefaultLifecycleExecutor.java:1468)
>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:222)
>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:178)
>>>        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
>>>        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
>>>        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
>>>        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
>>>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>        at java.lang.reflect.Method.invoke(Method.java:597)
>>>        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>>>        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>>>        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>>>        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
>>> Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:293)
>>>        at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:205)
>>>        at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:184)
>>>        at org.apache.maven.plugin.DefaultPluginManager.loadPluginFully(DefaultPluginManager.java:1626)
>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1582)
>>>        ... 15 more
>>> Caused by: org.apache.maven.project.InvalidProjectModelException: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1599)
>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1571)
>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:562)
>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)
>>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:277)
>>>        ... 19 more
>>> [INFO] ------------------------------------------------------------------------
>>> [INFO] Total time: 2 seconds
>>> [INFO] Finished at: Tue Jul 20 13:05:24 CEST 2010
>>> [INFO] Final Memory: 5M/12M
>>> [INFO] ------------------------------------------------------------------------
>>>
>>>
>>>
>>> Greetings beni
>>>
>>> Freundliche Grüsse
>>> Benjamin Lauener
>>> Praktikant
>>>
>>> --
>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>> * http://www.unic.com | [hidden email]
>>>
>>> -----Original Message-----
>>> From: Benjamin Lauener
>>> Sent: Dienstag, 20. Juli 2010 12:02
>>> To: '[hidden email]'
>>> Subject: RE: Hudson Sonar Plugin
>>>
>>> I deleted all incorrect POMs:
>>>
>>> maven-stapler-plugin
>>> wagon-svn
>>> javanettasks
>>>
>>> but after downloading them again I get the same error.
>>> Do you have another idea what could be wrong here?
>>>
>>> Thanks!
>>>
>>>
>>> Freundliche Grüsse
>>> Benjamin Lauener
>>> Praktikant
>>>
>>> --
>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>> * http://www.unic.com | [hidden email]
>>>
>>> -----Original Message-----
>>> From: Evgeny Mandrikov [mailto:[hidden email]]
>>> Sent: Dienstag, 20. Juli 2010 11:55
>>> To: [hidden email]
>>> Subject: Re: Hudson Sonar Plugin
>>>
>>> Oh, sorry - I've missed that you're already here :)
>>>
>>> You have an issue with local maven repository, so could you please try
>>> to remove incorrect.POMs before build in order to download them again?
>>>
>>> On Tue, Jul 20, 2010 at 1:51 PM, Evgeny Mandrikov <[hidden email]> wrote:
>>>> Hi,
>>>>
>>>> It's a problem not with hudson-sonar-plugin. So I think it would be
>>>> better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
>>>> And ask questions in dev mailing list of Hudson:
>>>> [hidden email]
>>>>
>>>> On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
>>>> <[hidden email]> wrote:
>>>>> Hey guys!
>>>>>
>>>>> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
>>>>> The console output looks like this:
>>>>>
>>>>>
>>>>>
>>>>> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>>>> [INFO] Scanning for projects...
>>>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>>>
>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>>>
>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>>>
>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>> [INFO] ------------------------------------------------------------------------
>>>>> [ERROR] BUILD ERROR
>>>>> [INFO] ------------------------------------------------------------------------
>>>>> [INFO] Error building POM (may not be this project's POM).
>>>>>
>>>>>
>>>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>>
>>>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>>
>>>>>
>>>>> [INFO] ------------------------------------------------------------------------
>>>>> [INFO] For more information, run Maven with the -e switch
>>>>> [INFO] ------------------------------------------------------------------------
>>>>> [INFO] Total time: 2 seconds
>>>>> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
>>>>> [INFO] Final Memory: 5M/11M
>>>>> [INFO] ------------------------------------------------------------------------
>>>>>
>>>>>
>>>>>
>>>>> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
>>>>> Does anybody know what the problem is? I hope you can help me.
>>>>> Thanks!
>>>>>
>>>>> Greetings beni
>>>>>
>>>>>
>>>>> Freundliche Grüsse
>>>>> Benjamin Lauener
>>>>> Praktikant
>>>>>
>>>>> --
>>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>>> * http://www.unic.com | [hidden email]
>>>>>
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: [hidden email]
>>>>> For additional commands, e-mail: [hidden email]
>>>>>
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> Best regards,
>>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>>> http://twitter.com/_godin_
>>>>
>>>
>>>
>>>
>>> --
>>> Best regards,
>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>> http://twitter.com/_godin_
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>>
>>
>>
>>
>> --
>> Best regards,
>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>> http://twitter.com/_godin_
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
>
>
> --
> Best regards,
> Evgeny Mandrikov aka Godin <http://godin.net.ru>
> http://twitter.com/_godin_
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>



--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: FW: Hudson Sonar Plugin

Evgeny Mandrikov
You should check .m2/settings.xml about repositories and mirrors or
check Nexus if you have one.

On Tue, Jul 20, 2010 at 3:44 PM, Benjamin Lauener
<[hidden email]> wrote:

> You're right, but Maven always downloads the same file when I delete this. I don't know what to do to get a right file.
>
> Freundliche Grüsse
> Benjamin Lauener
> Praktikant
>
> --
> Unic AG | Eigerstrasse 60 | CH-3007 Bern
> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
> * http://www.unic.com | [hidden email]
>
> -----Original Message-----
> From: Evgeny Mandrikov [mailto:[hidden email]]
> Sent: Dienstag, 20. Juli 2010 13:41
> To: [hidden email]
> Subject: Re: FW: Hudson Sonar Plugin
>
> You can have a look at this file by yourself - it's not a pom.xml,
> it's a html file. So, I wonder how this file was downloaded by your
> maven.
>
> On Tue, Jul 20, 2010 at 3:38 PM, Benjamin Lauener
> <[hidden email]> wrote:
>> Ah ok sorry :)
>>
>> I also tried to extract the jar file but it seems that the jar is corrupt. Anyway, I attached the maven-stapler-plugin-1.12.pom
>>
>> Thanks man!
>>
>>
>> Freundliche Grüsse
>> Benjamin Lauener
>> Praktikant
>>
>> --
>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>> * http://www.unic.com | [hidden email]
>>
>> -----Original Message-----
>> From: Evgeny Mandrikov [mailto:[hidden email]]
>> Sent: Dienstag, 20. Juli 2010 13:32
>> To: [hidden email]
>> Subject: Re: FW: Hudson Sonar Plugin
>>
>> Actually I've asked about this file:
>> d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>> On Tue, Jul 20, 2010 at 3:30 PM, Benjamin Lauener
>> <[hidden email]> wrote:
>>> Sure, i attached three poms.
>>> Sonar_pom
>>> Plugins_pom is parent of sonar_pom.
>>> Main_pom is parent of plugins_pom.
>>>
>>> But the strange thing is that I already setup a new Hudson plugin with: "mvn -cpu hpi:create" and tried to do a mvn install after that. But that gave me the same error. I think it is a configurations problem. What do you think?
>>>
>>> Freundliche Grüsse
>>> Benjamin Lauener
>>> Praktikant
>>>
>>> --
>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>> * http://www.unic.com | [hidden email]
>>>
>>> -----Original Message-----
>>> From: Evgeny Mandrikov [mailto:[hidden email]]
>>> Sent: Dienstag, 20. Juli 2010 13:24
>>> To: [hidden email]
>>> Subject: Re: FW: Hudson Sonar Plugin
>>>
>>> Could you please provide content of one of this POMs?
>>>
>>> On Tue, Jul 20, 2010 at 3:07 PM, Benjamin Lauener
>>> <[hidden email]> wrote:
>>>> Here ist he console output with stacktraces turned on, maybe you get any idea what is wrong ;)
>>>>
>>>>
>>>> D:\svn\external\Hudson\Plugins\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>>> + Error stacktraces are turned on.
>>>> [INFO] Scanning for projects...
>>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [INFO] ------------------------------------------------------------------------
>>>> [ERROR] BUILD ERROR
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Error building POM (may not be this project's POM).
>>>>
>>>>
>>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>
>>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>
>>>>
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Trace
>>>> org.apache.maven.lifecycle.LifecycleExecutionException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1599)
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findArtifactTypeHandlersInPlugins(DefaultLifecycleExecutor.java:1468)
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:222)
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:178)
>>>>        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
>>>>        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
>>>>        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
>>>>        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
>>>>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>>        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>>>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>>        at java.lang.reflect.Method.invoke(Method.java:597)
>>>>        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>>>>        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>>>>        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>>>>        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
>>>> Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:293)
>>>>        at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:205)
>>>>        at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:184)
>>>>        at org.apache.maven.plugin.DefaultPluginManager.loadPluginFully(DefaultPluginManager.java:1626)
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1582)
>>>>        ... 15 more
>>>> Caused by: org.apache.maven.project.InvalidProjectModelException: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1599)
>>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1571)
>>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:562)
>>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)
>>>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:277)
>>>>        ... 19 more
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Total time: 2 seconds
>>>> [INFO] Finished at: Tue Jul 20 13:05:24 CEST 2010
>>>> [INFO] Final Memory: 5M/12M
>>>> [INFO] ------------------------------------------------------------------------
>>>>
>>>>
>>>>
>>>> Greetings beni
>>>>
>>>> Freundliche Grüsse
>>>> Benjamin Lauener
>>>> Praktikant
>>>>
>>>> --
>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>> * http://www.unic.com | [hidden email]
>>>>
>>>> -----Original Message-----
>>>> From: Benjamin Lauener
>>>> Sent: Dienstag, 20. Juli 2010 12:02
>>>> To: '[hidden email]'
>>>> Subject: RE: Hudson Sonar Plugin
>>>>
>>>> I deleted all incorrect POMs:
>>>>
>>>> maven-stapler-plugin
>>>> wagon-svn
>>>> javanettasks
>>>>
>>>> but after downloading them again I get the same error.
>>>> Do you have another idea what could be wrong here?
>>>>
>>>> Thanks!
>>>>
>>>>
>>>> Freundliche Grüsse
>>>> Benjamin Lauener
>>>> Praktikant
>>>>
>>>> --
>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>> * http://www.unic.com | [hidden email]
>>>>
>>>> -----Original Message-----
>>>> From: Evgeny Mandrikov [mailto:[hidden email]]
>>>> Sent: Dienstag, 20. Juli 2010 11:55
>>>> To: [hidden email]
>>>> Subject: Re: Hudson Sonar Plugin
>>>>
>>>> Oh, sorry - I've missed that you're already here :)
>>>>
>>>> You have an issue with local maven repository, so could you please try
>>>> to remove incorrect.POMs before build in order to download them again?
>>>>
>>>> On Tue, Jul 20, 2010 at 1:51 PM, Evgeny Mandrikov <[hidden email]> wrote:
>>>>> Hi,
>>>>>
>>>>> It's a problem not with hudson-sonar-plugin. So I think it would be
>>>>> better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
>>>>> And ask questions in dev mailing list of Hudson:
>>>>> [hidden email]
>>>>>
>>>>> On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
>>>>> <[hidden email]> wrote:
>>>>>> Hey guys!
>>>>>>
>>>>>> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
>>>>>> The console output looks like this:
>>>>>>
>>>>>>
>>>>>>
>>>>>> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>>>>> [INFO] Scanning for projects...
>>>>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>>>>
>>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>>>>
>>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>>>>
>>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>> [ERROR] BUILD ERROR
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>> [INFO] Error building POM (may not be this project's POM).
>>>>>>
>>>>>>
>>>>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>>>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>>>
>>>>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>>>
>>>>>>
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>> [INFO] For more information, run Maven with the -e switch
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>> [INFO] Total time: 2 seconds
>>>>>> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
>>>>>> [INFO] Final Memory: 5M/11M
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>>
>>>>>>
>>>>>>
>>>>>> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
>>>>>> Does anybody know what the problem is? I hope you can help me.
>>>>>> Thanks!
>>>>>>
>>>>>> Greetings beni
>>>>>>
>>>>>>
>>>>>> Freundliche Grüsse
>>>>>> Benjamin Lauener
>>>>>> Praktikant
>>>>>>
>>>>>> --
>>>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>>>> * http://www.unic.com | [hidden email]
>>>>>>
>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: [hidden email]
>>>>>> For additional commands, e-mail: [hidden email]
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Best regards,
>>>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>>>> http://twitter.com/_godin_
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> Best regards,
>>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>>> http://twitter.com/_godin_
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>>>
>>>
>>>
>>>
>>> --
>>> Best regards,
>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>> http://twitter.com/_godin_
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>>
>>
>> --
>> Best regards,
>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>> http://twitter.com/_godin_
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
>
>
> --
> Best regards,
> Evgeny Mandrikov aka Godin <http://godin.net.ru>
> http://twitter.com/_godin_
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>



--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: FW: Hudson Sonar Plugin

Benjamin Lauener
I deleted all the corrupt files in archiva and in my local repo. But that doesn't help. I really don't know how to move on.

Freundliche Grüsse
Benjamin Lauener
Praktikant

--
Unic AG | Eigerstrasse 60 | CH-3007 Bern
Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
* http://www.unic.com | [hidden email]

-----Original Message-----
From: Evgeny Mandrikov [mailto:[hidden email]]
Sent: Dienstag, 20. Juli 2010 13:46
To: [hidden email]
Subject: Re: FW: Hudson Sonar Plugin

You should check .m2/settings.xml about repositories and mirrors or
check Nexus if you have one.

On Tue, Jul 20, 2010 at 3:44 PM, Benjamin Lauener
<[hidden email]> wrote:

> You're right, but Maven always downloads the same file when I delete this. I don't know what to do to get a right file.
>
> Freundliche Grüsse
> Benjamin Lauener
> Praktikant
>
> --
> Unic AG | Eigerstrasse 60 | CH-3007 Bern
> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
> * http://www.unic.com | [hidden email]
>
> -----Original Message-----
> From: Evgeny Mandrikov [mailto:[hidden email]]
> Sent: Dienstag, 20. Juli 2010 13:41
> To: [hidden email]
> Subject: Re: FW: Hudson Sonar Plugin
>
> You can have a look at this file by yourself - it's not a pom.xml,
> it's a html file. So, I wonder how this file was downloaded by your
> maven.
>
> On Tue, Jul 20, 2010 at 3:38 PM, Benjamin Lauener
> <[hidden email]> wrote:
>> Ah ok sorry :)
>>
>> I also tried to extract the jar file but it seems that the jar is corrupt. Anyway, I attached the maven-stapler-plugin-1.12.pom
>>
>> Thanks man!
>>
>>
>> Freundliche Grüsse
>> Benjamin Lauener
>> Praktikant
>>
>> --
>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>> * http://www.unic.com | [hidden email]
>>
>> -----Original Message-----
>> From: Evgeny Mandrikov [mailto:[hidden email]]
>> Sent: Dienstag, 20. Juli 2010 13:32
>> To: [hidden email]
>> Subject: Re: FW: Hudson Sonar Plugin
>>
>> Actually I've asked about this file:
>> d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>> On Tue, Jul 20, 2010 at 3:30 PM, Benjamin Lauener
>> <[hidden email]> wrote:
>>> Sure, i attached three poms.
>>> Sonar_pom
>>> Plugins_pom is parent of sonar_pom.
>>> Main_pom is parent of plugins_pom.
>>>
>>> But the strange thing is that I already setup a new Hudson plugin with: "mvn -cpu hpi:create" and tried to do a mvn install after that. But that gave me the same error. I think it is a configurations problem. What do you think?
>>>
>>> Freundliche Grüsse
>>> Benjamin Lauener
>>> Praktikant
>>>
>>> --
>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>> * http://www.unic.com | [hidden email]
>>>
>>> -----Original Message-----
>>> From: Evgeny Mandrikov [mailto:[hidden email]]
>>> Sent: Dienstag, 20. Juli 2010 13:24
>>> To: [hidden email]
>>> Subject: Re: FW: Hudson Sonar Plugin
>>>
>>> Could you please provide content of one of this POMs?
>>>
>>> On Tue, Jul 20, 2010 at 3:07 PM, Benjamin Lauener
>>> <[hidden email]> wrote:
>>>> Here ist he console output with stacktraces turned on, maybe you get any idea what is wrong ;)
>>>>
>>>>
>>>> D:\svn\external\Hudson\Plugins\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>>> + Error stacktraces are turned on.
>>>> [INFO] Scanning for projects...
>>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [INFO] ------------------------------------------------------------------------
>>>> [ERROR] BUILD ERROR
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Error building POM (may not be this project's POM).
>>>>
>>>>
>>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>
>>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>
>>>>
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Trace
>>>> org.apache.maven.lifecycle.LifecycleExecutionException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1599)
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findArtifactTypeHandlersInPlugins(DefaultLifecycleExecutor.java:1468)
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:222)
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:178)
>>>>        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
>>>>        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
>>>>        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
>>>>        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
>>>>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>>        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>>>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>>        at java.lang.reflect.Method.invoke(Method.java:597)
>>>>        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>>>>        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>>>>        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>>>>        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
>>>> Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:293)
>>>>        at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:205)
>>>>        at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:184)
>>>>        at org.apache.maven.plugin.DefaultPluginManager.loadPluginFully(DefaultPluginManager.java:1626)
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1582)
>>>>        ... 15 more
>>>> Caused by: org.apache.maven.project.InvalidProjectModelException: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1599)
>>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1571)
>>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:562)
>>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)
>>>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:277)
>>>>        ... 19 more
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Total time: 2 seconds
>>>> [INFO] Finished at: Tue Jul 20 13:05:24 CEST 2010
>>>> [INFO] Final Memory: 5M/12M
>>>> [INFO] ------------------------------------------------------------------------
>>>>
>>>>
>>>>
>>>> Greetings beni
>>>>
>>>> Freundliche Grüsse
>>>> Benjamin Lauener
>>>> Praktikant
>>>>
>>>> --
>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>> * http://www.unic.com | [hidden email]
>>>>
>>>> -----Original Message-----
>>>> From: Benjamin Lauener
>>>> Sent: Dienstag, 20. Juli 2010 12:02
>>>> To: '[hidden email]'
>>>> Subject: RE: Hudson Sonar Plugin
>>>>
>>>> I deleted all incorrect POMs:
>>>>
>>>> maven-stapler-plugin
>>>> wagon-svn
>>>> javanettasks
>>>>
>>>> but after downloading them again I get the same error.
>>>> Do you have another idea what could be wrong here?
>>>>
>>>> Thanks!
>>>>
>>>>
>>>> Freundliche Grüsse
>>>> Benjamin Lauener
>>>> Praktikant
>>>>
>>>> --
>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>> * http://www.unic.com | [hidden email]
>>>>
>>>> -----Original Message-----
>>>> From: Evgeny Mandrikov [mailto:[hidden email]]
>>>> Sent: Dienstag, 20. Juli 2010 11:55
>>>> To: [hidden email]
>>>> Subject: Re: Hudson Sonar Plugin
>>>>
>>>> Oh, sorry - I've missed that you're already here :)
>>>>
>>>> You have an issue with local maven repository, so could you please try
>>>> to remove incorrect.POMs before build in order to download them again?
>>>>
>>>> On Tue, Jul 20, 2010 at 1:51 PM, Evgeny Mandrikov <[hidden email]> wrote:
>>>>> Hi,
>>>>>
>>>>> It's a problem not with hudson-sonar-plugin. So I think it would be
>>>>> better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
>>>>> And ask questions in dev mailing list of Hudson:
>>>>> [hidden email]
>>>>>
>>>>> On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
>>>>> <[hidden email]> wrote:
>>>>>> Hey guys!
>>>>>>
>>>>>> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
>>>>>> The console output looks like this:
>>>>>>
>>>>>>
>>>>>>
>>>>>> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>>>>> [INFO] Scanning for projects...
>>>>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>>>>
>>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>>>>
>>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>>>>
>>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>> [ERROR] BUILD ERROR
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>> [INFO] Error building POM (may not be this project's POM).
>>>>>>
>>>>>>
>>>>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>>>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>>>
>>>>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>>>
>>>>>>
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>> [INFO] For more information, run Maven with the -e switch
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>> [INFO] Total time: 2 seconds
>>>>>> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
>>>>>> [INFO] Final Memory: 5M/11M
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>>
>>>>>>
>>>>>>
>>>>>> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
>>>>>> Does anybody know what the problem is? I hope you can help me.
>>>>>> Thanks!
>>>>>>
>>>>>> Greetings beni
>>>>>>
>>>>>>
>>>>>> Freundliche Grüsse
>>>>>> Benjamin Lauener
>>>>>> Praktikant
>>>>>>
>>>>>> --
>>>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>>>> * http://www.unic.com | [hidden email]
>>>>>>
>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: [hidden email]
>>>>>> For additional commands, e-mail: [hidden email]
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Best regards,
>>>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>>>> http://twitter.com/_godin_
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> Best regards,
>>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>>> http://twitter.com/_godin_
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>>>
>>>
>>>
>>>
>>> --
>>> Best regards,
>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>> http://twitter.com/_godin_
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>>
>>
>> --
>> Best regards,
>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>> http://twitter.com/_godin_
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
>
>
> --
> Best regards,
> Evgeny Mandrikov aka Godin <http://godin.net.ru>
> http://twitter.com/_godin_
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>



--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

FW: FW: Hudson Sonar Plugin

Benjamin Lauener
In reply to this post by Benjamin Lauener
Ok, I downloaded the stapler-jar manually and that doesn't seem to be a problem anymore.
But now I get another errormeassage:




Project ID: org.apache.maven.plugins:maven-enforcer-plugin:maven-plugin:1.0-SNAPSHOT

Reason: Cannot find parent: org.apache.maven.enforcer:enforcer for project: org.apache.maven.plugins:maven-enforcer-plugin:maven-plugin:1.0-SNAPSHOT for project org.apache.maven.plugins:maven-enforcer-plugin:maven-plugin:1.0-SNAPSHOT



Seems that there is almost everything wrong in here :P


Freundliche Grüsse
Benjamin Lauener
Praktikant

--
Unic AG | Eigerstrasse 60 | CH-3007 Bern
Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
* http://www.unic.com | [hidden email]

-----Original Message-----
From: Benjamin Lauener
Sent: Dienstag, 20. Juli 2010 14:31
To: '[hidden email]'
Subject: RE: FW: Hudson Sonar Plugin

I deleted all the corrupt files in archiva and in my local repo. But that doesn't help. I really don't know how to move on.

Freundliche Grüsse
Benjamin Lauener
Praktikant

--
Unic AG | Eigerstrasse 60 | CH-3007 Bern
Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
* http://www.unic.com | [hidden email]

-----Original Message-----
From: Evgeny Mandrikov [mailto:[hidden email]]
Sent: Dienstag, 20. Juli 2010 13:46
To: [hidden email]
Subject: Re: FW: Hudson Sonar Plugin

You should check .m2/settings.xml about repositories and mirrors or
check Nexus if you have one.

On Tue, Jul 20, 2010 at 3:44 PM, Benjamin Lauener
<[hidden email]> wrote:

> You're right, but Maven always downloads the same file when I delete this. I don't know what to do to get a right file.
>
> Freundliche Grüsse
> Benjamin Lauener
> Praktikant
>
> --
> Unic AG | Eigerstrasse 60 | CH-3007 Bern
> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
> * http://www.unic.com | [hidden email]
>
> -----Original Message-----
> From: Evgeny Mandrikov [mailto:[hidden email]]
> Sent: Dienstag, 20. Juli 2010 13:41
> To: [hidden email]
> Subject: Re: FW: Hudson Sonar Plugin
>
> You can have a look at this file by yourself - it's not a pom.xml,
> it's a html file. So, I wonder how this file was downloaded by your
> maven.
>
> On Tue, Jul 20, 2010 at 3:38 PM, Benjamin Lauener
> <[hidden email]> wrote:
>> Ah ok sorry :)
>>
>> I also tried to extract the jar file but it seems that the jar is corrupt. Anyway, I attached the maven-stapler-plugin-1.12.pom
>>
>> Thanks man!
>>
>>
>> Freundliche Grüsse
>> Benjamin Lauener
>> Praktikant
>>
>> --
>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>> * http://www.unic.com | [hidden email]
>>
>> -----Original Message-----
>> From: Evgeny Mandrikov [mailto:[hidden email]]
>> Sent: Dienstag, 20. Juli 2010 13:32
>> To: [hidden email]
>> Subject: Re: FW: Hudson Sonar Plugin
>>
>> Actually I've asked about this file:
>> d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>
>> On Tue, Jul 20, 2010 at 3:30 PM, Benjamin Lauener
>> <[hidden email]> wrote:
>>> Sure, i attached three poms.
>>> Sonar_pom
>>> Plugins_pom is parent of sonar_pom.
>>> Main_pom is parent of plugins_pom.
>>>
>>> But the strange thing is that I already setup a new Hudson plugin with: "mvn -cpu hpi:create" and tried to do a mvn install after that. But that gave me the same error. I think it is a configurations problem. What do you think?
>>>
>>> Freundliche Grüsse
>>> Benjamin Lauener
>>> Praktikant
>>>
>>> --
>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>> * http://www.unic.com | [hidden email]
>>>
>>> -----Original Message-----
>>> From: Evgeny Mandrikov [mailto:[hidden email]]
>>> Sent: Dienstag, 20. Juli 2010 13:24
>>> To: [hidden email]
>>> Subject: Re: FW: Hudson Sonar Plugin
>>>
>>> Could you please provide content of one of this POMs?
>>>
>>> On Tue, Jul 20, 2010 at 3:07 PM, Benjamin Lauener
>>> <[hidden email]> wrote:
>>>> Here ist he console output with stacktraces turned on, maybe you get any idea what is wrong ;)
>>>>
>>>>
>>>> D:\svn\external\Hudson\Plugins\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>>> + Error stacktraces are turned on.
>>>> [INFO] Scanning for projects...
>>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>>
>>>> Its dependencies (if any) will NOT be available to the current build.
>>>> [INFO] ------------------------------------------------------------------------
>>>> [ERROR] BUILD ERROR
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Error building POM (may not be this project's POM).
>>>>
>>>>
>>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>
>>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>
>>>>
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Trace
>>>> org.apache.maven.lifecycle.LifecycleExecutionException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1599)
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findArtifactTypeHandlersInPlugins(DefaultLifecycleExecutor.java:1468)
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.findExtensions(DefaultLifecycleExecutor.java:222)
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:178)
>>>>        at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
>>>>        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
>>>>        at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
>>>>        at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
>>>>        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>>>        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>>>        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>>>        at java.lang.reflect.Method.invoke(Method.java:597)
>>>>        at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
>>>>        at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>>>>        at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
>>>>        at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
>>>> Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build project for plugin 'org.kohsuke.stapler:maven-stapler-plugin': Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:293)
>>>>        at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(DefaultPluginManager.java:205)
>>>>        at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPluginManager.java:184)
>>>>        at org.apache.maven.plugin.DefaultPluginManager.loadPluginFully(DefaultPluginManager.java:1626)
>>>>        at org.apache.maven.lifecycle.DefaultLifecycleExecutor.loadPluginFully(DefaultLifecycleExecutor.java:1582)
>>>>        ... 15 more
>>>> Caused by: org.apache.maven.project.InvalidProjectModelException: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1599)
>>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.readModel(DefaultMavenProjectBuilder.java:1571)
>>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepository(DefaultMavenProjectBuilder.java:562)
>>>>        at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromRepository(DefaultMavenProjectBuilder.java:251)
>>>>        at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersion(DefaultPluginManager.java:277)
>>>>        ... 19 more
>>>> [INFO] ------------------------------------------------------------------------
>>>> [INFO] Total time: 2 seconds
>>>> [INFO] Finished at: Tue Jul 20 13:05:24 CEST 2010
>>>> [INFO] Final Memory: 5M/12M
>>>> [INFO] ------------------------------------------------------------------------
>>>>
>>>>
>>>>
>>>> Greetings beni
>>>>
>>>> Freundliche Grüsse
>>>> Benjamin Lauener
>>>> Praktikant
>>>>
>>>> --
>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>> * http://www.unic.com | [hidden email]
>>>>
>>>> -----Original Message-----
>>>> From: Benjamin Lauener
>>>> Sent: Dienstag, 20. Juli 2010 12:02
>>>> To: '[hidden email]'
>>>> Subject: RE: Hudson Sonar Plugin
>>>>
>>>> I deleted all incorrect POMs:
>>>>
>>>> maven-stapler-plugin
>>>> wagon-svn
>>>> javanettasks
>>>>
>>>> but after downloading them again I get the same error.
>>>> Do you have another idea what could be wrong here?
>>>>
>>>> Thanks!
>>>>
>>>>
>>>> Freundliche Grüsse
>>>> Benjamin Lauener
>>>> Praktikant
>>>>
>>>> --
>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>> * http://www.unic.com | [hidden email]
>>>>
>>>> -----Original Message-----
>>>> From: Evgeny Mandrikov [mailto:[hidden email]]
>>>> Sent: Dienstag, 20. Juli 2010 11:55
>>>> To: [hidden email]
>>>> Subject: Re: Hudson Sonar Plugin
>>>>
>>>> Oh, sorry - I've missed that you're already here :)
>>>>
>>>> You have an issue with local maven repository, so could you please try
>>>> to remove incorrect.POMs before build in order to download them again?
>>>>
>>>> On Tue, Jul 20, 2010 at 1:51 PM, Evgeny Mandrikov <[hidden email]> wrote:
>>>>> Hi,
>>>>>
>>>>> It's a problem not with hudson-sonar-plugin. So I think it would be
>>>>> better to read: http://wiki.hudson-ci.org/display/HUDSON/Extend+Hudson
>>>>> And ask questions in dev mailing list of Hudson:
>>>>> [hidden email]
>>>>>
>>>>> On Tue, Jul 20, 2010 at 1:47 PM, Benjamin Lauener
>>>>> <[hidden email]> wrote:
>>>>>> Hey guys!
>>>>>>
>>>>>> I am trying to edit the existing sonar plugin for hudson. But I can't do an mvn install. I am using Maven 2.2.
>>>>>> The console output looks like this:
>>>>>>
>>>>>>
>>>>>>
>>>>>> D:\svn\external\Hudson\Plugins\Sonar>set MAVEN_OPTS=-Xmx1024m
>>>>>> [INFO] Scanning for projects...
>>>>>> [WARNING] POM for 'org.jvnet.wagon-svn:wagon-svn:pom:1.8:runtime' is invalid.
>>>>>>
>>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.23:runtime' is invalid.
>>>>>>
>>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>>> [WARNING] POM for 'org.kohsuke.stapler:maven-stapler-plugin:pom:1.12:runtime' is invalid.
>>>>>>
>>>>>> Its dependencies (if any) will NOT be available to the current build.
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>> [ERROR] BUILD ERROR
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>> [INFO] Error building POM (may not be this project's POM).
>>>>>>
>>>>>>
>>>>>> Project ID: org.kohsuke.stapler:maven-stapler-plugin
>>>>>> POM Location: d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>>>
>>>>>> Reason: Not a v4.0.0 POM. for project org.kohsuke.stapler:maven-stapler-plugin at d:\repo\org\kohsuke\stapler\maven-stapler-plugin\1.12\maven-stapler-plugin-1.12.pom
>>>>>>
>>>>>>
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>> [INFO] For more information, run Maven with the -e switch
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>> [INFO] Total time: 2 seconds
>>>>>> [INFO] Finished at: Tue Jul 20 09:17:45 CEST 2010
>>>>>> [INFO] Final Memory: 5M/11M
>>>>>> [INFO] ------------------------------------------------------------------------
>>>>>>
>>>>>>
>>>>>>
>>>>>> Looks like there are some problems with the maven-stapler-plugin. I also tried to setup a new plugin but there I can't do an install too.
>>>>>> Does anybody know what the problem is? I hope you can help me.
>>>>>> Thanks!
>>>>>>
>>>>>> Greetings beni
>>>>>>
>>>>>>
>>>>>> Freundliche Grüsse
>>>>>> Benjamin Lauener
>>>>>> Praktikant
>>>>>>
>>>>>> --
>>>>>> Unic AG | Eigerstrasse 60 | CH-3007 Bern
>>>>>> Telefon: +41 31 560 12 12 | Direkt: +41 31 560 12 64
>>>>>> * http://www.unic.com | [hidden email]
>>>>>>
>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: [hidden email]
>>>>>> For additional commands, e-mail: [hidden email]
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Best regards,
>>>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>>>> http://twitter.com/_godin_
>>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> Best regards,
>>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>>> http://twitter.com/_godin_
>>>>
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: [hidden email]
>>>> For additional commands, e-mail: [hidden email]
>>>>
>>>>
>>>
>>>
>>>
>>> --
>>> Best regards,
>>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>>> http://twitter.com/_godin_
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>>
>>
>> --
>> Best regards,
>> Evgeny Mandrikov aka Godin <http://godin.net.ru>
>> http://twitter.com/_godin_
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
>
>
> --
> Best regards,
> Evgeny Mandrikov aka Godin <http://godin.net.ru>
> http://twitter.com/_godin_
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>



--
Best regards,
Evgeny Mandrikov aka Godin <http://godin.net.ru>
http://twitter.com/_godin_

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]