Icons loading issue in Jenkins

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Icons loading issue in Jenkins

Vishnu V Potti
 Hi All,

I have a Jenkins accessed via Netscaler endpoint. https://company.internal.com/jenkins.    
 Earlier I used to access via host:8080 format. i.e http://host:8080/jenkins and everything was working.    It stil lworks fine when accessed like that. 
 
At Netscaler side, we set "x-forwarded-proto" = https header and http to https redirection. Functionality wise works ok. Now I am seeing issues where the login screen logo wont load and some plugin icons wont load.      


Images below.


image.png

I debugged as seen below. I navigated to the url which was formed. The image doesn't exist in that location. But if I access via the host then it can be accessed. The two urls are below.

`https://company.internal.com/jenkins/static/e0c7cecc/plugin/credentials/images/24x24/credentials.png` Doesnt work
`http://host:8080/jenkins/static/e0c7cecc/plugin/credentials/images/24x24/credentials.png` Works


image.png




Any idea what's wrong and how can I resolve these issues? Although these doesnt impact functionality I would like to fix them.

image.png

  What i did so far w.r.t debugging.
1) Referenced this link https://wiki.jenkins.io/display/JENKINS/Configuring+Content+Security+Policy  and made some modifications. Nothing worked.
2) Installed Simple Theme Plugin and could resolve jenkins logo issue in the inner pages ,but not in the login page.


Thanks in advance.
Vish

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/b21c664b-e547-4db1-ae7f-5a1536e192c7o%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Icons loading issue in Jenkins

Mark Waite-2
This would be a great reason to review a related pull request to the Jenkins documentation.  Refer to the "Reverse Proxy Configuration with Jenkins" page that is the focus of pull request 3386.  If it helps you diagnose the issue, that is great.  If it doesn't help you diagnose the issue, it would be great if you could provide notes that describe how you diagnosed and resolved the issue.

Thanks,
Mark Waite

On Wednesday, July 8, 2020 at 5:11:24 AM UTC-6 [hidden email] wrote:
 Hi All,

I have a Jenkins accessed via Netscaler endpoint. https://company.internal.com/jenkins.    
 Earlier I used to access via host:8080 format. i.e http://host:8080/jenkins and everything was working.    It stil lworks fine when accessed like that. 
 
At Netscaler side, we set "x-forwarded-proto" = https header and http to https redirection. Functionality wise works ok. Now I am seeing issues where the login screen logo wont load and some plugin icons wont load.      


Images below.


image.png

I debugged as seen below. I navigated to the url which was formed. The image doesn't exist in that location. But if I access via the host then it can be accessed. The two urls are below.

`https://company.internal.com/jenkins/static/e0c7cecc/plugin/credentials/images/24x24/credentials.png` Doesnt work
`http://host:8080/jenkins/static/e0c7cecc/plugin/credentials/images/24x24/credentials.png` Works


image.png




Any idea what's wrong and how can I resolve these issues? Although these doesnt impact functionality I would like to fix them.

image.png

  What i did so far w.r.t debugging.
1) Referenced this link https://wiki.jenkins.io/display/JENKINS/Configuring+Content+Security+Policy  and made some modifications. Nothing worked.
2) Installed Simple Theme Plugin and could resolve jenkins logo issue in the inner pages ,but not in the login page.


Thanks in advance.
Vish

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/b125a706-1043-4631-838d-141fdbd9e858n%40googlegroups.com.