Increasing number of unavailable plugin updates

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Increasing number of unavailable plugin updates

Alan Sparks-2

We’re running the LTS version of Jenkins (2.263.2).   Starting a few weeks back or so, we’re getting more and more updates listed in the plugin manager that are not installable.  I’m trying to understand if at least one of them is not compatible with LTS and requires a higher version of Jenkins, or if there’s some interdependency that makes the list depend on itself…

 

So far I have a list of the following that can’t be updated (listed as UNAVAILABLE):

Branch API 2.6.3

Environment Injector 2.4.0

Favorite 2.3.3

LDAP 2.3

Maven Integration 3.9

Parameterized Trigger 2.40

Token Macro 2.14

 

Is there something I’m missing, or must I just wait for LTS to catch up somehow?  Thanks in advance for your response.

-Alan

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/DM6PR18MB3306BE46A355B1241E779EA6C5A21%40DM6PR18MB3306.namprd18.prod.outlook.com.
Reply | Threaded
Open this post in threaded view
|

Re: Increasing number of unavailable plugin updates

Mark Waite-2


On Wed, Jan 20, 2021 at 4:13 PM Alan Sparks <[hidden email]> wrote:

We’re running the LTS version of Jenkins (2.263.2).   Starting a few weeks back or so, we’re getting more and more updates listed in the plugin manager that are not installable.  I’m trying to understand if at least one of them is not compatible with LTS and requires a higher version of Jenkins, or if there’s some interdependency that makes the list depend on itself…


A Jenkins plugin release declares the minimum Jenkins version that it supports.  The Jenkins versions after 2.263 (2.264 through 2.276 and beyond) include the changes described in "Major changes in weekly releases".  Supporting those major changes in the plugins you listed has required that the plugins increase their minimum Jenkins version to a version 2.264 or higher.

Those plugin versions are listed as unavailable because they won't run in Jenkins 2.263.

The most recent weekly releases are able to install those plugins.  Users of the weekly releases are leading the effort to check that the major changes are ready for the March 2021 Jenkins long term support release.

If there is something critical that you need in those newer plugin releases, you'll need to switch from the Jenkins LTS to the Jenkins weekly release.  In general, those plugin releases were created so that they could support the changes in weekly releases after 2.263.

If there isn't something critical that you need in those newer plugin releases, you can remain with Jenkins LTS and remain with the releases that support Jenkins 2.263.x.

Mark Waite
 

 

So far I have a list of the following that can’t be updated (listed as UNAVAILABLE):

Branch API 2.6.3

Environment Injector 2.4.0

Favorite 2.3.3

LDAP 2.3

Maven Integration 3.9

Parameterized Trigger 2.40

Token Macro 2.14

 

Is there something I’m missing, or must I just wait for LTS to catch up somehow?  Thanks in advance for your response.

-Alan

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/DM6PR18MB3306BE46A355B1241E779EA6C5A21%40DM6PR18MB3306.namprd18.prod.outlook.com.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CAO49JtFGV9k9M-cyiSXBMFvd7pPdagWQK1XkabucjPkfR6zaEg%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: Increasing number of unavailable plugin updates

zil...@gmail.com
Thanks Mark!

On Wednesday, January 20, 2021 at 9:31:37 PM UTC-5 Mark Waite wrote:
On Wed, Jan 20, 2021 at 4:13 PM Alan Sparks <[hidden email]> wrote:

We’re running the LTS version of Jenkins (2.263.2).   Starting a few weeks back or so, we’re getting more and more updates listed in the plugin manager that are not installable.  I’m trying to understand if at least one of them is not compatible with LTS and requires a higher version of Jenkins, or if there’s some interdependency that makes the list depend on itself…


A Jenkins plugin release declares the minimum Jenkins version that it supports.  The Jenkins versions after 2.263 (2.264 through 2.276 and beyond) include the changes described in "Major changes in weekly releases".  Supporting those major changes in the plugins you listed has required that the plugins increase their minimum Jenkins version to a version 2.264 or higher.

Those plugin versions are listed as unavailable because they won't run in Jenkins 2.263.

The most recent weekly releases are able to install those plugins.  Users of the weekly releases are leading the effort to check that the major changes are ready for the March 2021 Jenkins long term support release.

If there is something critical that you need in those newer plugin releases, you'll need to switch from the Jenkins LTS to the Jenkins weekly release.  In general, those plugin releases were created so that they could support the changes in weekly releases after 2.263.

If there isn't something critical that you need in those newer plugin releases, you can remain with Jenkins LTS and remain with the releases that support Jenkins 2.263.x.

Mark Waite
 

 

So far I have a list of the following that can’t be updated (listed as UNAVAILABLE):

Branch API 2.6.3

Environment Injector 2.4.0

Favorite 2.3.3

LDAP 2.3

Maven Integration 3.9

Parameterized Trigger 2.40

Token Macro 2.14

 

Is there something I’m missing, or must I just wait for LTS to catch up somehow?  Thanks in advance for your response.

-Alan

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/DM6PR18MB3306BE46A355B1241E779EA6C5A21%40DM6PR18MB3306.namprd18.prod.outlook.com.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/fed1e6cd-5999-4a0a-85d9-b628cec87c3en%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

RE: Increasing number of unavailable plugin updates

Alan Sparks-2
In reply to this post by Mark Waite-2

Thanks very much for the information and the link to the blog.

-Alan

 

A Jenkins plugin release declares the minimum Jenkins version that it supports.  The Jenkins versions after 2.263 (2.264 through 2.276 and beyond) include the changes described in "Major changes in weekly releases".  Supporting those major changes in the plugins you listed has required that the plugins increase their minimum Jenkins version to a version 2.264 or higher.

 

Those plugin versions are listed as unavailable because they won't run in Jenkins 2.263.

 

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/DM6PR18MB3306E742744141BA764B721EC5A19%40DM6PR18MB3306.namprd18.prod.outlook.com.