Is {hudson-plugin-info} working properly on the wiki?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Is {hudson-plugin-info} working properly on the wiki?

Justin Holzer
I releases a new version of the NAnt plugin last night, and prior to
releasing it, I updated the pom.xml with my information so that I
would show up as the maintainer on the wiki page. Everything went fine
with the release process. The new version is showing up in update
center. However, the maintainer info on the wiki page doesn't seem
correct. I added the following developer info to pom.xml:

<developers>
  <developer>
    <name>Justin Holzer</name>
    <id>jholzer</id>
    <email>[hidden email]</email>
  </developer>
</developers>

Currently, on the wiki page
(http://wiki.hudson-ci.org/display/HUDSON/NAnt+Plugin), in the plugin
info, the maintainer is displayed as "n/a (id: Justin)". Did I do
something wrong? Does it take a while for this information to get
updated? Is it possible that the plugin info is not getting updated or
selected properly? Any info would be greatly appreciated.

- Justin

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Is {hudson-plugin-info} working properly on the wiki?

Andrew Bayer
The nant POM is probably using an old parent POM version - I think it's 1.324 and later that properly support the developers tag.

A.

On Thu, Feb 25, 2010 at 1:46 PM, Justin Holzer <[hidden email]> wrote:
I releases a new version of the NAnt plugin last night, and prior to
releasing it, I updated the pom.xml with my information so that I
would show up as the maintainer on the wiki page. Everything went fine
with the release process. The new version is showing up in update
center. However, the maintainer info on the wiki page doesn't seem
correct. I added the following developer info to pom.xml:

<developers>
 <developer>
   <name>Justin Holzer</name>
   <id>jholzer</id>
   <email>[hidden email]</email>
 </developer>
</developers>

Currently, on the wiki page
(http://wiki.hudson-ci.org/display/HUDSON/NAnt+Plugin), in the plugin
info, the maintainer is displayed as "n/a (id: Justin)". Did I do
something wrong? Does it take a while for this information to get
updated? Is it possible that the plugin info is not getting updated or
selected properly? Any info would be greatly appreciated.

- Justin

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Is {hudson-plugin-info} working properly on the wiki?

Justin Holzer
Thanks for the info Andrew. That is definitely the issue. I am
currently using 1.319. For such a minor change, would I still need to
do a brand new release, or is it possible, or practical, to replace
the existing release? I have tested the plugin against the newest
release (1.347), so I have every confidence it would work under 1.324,
though I would still need to verify this of course.

Thanks for the info,

- Justin

On Thu, Feb 25, 2010 at 4:48 PM, Andrew Bayer <[hidden email]> wrote:

> The nant POM is probably using an old parent POM version - I think it's
> 1.324 and later that properly support the developers tag.
>
> A.
>
> On Thu, Feb 25, 2010 at 1:46 PM, Justin Holzer <[hidden email]> wrote:
>>
>> I releases a new version of the NAnt plugin last night, and prior to
>> releasing it, I updated the pom.xml with my information so that I
>> would show up as the maintainer on the wiki page. Everything went fine
>> with the release process. The new version is showing up in update
>> center. However, the maintainer info on the wiki page doesn't seem
>> correct. I added the following developer info to pom.xml:
>>
>> <developers>
>>  <developer>
>>    <name>Justin Holzer</name>
>>    <id>jholzer</id>
>>    <email>[hidden email]</email>
>>  </developer>
>> </developers>
>>
>> Currently, on the wiki page
>> (http://wiki.hudson-ci.org/display/HUDSON/NAnt+Plugin), in the plugin
>> info, the maintainer is displayed as "n/a (id: Justin)". Did I do
>> something wrong? Does it take a while for this information to get
>> updated? Is it possible that the plugin info is not getting updated or
>> selected properly? Any info would be greatly appreciated.
>>
>> - Justin
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Is {hudson-plugin-info} working properly on the wiki?

Kohsuke Kawaguchi-2

You'd have to release a new version, I'm afraid.


Justin Holzer wrote:

> Thanks for the info Andrew. That is definitely the issue. I am
> currently using 1.319. For such a minor change, would I still need to
> do a brand new release, or is it possible, or practical, to replace
> the existing release? I have tested the plugin against the newest
> release (1.347), so I have every confidence it would work under 1.324,
> though I would still need to verify this of course.
>
> Thanks for the info,
>
> - Justin
>
> On Thu, Feb 25, 2010 at 4:48 PM, Andrew Bayer <[hidden email]> wrote:
>> The nant POM is probably using an old parent POM version - I think it's
>> 1.324 and later that properly support the developers tag.
>>
>> A.
>>
>> On Thu, Feb 25, 2010 at 1:46 PM, Justin Holzer <[hidden email]> wrote:
>>>
>>> I releases a new version of the NAnt plugin last night, and prior to
>>> releasing it, I updated the pom.xml with my information so that I
>>> would show up as the maintainer on the wiki page. Everything went fine
>>> with the release process. The new version is showing up in update
>>> center. However, the maintainer info on the wiki page doesn't seem
>>> correct. I added the following developer info to pom.xml:
>>>
>>> <developers>
>>> �<developer>
>>> � �<name>Justin Holzer</name>
>>> � �<id>jholzer</id>
>>> � �<email>[hidden email]</email>
>>> �</developer>
>>> </developers>
>>>
>>> Currently, on the wiki page
>>> (http://wiki.hudson-ci.org/display/HUDSON/NAnt+Plugin), in the plugin
>>> info, the maintainer is displayed as "n/a (id: Justin)". Did I do
>>> something wrong? Does it take a while for this information to get
>>> updated? Is it possible that the plugin info is not getting updated or
>>> selected properly? Any info would be greatly appreciated.
>>>
>>> - Justin
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Kohsuke Kawaguchi
Sun Microsystems                   http://weblogs.java.net/blog/kohsuke/

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]