[Issue 2102] New - pmd html escapes are lost in rendering

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Issue 2102] New - pmd html escapes are lost in rendering

sorokh
https://hudson.dev.java.net/issues/show_bug.cgi?id=2102
                 Issue #|2102
                 Summary|pmd html escapes are lost in rendering
               Component|hudson
                 Version|current
                Platform|PC
              OS/Version|Linux
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P2
            Subcomponent|violations
             Assigned to|peterkittreilly
             Reported by|sorokh






------- Additional comments from [hidden email] Tue Jul 22 14:21:13 +0000 2008 -------
Hi all,

The violations plugin seems to render Strings as regular html, even though pmd
escaped it in its output.
e.g. our pmd test reports the following:
<pre>
The String literal &quot;&lt;input type=\&quot;radio\&quot; name=\&quot;&quot;
appears 4 times in this file; the first occurrence is on line 382
</pre>
This is reported as The String literal "<input type= "radio"  name= "" appears 4
times in this file; the first occurrence is on line 382

I didn't look at the plugin code yet, it may be a quick fix. If so I'll submit a
patch ;-)

violations version 0.7.0
hudson version 1.235

greets,
Wim

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]