[Issue 2811] New - Upgrading from 1.248 to latest breaks JNLP foreground slaves

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[Issue 2811] New - Upgrading from 1.248 to latest breaks JNLP foreground slaves

markgruener
https://hudson.dev.java.net/issues/show_bug.cgi?id=2811
                 Issue #|2811
                 Summary|Upgrading from 1.248 to latest breaks JNLP foreground
                        |slaves
               Component|hudson
                 Version|current
                Platform|Other
              OS/Version|Linux
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P1
            Subcomponent|master-slave
             Assigned to|issues@hudson
             Reported by|markgruener






------- Additional comments from [hidden email] Thu Jan  8 20:50:38 +0000 2009 -------
I tried upgrading from 1.248 to 1.266 (and 1.270).
After the upgrade(s) the slave machines fail during the reconnect.
The slave fails to get the remoting.jar (says it is corrupt.
Pressing the detail button gives the test below.
P.S. If I use a browser and past in the url (below) the jar does download to my
desktop and seems intact (not corrupt).
The slaves in question are XP boxes running the slave in the foreground (not as
a service) the master is running on Linux.  Here is the batch file line:

%JAVA_HOME%\bin\javaws -Xms128m -Xmx256m
<a href="http://rtpus049.corpnet2.com:9053/computer/%COMPUTERNAME%/slave-agent.jnlp">http://rtpus049.corpnet2.com:9053/computer/%COMPUTERNAME%/slave-agent.jnlp

-------------------------------------------------------------
An error occurred while launching/running the application.

Title: Slave Agent for RTPWD055103BH
Vendor: Hudson project
Category: Download Error

Corrupted JAR file at http://rtpus049.corpnet2.com:9053/jnlpJars/remoting.jar

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 2811] Upgrading from 1.248 to latest breaks JNLP foreground slaves

markgruener
https://hudson.dev.java.net/issues/show_bug.cgi?id=2811






------- Additional comments from [hidden email] Thu Jan  8 20:53:44 +0000 2009 -------
Correction: 'gives the text below'.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 2811] Upgrading from 1.248 to latest breaks JNLP foreground slaves

Kohsuke Kawaguchi
Administrator
In reply to this post by markgruener
https://hudson.dev.java.net/issues/show_bug.cgi?id=2811



User kohsuke changed the following:

                What    |Old value                 |New value
================================================================================
                  Status|NEW                       |STARTED
--------------------------------------------------------------------------------




------- Additional comments from [hidden email] Fri Jan  9 22:40:38 +0000 2009 -------
Try the tips at http://www.elluminate.com/support/faqs/download_error.jsp and
let me know if that works.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 2811] Upgrading from 1.248 to latest breaks JNLP foreground slaves

Kohsuke Kawaguchi
Administrator
In reply to this post by markgruener
https://hudson.dev.java.net/issues/show_bug.cgi?id=2811






------- Additional comments from [hidden email] Wed Jan 21 01:59:47 +0000 2009 -------
Hi, any updates on this?

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 2811] Upgrading from 1.248 to latest breaks JNLP foreground slaves

markgruener
In reply to this post by markgruener
https://hudson.dev.java.net/issues/show_bug.cgi?id=2811






------- Additional comments from [hidden email] Wed Jan 21 14:56:26 +0000 2009 -------
Hi kohsuke,
     Clearing the javaws cache does not solve the problem.  After further
investigation I also noticed that other slaves and the master were having
issues, so I rolled back.  We currently have about 30 apps being built by Hudson
and it was too disruptive to continue my investigation.  I think I am going to
have our Unix people create a snapshot on another box so I can test further.
P.S.  It does seem that Hudson quality has gone down since people other than
yourself are committing:(


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 2811] Upgrading from 1.248 to latest breaks JNLP foreground slaves

Kohsuke Kawaguchi
Administrator
In reply to this post by markgruener
https://hudson.dev.java.net/issues/show_bug.cgi?id=2811



User kohsuke changed the following:

                What    |Old value                 |New value
================================================================================
                  Status|STARTED                   |RESOLVED
--------------------------------------------------------------------------------
                Priority|P1                        |P3
--------------------------------------------------------------------------------
              Resolution|                          |REMIND
--------------------------------------------------------------------------------




------- Additional comments from [hidden email] Thu Jul  9 19:24:39 +0000 2009 -------
Closing until we have additional information. So far this seems like an isolated
incident.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]