[Issue 316] New - JavaDoc link causes http-500 error when no javadoc was built

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Issue 316] New - JavaDoc link causes http-500 error when no javadoc was built

pmendelson-2
https://hudson.dev.java.net/issues/show_bug.cgi?id=316
                 Issue #|316
                 Summary|JavaDoc link causes http-500 error when no javadoc was
                        | built
               Component|hudson
                 Version|current
                Platform|All
              OS/Version|All
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|www
             Assigned to|issues@hudson
             Reported by|pmendelson






------- Additional comments from [hidden email] Tue Feb 20 12:38:36 +0000 2007 -------
If I configure a hudson project to publish javadoc at the end of a build, Hudson
then provides a view javadoc link.  If I never generated javadoc clicking on the
javadoc link will cause a stack trace.  IMO the software should do one of the
following:

1.  Declare the build a failure if the publish javadoc step can't find javadoc.
2.  Supress the view javadoc link if none was published.
3.  Replace the stack trace with a simple message that no javadoc was found.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]