[Issue 3298] New - WRONG JMETER REPORT GETTING GENERATED IN HUDSON

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[Issue 3298] New - WRONG JMETER REPORT GETTING GENERATED IN HUDSON

sabapathy
https://hudson.dev.java.net/issues/show_bug.cgi?id=3298
                 Issue #|3298
                 Summary|WRONG JMETER REPORT GETTING GENERATED IN HUDSON
               Component|hudson
                 Version|current
                Platform|All
              OS/Version|All
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|hudson.sfbay
             Assigned to|kohsuke
             Reported by|sabapathy






------- Additional comments from [hidden email] Tue Mar 17 08:21:57 +0000 2009 -------
The below target is used for running jmeter tests.
<target name="jmeter.tests" depends="run-load-tests" description="launch jmeter
load tests">
                <echo message="Starting jmeter tests..." />
                <jmeter
                        jmeterhome="jakarta-jmeter-2.3.2"
                        resultlog="${junitreport}/LoadTestResults.jtl">
                        <testplans dir="conf" includes="*.jmx"/>
                </jmeter>
        </target>

When I run the same from ant , I get a proper report but in Hudson plgin its
giving an errorous report.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3298] WRONG JMETER REPORT GETTING GENERATED IN HUDSON

sabapathy
https://hudson.dev.java.net/issues/show_bug.cgi?id=3298






------- Additional comments from [hidden email] Tue Mar 17 08:23:13 +0000 2009 -------
Created an attachment (id=618)
The correct HTML generated from buil script


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3298] WRONG JMETER REPORT GETTING GENERATED IN HUDSON

sabapathy
In reply to this post by sabapathy
https://hudson.dev.java.net/issues/show_bug.cgi?id=3298






------- Additional comments from [hidden email] Tue Mar 17 08:24:00 +0000 2009 -------
Created an attachment (id=619)
Wrong report generated by hudson


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3298] WRONG JMETER REPORT GETTING GENERATED IN HUDSON

sabapathy
In reply to this post by sabapathy
https://hudson.dev.java.net/issues/show_bug.cgi?id=3298






------- Additional comments from [hidden email] Tue Mar 17 08:24:51 +0000 2009 -------
Created an attachment (id=620)
Common jtl file for both


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3298] WRONG JMETER REPORT GETTING GENERATED IN HUDSON

sabapathy
In reply to this post by sabapathy
https://hudson.dev.java.net/issues/show_bug.cgi?id=3298






------- Additional comments from [hidden email] Tue Mar 17 08:28:31 +0000 2009 -------
Also the image of JMETER statistics report is not getting generated. Even after
enabling HEADLESS=TRUE


The log says

jmeter.tests:
     [echo] Starting jmeter tests...
   [jmeter] Executing test plan:
WebServiceSOAPRequest.jmx ==>

   [jmeter] Starting the test @ Tue Mar 17 08:04:44 CET 2009 (1237273484907)
   [jmeter] Tidying up ...    @ Tue Mar 17 08:05:14 CET 2009 (1237273514194)
   [jmeter] ... end of run

BUILD SUCCESSFUL
Total time: 1 minute 11 seconds
Recording test results
Recording JMeter reports SOATestSuite/junitreport/JMeterResults.jtl

jmeter report analysis is empty, ensure your jtl file is filled with samples.

finished: SUCCESS




---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3298] WRONG JMETER REPORT GETTING GENERATED IN HUDSON

Kohsuke Kawaguchi
Administrator
In reply to this post by sabapathy
https://hudson.dev.java.net/issues/show_bug.cgi?id=3298



User kohsuke changed the following:

                What    |Old value                 |New value
================================================================================
             Assigned to|kohsuke                   |issues@hudson
--------------------------------------------------------------------------------
              QA contact|kohsuke                   |vergnes
--------------------------------------------------------------------------------
            Subcomponent|hudson.sfbay              |jmeter
--------------------------------------------------------------------------------




------- Additional comments from [hidden email] Thu Jul  9 17:30:41 +0000 2009 -------
Reassigning.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]