[Issue 3505] New - Incorrect link in multi-configuration build

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Issue 3505] New - Incorrect link in multi-configuration build

pjhall
https://hudson.dev.java.net/issues/show_bug.cgi?id=3505
                 Issue #|3505
                 Summary|Incorrect link in multi-configuration build
               Component|hudson
                 Version|current
                Platform|All
              OS/Version|All
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|matrix
             Assigned to|issues@hudson
             Reported by|pjhall






------- Additional comments from [hidden email] Thu Apr 16 15:44:45 +0000 2009 -------
The 'Back to Project' link does not take the user back to the project when
viewing a build in a multi-configuration job.

e.g. the current page being viewed is
http://hudson.local:8080/job/test1/label=Fedora_8_64-bit/10/

the 'Back to Project' link points to
http://hudson.local:8080/job/test1/label=Fedora_8_64-bit/10/#10

which isn't useful.

I imagine this would be an easy fix...

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3505] Incorrect link in multi-configuration build

Alan Harder-2
https://hudson.dev.java.net/issues/show_bug.cgi?id=3505



User mindless changed the following:

                What    |Old value                 |New value
================================================================================
             Assigned to|issues@hudson             |mindless
--------------------------------------------------------------------------------




------- Additional comments from [hidden email] Sun Jul  5 19:21:33 +0000 2009 -------
started

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3505] Incorrect link in multi-configuration build

scm_issue_link
In reply to this post by pjhall
https://hudson.dev.java.net/issues/show_bug.cgi?id=3505



User scm_issue_link changed the following:

                What    |Old value                 |New value
================================================================================
                  Status|NEW                       |RESOLVED
--------------------------------------------------------------------------------
              Resolution|                          |FIXED
--------------------------------------------------------------------------------




------- Additional comments from [hidden email] Sun Jul  5 19:28:37 +0000 2009 -------
Code changed in hudson
User: : mindless
Path:
 trunk/hudson/main/core/src/main/java/hudson/matrix/MatrixRun.java
http://fisheye4.cenqua.com/changelog/hudson/?cs=19409
Log:
[FIXED HUDSON-3505] fix getUpUrl when parent is MatrixConfiguration.
(this makes a valid link for "Back to Project" in this case, though sidepanel
navigation between MatrixProject/Configuration/Build/Run could still be improved)


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]