[Issue 3513] New - SVN, TAG, "Get" in the form doesn't work

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Issue 3513] New - SVN, TAG, "Get" in the form doesn't work

nuage6
https://hudson.dev.java.net/issues/show_bug.cgi?id=3513
                 Issue #|3513
                 Summary|SVN, TAG, "Get" in the form doesn't work
               Component|hudson
                 Version|current
                Platform|All
              OS/Version|All
                     URL|http://xxx:8090/job/BuildPoken/655/tagBuild/
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|www
             Assigned to|issues@hudson
             Reported by|nuage6






------- Additional comments from [hidden email] Fri Apr 17 07:56:41 +0000 2009 -------
Problem

On http://xxx:8090/job/BuildPoken/656/tagBuild/
When you tag a version, all the things to be tagged are added to the url.

<a href="http://xxx:8090/job/BuildPoken/656/tagBuild/submit?tag0=on&name0=http%3A%2F%2Fsvn.poken.ch%2Fsvn%2">http://xxx:8090/job/BuildPoken/656/tagBuild/submit?tag0=on&name0=http%3A%2F%2Fsvn.poken.ch%2Fsvn%2...

And some browser don't support long url.

Our solution is to transform GET to POST (using WebDeveloper plugin on firefox)
and it works.

Gab

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3513] SVN, TAG, "Get" in the form doesn't work

Alan Harder-2
https://hudson.dev.java.net/issues/show_bug.cgi?id=3513



User mindless changed the following:

                What    |Old value                 |New value
================================================================================
             Assigned to|issues@hudson             |mindless
--------------------------------------------------------------------------------




------- Additional comments from [hidden email] Sun Jul  5 15:37:51 +0000 2009 -------
started

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3513] SVN, TAG, "Get" in the form doesn't work

scm_issue_link
In reply to this post by nuage6
https://hudson.dev.java.net/issues/show_bug.cgi?id=3513



User scm_issue_link changed the following:

                What    |Old value                 |New value
================================================================================
                  Status|NEW                       |RESOLVED
--------------------------------------------------------------------------------
              Resolution|                          |FIXED
--------------------------------------------------------------------------------




------- Additional comments from [hidden email] Sun Jul  5 15:48:24 +0000 2009 -------
Code changed in hudson
User: : mindless
Path:
 trunk/hudson/plugins/subversion/src/main/resources/hudson/scm/SubversionTagAction/tagForm.jelly
http://fisheye4.cenqua.com/changelog/hudson/?cs=19408
Log:
[FIXED HUDSON-3513] use post instead of get to avoid very long url


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]