[Issue 3788] New - "No artifacts are recorded. Is this a Maven project?" only for parallel builds

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Issue 3788] New - "No artifacts are recorded. Is this a Maven project?" only for parallel builds

jparent-2
https://hudson.dev.java.net/issues/show_bug.cgi?id=3788
                 Issue #|3788
                 Summary|"No artifacts are recorded. Is this a Maven project?"
                        |only for parallel builds
               Component|hudson
                 Version|current
                Platform|All
              OS/Version|All
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P1
            Subcomponent|build-publisher
             Assigned to|dvrzalik
             Reported by|jparent






------- Additional comments from [hidden email] Thu May 28 16:11:50 +0000 2009 -------
I recently enable deployment to a repo post-build action. The deploying part
works fine but whenever I activate parallel builds things go wrong. The top
level --aka parent -- pom.xml obviously has no artifact to deploy and so the
build is marked as failed pretty quickly. That's a problem :( Disable parallel
builds and it works!
 
Note that despite the build being marked a failed Hudson still launches the
parallel compilation of the modules

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3788] "No artifacts are recorded. Is this a Maven project?" only for parallel builds

dvrzalik
https://hudson.dev.java.net/issues/show_bug.cgi?id=3788



User dvrzalik changed the following:

                What    |Old value                 |New value
================================================================================
             Assigned to|dvrzalik                  |issues@hudson
--------------------------------------------------------------------------------
              QA contact|dvrzalik                  |issues@hudson
--------------------------------------------------------------------------------
            Subcomponent|build-publisher           |maven2
--------------------------------------------------------------------------------




------- Additional comments from [hidden email] Thu May 28 16:23:56 +0000 2009 -------
Wrong component...

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3788] "No artifacts are recorded. Is this a Maven project?" only for parallel builds

Kohsuke Kawaguchi
Administrator
In reply to this post by jparent-2
https://hudson.dev.java.net/issues/show_bug.cgi?id=3788



User kohsuke changed the following:

                What    |Old value                 |New value
================================================================================
                Priority|P1                        |P3
--------------------------------------------------------------------------------




------- Additional comments from [hidden email] Thu Jul  9 19:10:58 +0000 2009 -------
Given that there's a work around, re-prioritizing.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]