[Issue 3870] New - after build the slave fails

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Issue 3870] New - after build the slave fails

worsaae
https://hudson.dev.java.net/issues/show_bug.cgi?id=3870
                 Issue #|3870
                 Summary|after build the slave fails
               Component|hudson
                 Version|current
                Platform|All
              OS/Version|All
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|build-publisher
             Assigned to|dvrzalik
             Reported by|worsaae






------- Additional comments from [hidden email] Fri Jun 12 14:15:11 +0000 2009 -------
When building on master I have no problem
But when my (windows) slave have completed the build an exception happens:

checkstyle:
[checkstyle] Running Checkstyle 4.4 on 384 files

BUILD SUCCESSFUL
Total time: 3 minutes 4 seconds
Recording test results
FATAL: remote file operation failed
hudson.util.IOException2: remote file operation failed
        at hudson.FilePath.act(FilePath.java:631)
        at
hudson.plugins.violations.ViolationsPublisher.perform(ViolationsPublisher.java:77)
        at
hudson.tasks.BuildStepCompatibilityLayer.perform(BuildStepCompatibilityLayer.java:56)
        at
hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:372)
        at
hudson.model.AbstractBuild$AbstractRunner.performAllBuildStep(AbstractBuild.java:360)
        at hudson.model.Build$RunnerImpl.post2(Build.java:183)
        at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:345)
        at hudson.model.Run.run(Run.java:947)
        at hudson.model.Build.run(Build.java:112)
        at hudson.model.ResourceController.execute(ResourceController.java:93)
        at hudson.model.Executor.run(Executor.java:119)
Caused by: java.io.IOException: Remote call failed
        at hudson.remoting.Channel.call(Channel.java:518)
        at hudson.FilePath.act(FilePath.java:626)
        ... 10 more
Caused by: java.lang.NoClassDefFoundError: hudson/maven/MavenReporterDescriptor
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at hudson.remoting.RemoteClassLoader.findClass(RemoteClassLoader.java:108)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClassInternal(Unknown Source)
        at
hudson.plugins.violations.ViolationsCollector.invoke(ViolationsCollector.java:98)
        at
hudson.plugins.violations.ViolationsCollector.invoke(ViolationsCollector.java:27)
        at hudson.FilePath$FileCallableWrapper.call(FilePath.java:1642)
        at hudson.remoting.UserRequest.perform(UserRequest.java:103)
        at hudson.remoting.UserRequest.perform(UserRequest.java:47)
        at hudson.remoting.Request$2.run(Request.java:236)
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
        at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at hudson.remoting.Engine$1$1.run(Engine.java:54)
        at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException: hudson.maven.MavenReporterDescriptor
        at
hudson.remoting.RemoteClassLoader$ClassLoaderProxy.fetch(RemoteClassLoader.java:275)
        at sun.reflect.GeneratedMethodAccessor666.invoke(Unknown Source)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at
hudson.remoting.RemoteInvocationHandler$RPCRequest.perform(RemoteInvocationHandler.java:264)
        at hudson.remoting.Request$2.run(Request.java:236)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:885)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:907)
        at java.lang.Thread.run(Thread.java:619)


I have had the slave working weeks ago. It seem to have broken when i
updated hudson on the master

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3870] after build the slave fails

dvrzalik
https://hudson.dev.java.net/issues/show_bug.cgi?id=3870



User dvrzalik changed the following:

                What    |Old value                 |New value
================================================================================
             Assigned to|dvrzalik                  |peterkittreilly
--------------------------------------------------------------------------------
              QA contact|dvrzalik                  |peterkittreilly
--------------------------------------------------------------------------------
            Subcomponent|build-publisher           |violations
--------------------------------------------------------------------------------




------- Additional comments from [hidden email] Fri Jul  3 11:48:04 +0000 2009 -------
Wrong component...

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3870] after build the slave fails

peterkittreilly-2
In reply to this post by worsaae
https://hudson.dev.java.net/issues/show_bug.cgi?id=3870






------- Additional comments from [hidden email] Tue Jul  7 21:24:36 +0000 2009 -------
Can you try the latest version of violations?, it contains
a fix for this problem I think.

Peter


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3870] after build the slave fails

worsaae
In reply to this post by worsaae
https://hudson.dev.java.net/issues/show_bug.cgi?id=3870






------- Additional comments from [hidden email] Wed Jul  8 07:11:02 +0000 2009 -------
Running at violations 0.7.4 and hudson to 1.314
changed to java 1.6 and performed a javaws -uninstall
on the client

I am unable to reproduce the problem

Thank you

Lars

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]