[Issue 3937] New - Maven antrun classpath goes wrong inside hudson

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Issue 3937] New - Maven antrun classpath goes wrong inside hudson

bimargulies-2
https://hudson.dev.java.net/issues/show_bug.cgi?id=3937
                 Issue #|3937
                 Summary|Maven antrun classpath goes wrong inside hudson
               Component|hudson
                 Version|current
                Platform|Sun
              OS/Version|Linux
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P1
            Subcomponent|maven2
             Assigned to|issues@hudson
             Reported by|bimargulies






------- Additional comments from [hidden email] Fri Jun 26 14:01:17 +0000 2009 -------
I have a maven project that uses the maven-antrun-plugin to test some samples
that come with a build.xml file. It all works fine from command line.

In hudson, it fails, claiming that it can't find the compiler, due to a bad
JAVA_HOME.

A moderate level of googling failed to reveal a solution to me, and it seems to
me that from first principles what works at command level should also work in
hudson.


[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error executing ant tasks

Embedded error: The following error occurred while executing this line:
/home/hudson/jobs/etrog/workspace/etrog/lucene2.2/target/rlp-bl-lucene2.2-0.9-SNAPSHOT-all.dir/rlp-bl-lucene2.2-0.9-SNAPSHOT/samples/simple/build.xml:19:
Unable to find a javac compiler;
com.sun.tools.javac.Main is not on the classpath.
Perhaps JAVA_HOME does not point to the JDK
[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 3 minutes 49 seconds
[INFO] Finished at: Fri Jun 26 09:37:04 EDT 2009
[INFO] Final Memory: 50M/81M

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3937] Maven antrun classpath goes wrong inside hudson

Kohsuke Kawaguchi
Administrator
https://hudson.dev.java.net/issues/show_bug.cgi?id=3937



User kohsuke changed the following:

                What    |Old value                 |New value
================================================================================
                  Status|NEW                       |RESOLVED
--------------------------------------------------------------------------------
              Resolution|                          |INVALID
--------------------------------------------------------------------------------




------- Additional comments from [hidden email] Thu Jul  9 19:13:24 +0000 2009 -------
I believe this is the standard behavior of Maven antrun plugin. See
http://johnjianfang.blogspot.com/2009/03/maven-antrun-plugin.html for another
reference.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]