[Issue 3985] New - NullPointerException at startup when trying to get slave status

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Issue 3985] New - NullPointerException at startup when trying to get slave status

deanydean-2
https://hudson.dev.java.net/issues/show_bug.cgi?id=3985
                 Issue #|3985
                 Summary|NullPointerException at startup when trying to get sla
                        |ve status
               Component|hudson
                 Version|current
                Platform|Sun
              OS/Version|Solaris
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P3
            Subcomponent|master-slave
             Assigned to|issues@hudson
             Reported by|deanydean






------- Additional comments from [hidden email] Tue Jul  7 06:51:45 +0000 2009 -------
Hi all,

I'm getting a NullPointerException when my Hudson instance is starting up. The
following stack trace is displayed in the browser and in the error logs:

java.lang.NullPointerException
        at
com.youdevise.hudson.slavestatus.SlaveListenerInitiator.onOnline(SlaveListenerInitiator.java:38)
        at hudson.slaves.ComputerListener.onOnline(ComputerListener.java:118)
        at hudson.model.Hudson.(Hudson.java:589)
        at hudson.WebAppMain$2.run(WebAppMain.java:190)

When running my slave agent I get:

Failing to obtain http://<hostname>:8080/computer/<slavename>/slave-agent.jnlp
java.io.IOException: Failed to load
http://<hostname>:8080/computer/<slavename>/slave-agent.jnlp: 503 Service
Temporarily Unavailable
        at hudson.remoting.Launcher.parseJnlpArguments(Launcher.java:194)
        at hudson.remoting.Launcher.run(Launcher.java:169)
        at hudson.remoting.Launcher.main(Launcher.java:154)
Waiting 10 seconds before retry

I currently have zero functionality on my Hudson instance. Any workaround for
now would be great.

Master: OpenSolaris x86 w/ Hudson 1.314
Slave: OpenSolaris x86 using JNLP launch from slave.jar.

Thanks,

-- DD

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 3985] NullPointerException at startup when trying to get slave status

deanydean-2
https://hudson.dev.java.net/issues/show_bug.cgi?id=3985






------- Additional comments from [hidden email] Tue Jul  7 07:28:11 +0000 2009 -------
Workaround:

Remove the slave status plugin by removing the slave-status.hpi file and the
slave-status directory from .hudson/plugins.

This at least allows the server to startup.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]