[Issue 4933] New - User email address lookup in Perforce stopped working

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Issue 4933] New - User email address lookup in Perforce stopped working

torbent
https://hudson.dev.java.net/issues/show_bug.cgi?id=4933
                 Issue #|4933
                 Summary|User email address lookup in Perforce stopped working
               Component|hudson
                 Version|current
                Platform|All
              OS/Version|All
                     URL|
                  Status|NEW
       Status whiteboard|
                Keywords|
              Resolution|
              Issue type|DEFECT
                Priority|P2
            Subcomponent|perforce
             Assigned to|issues@hudson
             Reported by|torbent






------- Additional comments from [hidden email] Tue Nov 24 09:44:34 +0000 2009 -------
We used to have users' email addresses looked up in Perforce, but it has stopped
working. I *think* this happened in the 1.0.15 release of the plugin.
I found issue 1374 which was a request to implement this lookup in the first
place, and stumbled upon issue 1022 where the submitter mentions a change to
PerforceMailResolver in October (fits with 1.0.15).
Symptom: Mail is sent to "username" instead of "email address" (for users not
already registered in Hudson's list of people).

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 4933] User email address lookup in Perforce stopped working

emmulator
https://hudson.dev.java.net/issues/show_bug.cgi?id=4933






------- Additional comments from [hidden email] Tue Nov 24 18:08:45 +0000 2009 -------
Were you using Matrix builds, or did you have any slave nodes?  I'm the one who
made the change to the PerforceMailResolver.  It was relying on an instance
variable that was volitile in a distributed build environment.  I suspect that
it only worked when there was only one node, or perhaps it worked so long as it
was called before any distributed builds had run.  I didn't see any way to fix
it while also supporting distributed matrix builds.

Isn't there a simple workaround in that you can just edit the user's information
to set the email address manually?  I realize that's not ideal, but there's no
equivalent workaround for broken distributed builds, so unless someone can
figure out how to support both, I think the distributed builds are more
important than getting email addresses from perforce.  I'm sure it is possible
to do both, I just didn't see how when I looked at it.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 4933] User email address lookup in Perforce stopped working

emmulator
In reply to this post by torbent
https://hudson.dev.java.net/issues/show_bug.cgi?id=4933






------- Additional comments from [hidden email] Tue Nov 24 18:10:12 +0000 2009 -------
http://n4.nabble.com/PerforceMailResolver-is-broken-td395080.html

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[Issue 4933] User email address lookup in Perforce stopped working

torbent
In reply to this post by torbent
https://hudson.dev.java.net/issues/show_bug.cgi?id=4933






------- Additional comments from [hidden email] Tue Nov 24 18:26:34 +0000 2009 -------
No, not using Matrix builds (yet - am considering it, but hesitant).
Yes, have some slaves. I haven't verified whether email lookup only fails on
slaves or also on Master.
As far as I recall, the email lookup used to take place at the end of the build,
when/if it was necessary in order to blame someone. But I could be wrong.

Yes, I can (and have) edit the users when this happens, which it fortunately
rarely does these days, but a fix would definitely be nice. I agree that matrix
builds are more important, though :-)

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]