Issue with Warnings NG

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Issue with Warnings NG

christop...@googlemail.com

I have two different kinds of jobs:
one is installing all the requirements for a job from a storage, building one package and collecting warnings and cppcheck results with warnings ng. Here everything works fine, display of warnings and cppcheck-analysis works.
In another jobs I am building all the requirements within the job and I am collecting cppcheck results and warnings separately for every module (32 modules overall). (I am aware this might not be the best choice, I am working at a redesign but this is only one open task).

I am calling warnings-ng with different names and ids respectively:

    recordIssues tools: [cppCheck(pattern:"${MODULE_PATH}/**/cppcheck-result-*.xml", id: "CppCheck-${MODULE}_${PLATFORM}_${VARIANT}", name: "CppCheck-${MODULE}_${PLATFORM}_${VARIANT}") ]
    recordIssues tools: [ msBuild( id: "${MODULE}_${PLATFORM}_${VARIANT}", name: "${MODULE} ${PLATFORM} ${VARIANT}" ) ]
(there are additional options that difer between both calls, that's why there are two separate calls).
In this kind of job, display a the Jenkins UI does not completely work. I get the history plots in the UI but the links to the complete display do not work.

Any ideas for me? Is it my failure or does the plugin not like so many results?

TIA for any kind of assistance!
Regards,
Christoph

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/c4562bdb-47f8-4189-b7a8-20d730baf668n%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Issue with Warnings NG

Ulli Hafner

Am 21.08.2020 um 12:02 schrieb '[hidden email]' via Jenkins Users <[hidden email]>:


I have two different kinds of jobs:
one is installing all the requirements for a job from a storage, building one package and collecting warnings and cppcheck results with warnings ng. Here everything works fine, display of warnings and cppcheck-analysis works.
In another jobs I am building all the requirements within the job and I am collecting cppcheck results and warnings separately for every module (32 modules overall). (I am aware this might not be the best choice, I am working at a redesign but this is only one open task).

I am calling warnings-ng with different names and ids respectively:

    recordIssues tools: [cppCheck(pattern:"${MODULE_PATH}/**/cppcheck-result-*.xml", id: "CppCheck-${MODULE}_${PLATFORM}_${VARIANT}", name: "CppCheck-${MODULE}_${PLATFORM}_${VARIANT}") ]
    recordIssues tools: [ msBuild( id: "${MODULE}_${PLATFORM}_${VARIANT}", name: "${MODULE} ${PLATFORM} ${VARIANT}" ) ]
(there are additional options that difer between both calls, that's why there are two separate calls).
In this kind of job, display a the Jenkins UI does not completely work. I get the history plots in the UI but the links to the complete display do not work.

What does not work, can you please elaborate? Is the link wrong, or does the chart not react on click events? When the link is wrong, what is the link URL?

Does it help if you place the id and name outside of the tools section? 



Any ideas for me? Is it my failure or does the plugin not like so many results?

TIA for any kind of assistance!
Regards,
Christoph

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/c4562bdb-47f8-4189-b7a8-20d730baf668n%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/98A77A67-D53F-4904-A0DA-AAE5C23D45F6%40gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: Issue with Warnings NG

christop...@googlemail.com
Working link to cppcheck:
http://%SERVER%:8080/job/%JOBNAME%/905/cppcheck
created by that call:
recordIssues tools: [cppCheck(pattern:'**/cppcheck-result-*.xml', name: "CppCheck") ]

Not working link:
http://%SERVER%:8080/job/%OTHER-JOBNAME%/ 305/CppCheck-%MODULENAME%_win32vc9_release
-> ah, there is a forward slash in the module name like in %PRODUCT%/src

this is the call:
    recordIssues tools: [cppCheck(pattern:"${MODULE_PATH}/**/cppcheck-result-*.xml", id: "CppCheck-${MODULE}_${PLATFORM}_${VARIANT}", name: "CppCheck-${MODULE}_${PLATFORM}_${VARIANT}") ]

Let me remove the slashes from the module and give it another try. I'll come back with the result but it will run for a while.....

By the way, the failure is: when I click the link I see the browser asking for a forwarding for a short time, then I am back on the page of the build (http://%SERVER%:8080/job/%OTHER-JOBNAME%/ 305/ )

Maybe this helped to solve the issue, thanks so far!

Regards,
Christoph




[hidden email] schrieb am Freitag, 21. August 2020 um 13:42:54 UTC+2:

Am 21.08.2020 um 12:02 schrieb '[hidden email]' via Jenkins Users <[hidden email]>:



I have two different kinds of jobs:
one is installing all the requirements for a job from a storage, building one package and collecting warnings and cppcheck results with warnings ng. Here everything works fine, display of warnings and cppcheck-analysis works.
In another jobs I am building all the requirements within the job and I am collecting cppcheck results and warnings separately for every module (32 modules overall). (I am aware this might not be the best choice, I am working at a redesign but this is only one open task).

I am calling warnings-ng with different names and ids respectively:

    recordIssues tools: [cppCheck(pattern:"${MODULE_PATH}/**/cppcheck-result-*.xml", id: "CppCheck-${MODULE}_${PLATFORM}_${VARIANT}", name: "CppCheck-${MODULE}_${PLATFORM}_${VARIANT}") ]
    recordIssues tools: [ msBuild( id: "${MODULE}_${PLATFORM}_${VARIANT}", name: "${MODULE} ${PLATFORM} ${VARIANT}" ) ]
(there are additional options that difer between both calls, that's why there are two separate calls).
In this kind of job, display a the Jenkins UI does not completely work. I get the history plots in the UI but the links to the complete display do not work.

What does not work, can you please elaborate? Is the link wrong, or does the chart not react on click events? When the link is wrong, what is the link URL?

Does it help if you place the id and name outside of the tools section? 



Any ideas for me? Is it my failure or does the plugin not like so many results?

TIA for any kind of assistance!
Regards,
Christoph

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/c4562bdb-47f8-4189-b7a8-20d730baf668n%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/d68cea32-8703-4b22-9472-7c8fc40f8a3en%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Issue with Warnings NG

christop...@googlemail.com
Excuse me, it took a while, there is a lot going on in the software currently and I had no complete builds.
It helped to replace the path separators with hyphens.
Thanks for listening!

Best regards,
Christoph

[hidden email] schrieb am Freitag, 21. August 2020 um 14:01:14 UTC+2:
Working link to cppcheck:
http://%SERVER%:8080/job/%JOBNAME%/905/cppcheck
created by that call:
recordIssues tools: [cppCheck(pattern:'**/cppcheck-result-*.xml', name: "CppCheck") ]

Not working link:
http://%SERVER%:8080/job/%OTHER-JOBNAME%/ 305/CppCheck-%MODULENAME%_win32vc9_release
-> ah, there is a forward slash in the module name like in %PRODUCT%/src

this is the call:
    recordIssues tools: [cppCheck(pattern:"${MODULE_PATH}/**/cppcheck-result-*.xml", id: "CppCheck-${MODULE}_${PLATFORM}_${VARIANT}", name: "CppCheck-${MODULE}_${PLATFORM}_${VARIANT}") ]

Let me remove the slashes from the module and give it another try. I'll come back with the result but it will run for a while.....

By the way, the failure is: when I click the link I see the browser asking for a forwarding for a short time, then I am back on the page of the build (http://%SERVER%:8080/job/%OTHER-JOBNAME%/ 305/ )

Maybe this helped to solve the issue, thanks so far!

Regards,
Christoph




[hidden email] schrieb am Freitag, 21. August 2020 um 13:42:54 UTC+2:

Am 21.08.2020 um 12:02 schrieb '[hidden email]' via Jenkins Users <[hidden email]>:



I have two different kinds of jobs:
one is installing all the requirements for a job from a storage, building one package and collecting warnings and cppcheck results with warnings ng. Here everything works fine, display of warnings and cppcheck-analysis works.
In another jobs I am building all the requirements within the job and I am collecting cppcheck results and warnings separately for every module (32 modules overall). (I am aware this might not be the best choice, I am working at a redesign but this is only one open task).

I am calling warnings-ng with different names and ids respectively:

    recordIssues tools: [cppCheck(pattern:"${MODULE_PATH}/**/cppcheck-result-*.xml", id: "CppCheck-${MODULE}_${PLATFORM}_${VARIANT}", name: "CppCheck-${MODULE}_${PLATFORM}_${VARIANT}") ]
    recordIssues tools: [ msBuild( id: "${MODULE}_${PLATFORM}_${VARIANT}", name: "${MODULE} ${PLATFORM} ${VARIANT}" ) ]
(there are additional options that difer between both calls, that's why there are two separate calls).
In this kind of job, display a the Jenkins UI does not completely work. I get the history plots in the UI but the links to the complete display do not work.

What does not work, can you please elaborate? Is the link wrong, or does the chart not react on click events? When the link is wrong, what is the link URL?

Does it help if you place the id and name outside of the tools section? 



Any ideas for me? Is it my failure or does the plugin not like so many results?

TIA for any kind of assistance!
Regards,
Christoph

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/c4562bdb-47f8-4189-b7a8-20d730baf668n%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/f529532c-2ab9-4891-9da5-57e02c5accc8n%40googlegroups.com.