Issue with mvn clean build using the latest cvs update

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Issue with mvn clean build using the latest cvs update

Sandeep Konchady
Hi,

    I did a cvs update this morning of the hudson source base and wanted to do a mvn clean install. Unfortunately I am facing an issue with tools plugin. Any idea why this could be happening?

Hudson\hudson\hudson>mvn clean
[INFO] Scanning for projects...
[INFO] Reactor build order:
[INFO]   Hudson
[INFO]   Hudson main module
[INFO]   Hudson remoting layer
[INFO]   Hudson core
[INFO]   Hudson JNLP slave agent
[INFO]   Hudson war
[INFO]   Hudson tools
[INFO]   Maven Hudson Plugin
[INFO]   Hudson plugin POM
[INFO]   Hudson build timeout plugin
[INFO]   Hudson Emma plugin
[INFO]   Hudson hello-world plugin
[INFO]   Hudson IRC Plugin
[INFO]   Hudson JAPEX plugin
[INFO]   Hudson JavaTest report plugin
[INFO]   Hudson java.net uploader plugin
[INFO]   Hudson java.net CVS/SVN build trigger plugin
[INFO]   Hudson JMX Plugin
[INFO]   Hudson JWSDP SQE test report plugin
[INFO]   Hudson JPRT plugin
[INFO]   Hudson promoted builds testplugin
[INFO]   Hudson TextFinder plugin
[INFO]   Hudson Xvnc plugin
[INFO] -------------------------------------------------------------------------
---
[INFO] Building Hudson
[INFO]    task-segment: [clean]
[INFO] -------------------------------------------------------------------------
---
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).


Project ID: org.apache.maven.plugins:maven-clean-plugin

Reason: Error getting POM for 'org.apache.maven.plugins:maven-clean-plugin' from
 the repository: Failed to resolve artifact, possibly due to a repository list t
hat is not appropriately equipped for this artifact's metadata.
  org.apache.maven.plugins:maven-clean-plugin:pom:2.2-SNAPSHOT

from the specified remote repositories:
  m2-snapshot (http://people.apache.org/maven-snapshot-repository/),
  central (http://repo1.maven.org/maven2),
  java.net2 (https://maven2-repository.dev.java.net/nonav/repository)



[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: < 1 second
[INFO] Finished at: Tue Feb 20 13:25:03 PST 2007
[INFO] Final Memory: 5M/54M
[INFO] ------------------------------------------------------------------------

Thanks,
Sandeep
--
Sandeep Konchady

Sun Microsystems, Inc.
4220 Network Circle, USCA22-124
Santa Clara, CA 95054 US
Phone x17475/+1 408 276 7475
Mobile 408-420-7263
Email [hidden email]
My Blog

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issue with mvn clean build using the latest cvs update

Kohsuke Kawaguchi-2
Sandeep Konchady wrote:

> Project ID: org.apache.maven.plugins:maven-clean-plugin
>
> Reason: Error getting POM for
> 'org.apache.maven.plugins:maven-clean-plugin' from
>  the repository: Failed to resolve artifact, possibly due to a
> repository list t
> hat is not appropriately equipped for this artifact's metadata.
>   org.apache.maven.plugins:maven-clean-plugin:pom:2.2-SNAPSHOT
>
> from the specified remote repositories:
>   m2-snapshot (http://people.apache.org/maven-snapshot-repository/),
>   central (http://repo1.maven.org/maven2),
>   java.net2 (https://maven2-repository.dev.java.net/nonav/repository)
Somewhere in POM you have m2-snapshot reference. Try removing those.

I couldn't find it in any of the POM in the workspace, so I suspect it's
your local change, or maybe even in ~/.m2/settings.xml


--
Kohsuke Kawaguchi
Sun Microsystems                   [hidden email]

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issue with mvn clean build using the latest cvs update

Sandeep Konchady

As always thanks for the prompt reply. Yes it was in my local copy and it is fixed now.

- Sandeep

Kohsuke Kawaguchi wrote:
Sandeep Konchady wrote:
Project ID: org.apache.maven.plugins:maven-clean-plugin

Reason: Error getting POM for 'org.apache.maven.plugins:maven-clean-plugin' from
 the repository: Failed to resolve artifact, possibly due to a repository list t
hat is not appropriately equipped for this artifact's metadata.
  org.apache.maven.plugins:maven-clean-plugin:pom:2.2-SNAPSHOT

from the specified remote repositories:
  m2-snapshot (http://people.apache.org/maven-snapshot-repository/),
  central (http://repo1.maven.org/maven2),
  java.net2 (https://maven2-repository.dev.java.net/nonav/repository)

Somewhere in POM you have m2-snapshot reference. Try removing those.

I couldn't find it in any of the POM in the workspace, so I suspect it's your local change, or maybe even in ~/.m2/settings.xml

--
Sandeep Konchady

Sun Microsystems, Inc.
4220 Network Circle, USCA22-124
Santa Clara, CA 95054 US
Phone x17475/+1 408 276 7475
Mobile 408-420-7263
Email [hidden email]
My Blog

smime.p7s (4K) Download Attachment