Issue with upgrading to Jenkins 2.76

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Issue with upgrading to Jenkins 2.76

Rijo Simon
I have been building a plugin project in 2.60.3, but now I need to upgrade to 2.76 because my understanding is that you need to upgrade to this version to have Multibranch Pipeline item under New Items tab. But on updating jenkins.version to 2.76 I get the following error:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-
plugin:1.3.1:enforce (display-info) on project XXX: 
Execution display-info of goal org.apache.maven.plugins:maven-enforcer-
plugin:1.3.1:enforce failed: org.apache.maven.shared.dependency.graph. 
DependencyGraphBuilderException : Could not resolve dependencies for 
project XXX:XXX:hpi:1.0-SNAPSHOT: 
Failure to find org.jenkins-ci.main:jenkins-war:jar:war-for-test:2.76 
in https://repo.jenkins-ci.org/public/ was cached in the local 
repository, resolution will not be reattempted until the update 
interval of repo.jenkins-ci.org has elapsed or updates are forced -> 
[Help 1]

I don't understand how to resolve this. Help would be appreciated.

My POM file is attached below.

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/4fa44cf1-31b7-4b95-9d3d-78990a450ddf%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

pom.xml (3K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issue with upgrading to Jenkins 2.76

Jesse Glick-4
On Tue, Jan 2, 2018 at 1:04 PM, Rijo Simon <[hidden email]> wrote:
> Failure to find org.jenkins-ci.main:jenkins-war:jar:war-for-test:2.76

You are using an old parent POM; update it.

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/CANfRfr10Cj2dzxcx8KyJooVJ8KeRQvca91RtE33yGPzCc%3DhG4A%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Issue with upgrading to Jenkins 2.76

Daniel Beck
In reply to this post by Rijo Simon

> On 2. Jan 2018, at 19:04, Rijo Simon <[hidden email]> wrote:
>
> I don't understand how to resolve this.

Update to a more recent parent POM; war-for-test artifacts have been discontinued.

See https://github.com/jenkinsci/plugin-pom/blob/master/CHANGELOG.md

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/B3678BDA-4B3E-4D3A-A2F3-DA4BDD9F9780%40beckweb.net.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Issue with upgrading to Jenkins 2.76

Rijo Simon
Newbie to both Jenkins dev and maven, so sorry if this sounds dumb. What do you mean by update to a more recent parent POM? On updating the version of for org.jenkins-ci.plugins to 3.1 I get the following error: 


[ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M1:enforce (display-info) on project gobuildsandboxbuilder: Execution display-info of goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M1:enforce failed: Unknown JDK version given. Should be something like "1.7" -> [Help 1]


Also the model version for the POM is 4.0.0, what specifically should I be updating to update to a more recent POM?


Thanks,

Rijo


On Tuesday, January 2, 2018 at 10:23:12 AM UTC-8, Daniel Beck wrote:

> On 2. Jan 2018, at 19:04, Rijo Simon <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="u0wLNyMOEQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">ri...@...> wrote:
>
> I don't understand how to resolve this.

Update to a more recent parent POM; war-for-test artifacts have been discontinued.

See <a href="https://github.com/jenkinsci/plugin-pom/blob/master/CHANGELOG.md" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fjenkinsci%2Fplugin-pom%2Fblob%2Fmaster%2FCHANGELOG.md\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEUzPfjyHI86RB1fyxtTwsBlN_TcQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fjenkinsci%2Fplugin-pom%2Fblob%2Fmaster%2FCHANGELOG.md\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNEUzPfjyHI86RB1fyxtTwsBlN_TcQ&#39;;return true;">https://github.com/jenkinsci/plugin-pom/blob/master/CHANGELOG.md

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/6ea4bb09-f574-4221-9100-45f229639d5c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Issue with upgrading to Jenkins 2.76

Daniel Beck

> On 2. Jan 2018, at 19:53, Rijo Simon <[hidden email]> wrote:
>
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M1:enforce (display-info) on project gobuildsandboxbuilder: Execution display-info of goal org.apache.maven.plugins:maven-enforcer-plugin:3.0.0-M1:enforce failed: Unknown JDK version given. Should be something like "1.7" -> [Help 1]
>

You need to adapt to other changes in the parent pom, such as explicitly specifying a JDK version. The changelog I link to should give you an overview what may be needed.

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/286E1EBD-FC9E-4132-AECA-692CCE3FB3D3%40beckweb.net.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

org.jenkins-ci.main:jenkins-war:executable-war:2.73.3 cannot be resolved (Was: Re: Issue with upgrading to Jenkins 2.76)

Ulli Hafner
In reply to this post by Daniel Beck
I’m not sure if this is related: I get in IntelliJ an error for my plug-ins that the artefact org.jenkins-ci.main:jenkins-war:executable-war:2.73.3 cannot be resolved. (See screenshot)
I’m using plugin parent 3.2 and test harness 2.33.

Is there a way to get around this error? (There is not problem using mvn in the console.)

Am 02.01.2018 um 19:23 schrieb Daniel Beck <[hidden email]>:


On 2. Jan 2018, at 19:04, Rijo Simon <[hidden email]> wrote:

I don't understand how to resolve this.

Update to a more recent parent POM; war-for-test artifacts have been discontinued.

See https://github.com/jenkinsci/plugin-pom/blob/master/CHANGELOG.md

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/B3678BDA-4B3E-4D3A-A2F3-DA4BDD9F9780%40beckweb.net.
For more options, visit https://groups.google.com/d/optout.


--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/136752D5-EAD4-4E0B-A74D-59B25DFE19F8%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

signature.asc (540 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: org.jenkins-ci.main:jenkins-war:executable-war:2.73.3 cannot be resolved (Was: Re: Issue with upgrading to Jenkins 2.76)

Jesse Glick-4
I suppose this is an aspect of JENKINS-45245, but if the test actually
runs (as it should in JTH 2.27+), why do you care?

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/CANfRfr03rtCV-ab%3DCOkjg-jdk12KxGQPoCuw%2BBMJHZJtfq%3Di0g%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: org.jenkins-ci.main:jenkins-war:executable-war:2.73.3 cannot be resolved (Was: Re: Issue with upgrading to Jenkins 2.76)

Ulli Hafner
Well, I just do not like red squiggles somewhere in the project. It looks like a compile error - so if I ignore it now I might ignore some other important red squiggles in the future...

> Am 05.01.2018 um 01:01 schrieb Jesse Glick <[hidden email]>:
>
> I suppose this is an aspect of JENKINS-45245, but if the test actually
> runs (as it should in JTH 2.27+), why do you care?
>
> --
> You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
> To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/CANfRfr03rtCV-ab%3DCOkjg-jdk12KxGQPoCuw%2BBMJHZJtfq%3Di0g%40mail.gmail.com.
> For more options, visit https://groups.google.com/d/optout.
--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/C53B64C7-F7DA-4442-ACD0-83EF83C0EE15%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

signature.asc (540 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: org.jenkins-ci.main:jenkins-war:executable-war:2.73.3 cannot be resolved (Was: Re: Issue with upgrading to Jenkins 2.76)

Jesse Glick-4
On Thu, Jan 4, 2018 at 7:26 PM, Ullrich Hafner <[hidden email]> wrote:
> I just do not like red squiggles somewhere in the project. It looks like a compile error

Right. Well, other than voting for the known IDEA bug, not sure what
to tell you.

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/CANfRfr3Ed%3D%2BHz90E%3DMQi3-LH_jhCMm2nO0Do97SdyFwjOVRatA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.