[JIRA] Commented: (JENKINS-8426) after first message, jabber doesn't return any messages

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[JIRA] Commented: (JENKINS-8426) after first message, jabber doesn't return any messages

JIRA noreply@jenkins-ci.org

    [ http://issues.jenkins-ci.org/browse/JENKINS-8426?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=145759#comment-145759 ]

kutzi commented on JENKINS-8426:
--------------------------------

Please try the plugins attached to JENKINS-7060. They use a new, beta version of the Smack library which should fix a lot of bugs.

> after first message, jabber doesn't return any messages
> -------------------------------------------------------
>
>                 Key: JENKINS-8426
>                 URL: http://issues.jenkins-ci.org/browse/JENKINS-8426
>             Project: Jenkins
>          Issue Type: Bug
>          Components: jabber
>    Affects Versions: current
>         Environment: Hudson: 1.389
> OS: Centos 5.3
> Latest released instant-messaging and jabber plugins as of date ticket opened
>            Reporter: peterkline
>            Assignee: kutzi
>             Fix For: current
>
>
> Everything was working great for a few minutes.  We issued a bunch of commands and all was good. We then went back awhile later and no output was being received.  We are using a standard jabber.org account.  We can see from the server log that messages from our IM client are reaching the server but we just don't get anything back.  If we bounce the config (not rebooting or restarting hudson) we can see the hudson jabber disconnect/reconnect.  We can then send 1 command and get a response.  After that we get nothing back (the !status command for example).
> Hudson Server Log:
> Jan 5, 2011 1:46:35 PM hudson.plugins.jabber.im.transport.JabberIMConnection$PrivateChatListener processPacket
> INFO: Message from [hidden email]/gmail.071F0034 : !status
> Jan 5, 2011 1:46:31 PM hudson.plugins.jabber.im.transport.JabberIMConnection$PrivateChatListener processPacket
> INFO: Message from [hidden email]/gmail.071F0034 : !help
> Jan 5, 2011 1:46:21 PM hudson.plugins.jabber.im.transport.JabberIMConnection connect
> INFO: Connected to XMPP on jabber.org:5222/jabber.org using TLS
> Jan 5, 2011 1:46:21 PM hudson.plugins.jabber.im.transport.JabberIMConnection setupSubscriptionMode
> INFO: Accepting all subscription requests
> Jan 5, 2011 1:46:20 PM hudson.plugins.im.IMConnectionProvider$ConnectorRunnable run
> INFO: Trying to reconnect

--
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira