[JIRA] Created: (HUDSON-5644) Perforce SCM polling not working (NPE)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[JIRA] Created: (HUDSON-5644) Perforce SCM polling not working (NPE)

Hudson issues mailing list
Perforce SCM polling not working (NPE)
--------------------------------------

                 Key: HUDSON-5644
                 URL: http://issues.hudson-ci.org/browse/HUDSON-5644
             Project: Hudson
          Issue Type: Bug
          Components: perforce
         Environment: Windows XP Pro SP3, Hudson 1.346, Perforce Plugin 1.0.19, Perforce Client 2009.2/232252, Perforce Server 2009.1/222893
            Reporter: jnilsson


Since my latest Hudson upgrade, including upgrading the Perforce plugin, the SCM polling seems to have stopped working completely. If I check the Perforce Polling Log from the UI, I only see this:

{noformat}
Started on 2010-feb-16 09:10:34
Looking for changes...
Using master perforce client: bkgnd-master1-elib-main
{noformat}

At the Hudson console, the following is displayed:

{noformat}
$ C:\dev\scm\p4\p4.exe workspace -o bkgnd-master1-elib-main
{noformat}
...
{noformat}
2010-feb-16 09:10:34 hudson.triggers.SCMTrigger$Runner runPolling
ALLVARLIG: Failed to record SCM polling
java.lang.NullPointerException
        at hudson.plugins.perforce.PerforceSCM.getPerforceWorkspace(PerforceSCM.java:739)
        at hudson.plugins.perforce.PerforceSCM.pollChanges(PerforceSCM.java:538)
        at hudson.scm.SCM.poll(SCM.java:344)
        at hudson.model.AbstractProject.poll(AbstractProject.java:1150)
        at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:319)
        at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:346)
        at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
        at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)
{noformat}

Any hints on how to troubleshoot?

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.hudson-ci.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[JIRA] Commented: (HUDSON-5644) Perforce SCM polling not working (NPE)

Hudson issues mailing list

    [ http://issues.hudson-ci.org/browse/HUDSON-5644?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=136024#action_136024 ]

scm_issue_link commented on HUDSON-5644:
----------------------------------------

Code changed in hudson
User: : rpetti
Path:
 trunk/hudson/plugins/perforce/src/main/java/hudson/plugins/perforce/PerforceSCM.java
http://hudson-ci.org/commit/27555
Log:
[FIXED HUDSON-5644] re-enabling 'requiresworkspaceforpolling' since it breaks polling outright.


> Perforce SCM polling not working (NPE)
> --------------------------------------
>
>                 Key: HUDSON-5644
>                 URL: http://issues.hudson-ci.org/browse/HUDSON-5644
>             Project: Hudson
>          Issue Type: Bug
>          Components: perforce
>         Environment: Windows XP Pro SP3, Hudson 1.346, Perforce Plugin 1.0.19, Perforce Client 2009.2/232252, Perforce Server 2009.1/222893
>            Reporter: jnilsson
>
> Since my latest Hudson upgrade, including upgrading the Perforce plugin, the SCM polling seems to have stopped working completely. If I check the Perforce Polling Log from the UI, I only see this:
> {noformat}
> Started on 2010-feb-16 09:10:34
> Looking for changes...
> Using master perforce client: bkgnd-master1-elib-main
> {noformat}
> At the Hudson console, the following is displayed:
> {noformat}
> $ C:\dev\scm\p4\p4.exe workspace -o bkgnd-master1-elib-main
> {noformat}
> ...
> {noformat}
> 2010-feb-16 09:10:34 hudson.triggers.SCMTrigger$Runner runPolling
> ALLVARLIG: Failed to record SCM polling
> java.lang.NullPointerException
> at hudson.plugins.perforce.PerforceSCM.getPerforceWorkspace(PerforceSCM.java:739)
> at hudson.plugins.perforce.PerforceSCM.pollChanges(PerforceSCM.java:538)
> at hudson.scm.SCM.poll(SCM.java:344)
> at hudson.model.AbstractProject.poll(AbstractProject.java:1150)
> at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:319)
> at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:346)
> at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
> at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
> at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
> at java.util.concurrent.FutureTask.run(Unknown Source)
> at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
> at java.lang.Thread.run(Unknown Source)
> {noformat}
> Any hints on how to troubleshoot?

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.hudson-ci.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[JIRA] Resolved: (HUDSON-5644) Perforce SCM polling not working (NPE)

Hudson issues mailing list
In reply to this post by Hudson issues mailing list

     [ http://issues.hudson-ci.org/browse/HUDSON-5644?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

scm_issue_link resolved HUDSON-5644.
------------------------------------

    Resolution: Fixed

> Perforce SCM polling not working (NPE)
> --------------------------------------
>
>                 Key: HUDSON-5644
>                 URL: http://issues.hudson-ci.org/browse/HUDSON-5644
>             Project: Hudson
>          Issue Type: Bug
>          Components: perforce
>         Environment: Windows XP Pro SP3, Hudson 1.346, Perforce Plugin 1.0.19, Perforce Client 2009.2/232252, Perforce Server 2009.1/222893
>            Reporter: jnilsson
>
> Since my latest Hudson upgrade, including upgrading the Perforce plugin, the SCM polling seems to have stopped working completely. If I check the Perforce Polling Log from the UI, I only see this:
> {noformat}
> Started on 2010-feb-16 09:10:34
> Looking for changes...
> Using master perforce client: bkgnd-master1-elib-main
> {noformat}
> At the Hudson console, the following is displayed:
> {noformat}
> $ C:\dev\scm\p4\p4.exe workspace -o bkgnd-master1-elib-main
> {noformat}
> ...
> {noformat}
> 2010-feb-16 09:10:34 hudson.triggers.SCMTrigger$Runner runPolling
> ALLVARLIG: Failed to record SCM polling
> java.lang.NullPointerException
> at hudson.plugins.perforce.PerforceSCM.getPerforceWorkspace(PerforceSCM.java:739)
> at hudson.plugins.perforce.PerforceSCM.pollChanges(PerforceSCM.java:538)
> at hudson.scm.SCM.poll(SCM.java:344)
> at hudson.model.AbstractProject.poll(AbstractProject.java:1150)
> at hudson.triggers.SCMTrigger$Runner.runPolling(SCMTrigger.java:319)
> at hudson.triggers.SCMTrigger$Runner.run(SCMTrigger.java:346)
> at hudson.util.SequentialExecutionQueue$QueueEntry.run(SequentialExecutionQueue.java:118)
> at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
> at java.util.concurrent.FutureTask$Sync.innerRun(Unknown Source)
> at java.util.concurrent.FutureTask.run(Unknown Source)
> at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
> at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
> at java.lang.Thread.run(Unknown Source)
> {noformat}
> Any hints on how to troubleshoot?

--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.hudson-ci.org/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]