[JIRA] (JENKINS-12183) SVNMerge plugin does not work with SVN plugin version 1.37, but works with 1.34

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

[JIRA] (JENKINS-12183) SVNMerge plugin does not work with SVN plugin version 1.37, but works with 1.34

JIRA noreply@jenkins-ci.org
sergei sergei created JENKINS-12183:
---------------------------------------

             Summary: SVNMerge plugin does not work with SVN plugin version 1.37, but works with 1.34
                 Key: JENKINS-12183
                 URL: https://issues.jenkins-ci.org/browse/JENKINS-12183
             Project: Jenkins
          Issue Type: Bug
          Components: svnmerge
    Affects Versions: current
            Reporter: sergei sergei
            Assignee: Kohsuke Kawaguchi


I have used svn merge plugin together with svn plugin v1.34 and it all worked fine. Some time ago I updated svn plugin to the latest one 1.37 and svnmerge stopped working.

Try creating a feature branch and it gives some svn error.
There's something wrong with svnm.getCopyClient().doCopy which complains about wrong paths passed as arguments, while it all worked fine with 1.34

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.jenkins-ci.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[JIRA] (JENKINS-12183) SVNMerge plugin does not work with SVN plugin version 1.37, but works with 1.34

JIRA noreply@jenkins-ci.org

    [ https://issues.jenkins-ci.org/browse/JENKINS-12183?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=157037#comment-157037 ]

sergei sergei commented on JENKINS-12183:
-----------------------------------------

Result of Last Rebase

java.lang.NullPointerException
        at jenkins.plugins.svnmerge.FeatureBranchProperty.rebase(FeatureBranchProperty.java:148)
        at jenkins.plugins.svnmerge.RebaseAction.perform(RebaseAction.java:105)
        at jenkins.plugins.svnmerge.RebaseAction.perform(RebaseAction.java:25)
        at jenkins.plugins.svnmerge.AbstractSvnmergeTaskAction$WorkerThread.perform(AbstractSvnmergeTaskAction.java:105)
        at hudson.model.TaskThread.run(TaskThread.java:127)
        at jenkins.plugins.svnmerge.AbstractSvnmergeTaskAction$TaskImpl$1.run(AbstractSvnmergeTaskAction.java:161)
        at hudson.model.ResourceController.execute(ResourceController.java:88)
        at hudson.model.Executor.run(Executor.java:238)
               

> SVNMerge plugin does not work with SVN plugin version 1.37, but works with 1.34
> -------------------------------------------------------------------------------
>
>                 Key: JENKINS-12183
>                 URL: https://issues.jenkins-ci.org/browse/JENKINS-12183
>             Project: Jenkins
>          Issue Type: Bug
>          Components: svnmerge
>    Affects Versions: current
>            Reporter: sergei sergei
>            Assignee: Kohsuke Kawaguchi
>
> I have used svn merge plugin together with svn plugin v1.34 and it all worked fine. Some time ago I updated svn plugin to the latest one 1.37 and svnmerge stopped working.
> Try creating a feature branch and it gives some svn error.
> There's something wrong with svnm.getCopyClient().doCopy which complains about wrong paths passed as arguments, while it all worked fine with 1.34

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.jenkins-ci.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[JIRA] (JENKINS-12183) SVNMerge plugin does not work with SVN plugin version 1.37, but works with 1.34

JIRA noreply@jenkins-ci.org
In reply to this post by JIRA noreply@jenkins-ci.org

    [ https://issues.jenkins-ci.org/browse/JENKINS-12183?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=157037#comment-157037 ]

sergei sergei edited comment on JENKINS-12183 at 12/21/11 2:31 PM:
-------------------------------------------------------------------

-
               
      was (Author: ir73):
    Result of Last Rebase

java.lang.NullPointerException
        at jenkins.plugins.svnmerge.FeatureBranchProperty.rebase(FeatureBranchProperty.java:148)
        at jenkins.plugins.svnmerge.RebaseAction.perform(RebaseAction.java:105)
        at jenkins.plugins.svnmerge.RebaseAction.perform(RebaseAction.java:25)
        at jenkins.plugins.svnmerge.AbstractSvnmergeTaskAction$WorkerThread.perform(AbstractSvnmergeTaskAction.java:105)
        at hudson.model.TaskThread.run(TaskThread.java:127)
        at jenkins.plugins.svnmerge.AbstractSvnmergeTaskAction$TaskImpl$1.run(AbstractSvnmergeTaskAction.java:161)
        at hudson.model.ResourceController.execute(ResourceController.java:88)
        at hudson.model.Executor.run(Executor.java:238)
                 

> SVNMerge plugin does not work with SVN plugin version 1.37, but works with 1.34
> -------------------------------------------------------------------------------
>
>                 Key: JENKINS-12183
>                 URL: https://issues.jenkins-ci.org/browse/JENKINS-12183
>             Project: Jenkins
>          Issue Type: Bug
>          Components: svnmerge
>    Affects Versions: current
>            Reporter: sergei sergei
>            Assignee: Kohsuke Kawaguchi
>
> I have used svn merge plugin together with svn plugin v1.34 and it all worked fine. Some time ago I updated svn plugin to the latest one 1.37 and svnmerge stopped working.
> Try creating a feature branch and it gives some svn error.
> There's something wrong with svnm.getCopyClient().doCopy which complains about wrong paths passed as arguments, while it all worked fine with 1.34

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.jenkins-ci.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[JIRA] [svnmerge] (JENKINS-12183) SVNMerge plugin does not work with SVN plugin version 1.37, but works with 1.34

JIRA noreply@jenkins-ci.org
In reply to this post by JIRA noreply@jenkins-ci.org
Adam Payne commented on Bug JENKINS-12183

I'm using jenkins.war 1.515, which came with subversion plugin 1.45, and I installed svnmerge plugin 1.2, and my initial branch creation, integration, and rebasing are working. Reintegrating the second time is giving the same error as in JENKINS-16723.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators.
For more information on JIRA, see: http://www.atlassian.com/software/jira

--
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

[JIRA] [svnmerge] (JENKINS-12183) SVNMerge plugin does not work with SVN plugin version 1.37, but works with 1.34

JIRA noreply@jenkins-ci.org
In reply to this post by JIRA noreply@jenkins-ci.org
 
Adam Payne edited a comment on Bug JENKINS-12183

I'm using jenkins.war 1.515, which came with subversion plugin 1.45, and I installed svnmerge plugin 1.2, and my initial branch creation, integration, and rebasing are working. Reintegrating the second time is giving the same error as in JENKINS-16723.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators.
For more information on JIRA, see: http://www.atlassian.com/software/jira

--
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

[JIRA] [svnmerge] (JENKINS-12183) SVNMerge plugin does not work with SVN plugin version 1.37, but works with 1.34

JIRA noreply@jenkins-ci.org
In reply to this post by JIRA noreply@jenkins-ci.org
Hugues Chabot resolved Bug JENKINS-12183 as Won't Fix

SVNMerge plugin now use Subversion plugin 2.2. This issue is no longer relevant.

Change By: Hugues Chabot (05/Apr/14 1:57 AM)
Status: Open Resolved
Resolution: Won't Fix
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators.
For more information on JIRA, see: http://www.atlassian.com/software/jira

--
You received this message because you are subscribed to the Google Groups "Jenkins Issues" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.