Jenkins 2.7 vs 2.4

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Jenkins 2.7 vs 2.4

Filippo
Hello,
I've installed Jenkins 2.4 on a CentOS server via yum. I would like to try Blue Ocean, that runs only with Jenkins v 2.7.
So I opened the RedHat repository (https://pkg.jenkins.io/redhat/) and noticed that the 2.7 rpm is dated 2016/05/29, while the 2.4 is dated 2017/02/13.
The question is: why is the 2.7 so older than 2.4?
And are the other packages (2.8 and 2.9) also compatible with blue ocean?

Thanks.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/2d4e92fb-a2b6-46fd-8157-41ea58ffeebe%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jenkins 2.7 vs 2.4

Richard Bywater-2
Not quite sure where you are seeing that date against 2.4. The results from my view of that list is:
jenkins-2.4-1.1.noarch.rpm 2016/05/15 65.4M
jenkins-2.7-1.1.noarch.rpm 2016/05/29 65.4M

So 2.7 is newer than 2.4. I believe you'll find that Blue Ocean is 2.7+ so you should probably grab the latest version that you feel comfortable with (2.55 is the latest available there)

Richard.


On Tue, 18 Apr 2017 at 22:52 Filippo <[hidden email]> wrote:
Hello,
I've installed Jenkins 2.4 on a CentOS server via yum. I would like to try Blue Ocean, that runs only with Jenkins v 2.7.
So I opened the RedHat repository (https://pkg.jenkins.io/redhat/) and noticed that the 2.7 rpm is dated 2016/05/29, while the 2.4 is dated 2017/02/13.
The question is: why is the 2.7 so older than 2.4?
And are the other packages (2.8 and 2.9) also compatible with blue ocean?

Thanks.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/2d4e92fb-a2b6-46fd-8157-41ea58ffeebe%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CAMui945DKCSw4FYiEfSH7nky_1_xVCusmmEMjYaDmjo2tyEGYA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jenkins 2.7 vs 2.4

Filippo
My fault, I though that 2.55 was 2.5.5. Sorry.
Thanks

Il giorno martedì 18 aprile 2017 13:13:35 UTC+2, Richard Bywater ha scritto:
Not quite sure where you are seeing that date against 2.4. The results from my view of that list is:
jenkins-2.4-1.1.noarch.rpm 2016/05/15 65.4M
jenkins-2.7-1.1.noarch.rpm 2016/05/29 65.4M

So 2.7 is newer than 2.4. I believe you'll find that Blue Ocean is 2.7+ so you should probably grab the latest version that you feel comfortable with (2.55 is the latest available there)

Richard.


On Tue, 18 Apr 2017 at 22:52 Filippo <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="gaenXTAxAwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">filippo...@...> wrote:
Hello,
I've installed Jenkins 2.4 on a CentOS server via yum. I would like to try Blue Ocean, that runs only with Jenkins v 2.7.
So I opened the RedHat repository (<a href="https://pkg.jenkins.io/redhat/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fpkg.jenkins.io%2Fredhat%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNE29ROwI24Nm5NiTwhAGqjFJ9PBbQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fpkg.jenkins.io%2Fredhat%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNE29ROwI24Nm5NiTwhAGqjFJ9PBbQ&#39;;return true;">https://pkg.jenkins.io/redhat/) and noticed that the 2.7 rpm is dated 2016/05/29, while the 2.4 is dated 2017/02/13.
The question is: why is the 2.7 so older than 2.4?
And are the other packages (2.8 and 2.9) also compatible with blue ocean?

Thanks.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="gaenXTAxAwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">jenkinsci-use...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/jenkinsci-users/2d4e92fb-a2b6-46fd-8157-41ea58ffeebe%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/jenkinsci-users/2d4e92fb-a2b6-46fd-8157-41ea58ffeebe%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/jenkinsci-users/2d4e92fb-a2b6-46fd-8157-41ea58ffeebe%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/jenkinsci-users/2d4e92fb-a2b6-46fd-8157-41ea58ffeebe%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/36fdb4c9-e84b-4b0b-b686-75dcbe4436a7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jenkins 2.7 vs 2.4

James Dumay
In reply to this post by Filippo
Hi Filippo,

Great to hear that you are upgrading to use Blue Ocean :)

While Blue Ocean is compatible with 2.7.1 and above I do strongly advise using the latest LTS, 2.46.1, as there have been several nasty security vulnerabilities.

All the best,

James

On Tuesday, April 18, 2017 at 8:52:14 PM UTC+10, Filippo wrote:
Hello,
I've installed Jenkins 2.4 on a CentOS server via yum. I would like to try Blue Ocean, that runs only with Jenkins v 2.7.
So I opened the RedHat repository (<a href="https://pkg.jenkins.io/redhat/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fpkg.jenkins.io%2Fredhat%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNE29ROwI24Nm5NiTwhAGqjFJ9PBbQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fpkg.jenkins.io%2Fredhat%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNE29ROwI24Nm5NiTwhAGqjFJ9PBbQ&#39;;return true;">https://pkg.jenkins.io/redhat/) and noticed that the 2.7 rpm is dated 2016/05/29, while the 2.4 is dated 2017/02/13.
The question is: why is the 2.7 so older than 2.4?
And are the other packages (2.8 and 2.9) also compatible with blue ocean?

Thanks.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/8a45ad4a-4bdd-4aa0-be81-caee0f8e633b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jenkins 2.7 vs 2.4

Filippo
Hi James,
yes, I'm using the 2.46.1 version.
But I can use Blue Ocean only for browsing activity, because our projects are stored under SVN while Blue Ocean seems to support only GIT projects, so I must switch to "classic UI" every time I have to change some build configuration.

Bye

Filippo

Il giorno giovedì 20 aprile 2017 07:57:20 UTC+2, James Dumay ha scritto:
Hi Filippo,

Great to hear that you are upgrading to use Blue Ocean :)

While Blue Ocean is compatible with 2.7.1 and above I do strongly advise using the latest LTS, 2.46.1, as there have been several nasty security vulnerabilities.

All the best,

James

On Tuesday, April 18, 2017 at 8:52:14 PM UTC+10, Filippo wrote:
Hello,
I've installed Jenkins 2.4 on a CentOS server via yum. I would like to try Blue Ocean, that runs only with Jenkins v 2.7.
So I opened the RedHat repository (<a href="https://pkg.jenkins.io/redhat/" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fpkg.jenkins.io%2Fredhat%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNE29ROwI24Nm5NiTwhAGqjFJ9PBbQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fpkg.jenkins.io%2Fredhat%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNE29ROwI24Nm5NiTwhAGqjFJ9PBbQ&#39;;return true;">https://pkg.jenkins.io/redhat/) and noticed that the 2.7 rpm is dated 2016/05/29, while the 2.4 is dated 2017/02/13.
The question is: why is the 2.7 so older than 2.4?
And are the other packages (2.8 and 2.9) also compatible with blue ocean?

Thanks.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/bff9c00d-8471-4d2f-8600-c0b929f48ba7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Jenkins 2.7 vs 2.4

James Dumay
Yes, I suspect that will be a limitation for some time. Sorry :(

On Thursday, April 20, 2017 at 5:36:27 PM UTC+10, Filippo wrote:
Hi James,
yes, I'm using the 2.46.1 version.
But I can use Blue Ocean only for browsing activity, because our projects are stored under SVN while Blue Ocean seems to support only GIT projects, so I must switch to "classic UI" every time I have to change some build configuration.

Bye

Filippo

Il giorno giovedì 20 aprile 2017 07:57:20 UTC+2, James Dumay ha scritto:
Hi Filippo,

Great to hear that you are upgrading to use Blue Ocean :)

While Blue Ocean is compatible with 2.7.1 and above I do strongly advise using the latest LTS, 2.46.1, as there have been several nasty security vulnerabilities.

All the best,

James

On Tuesday, April 18, 2017 at 8:52:14 PM UTC+10, Filippo wrote:
Hello,
I've installed Jenkins 2.4 on a CentOS server via yum. I would like to try Blue Ocean, that runs only with Jenkins v 2.7.
So I opened the RedHat repository (<a href="https://pkg.jenkins.io/redhat/" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fpkg.jenkins.io%2Fredhat%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNE29ROwI24Nm5NiTwhAGqjFJ9PBbQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fpkg.jenkins.io%2Fredhat%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNE29ROwI24Nm5NiTwhAGqjFJ9PBbQ&#39;;return true;">https://pkg.jenkins.io/redhat/) and noticed that the 2.7 rpm is dated 2016/05/29, while the 2.4 is dated 2017/02/13.
The question is: why is the 2.7 so older than 2.4?
And are the other packages (2.8 and 2.9) also compatible with blue ocean?

Thanks.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/47e58e48-3770-4965-b8be-9ee088af3775%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Loading...