Jenkins and go mod 403 problem

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Jenkins and go mod 403 problem

Jayaraj Wilson

At the onset let me state that I have started using Jenkins only for the past 4 days and am very much a newbie. 

My source code is in go and across multiple repos on bitbucket and I wanted to create a build pipeline. I started by creating a simple job on jenkins to build. I am almost done but the build fails at the last portion 

go: missing Mercurial command. See https://golang.org/s/gogetcmd
go: bitbucket.org/xxxxxxxxxx/servers@v0.0.3: https://api.bitbucket.org/2.0/repositories/xxxxxxxxxx/servers?fields=scm: 403 Forbidden
go: missing Mercurial command. See https://golang.org/s/gogetcmd go: bitbucket.org/xxxxxxxxxx/errors@v0.0.4: https://api.bitbucket.org/2.0/repositories/xxxxxxxxxx/errors?fields=scm: 403 Forbidden
go: error loading module requirements

I assumed that the following entry needed to be made in the .gitconfig file in /var/lib/jenkins which seems to be used the jenkins home to address the problem.

[url "[hidden email]:"]
   insteadOf = "https://bitbucket.org/"

But I am still facing the build failure. Is there something that I need to configure on jenkins. Is there any other step to do? Would highly appreciate inputs.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/21d7fe52-82ef-4326-835e-e49e923bb84e%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.