Jenkins installation freeze at install plugin page and unable to continue

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
BTH
Reply | Threaded
Open this post in threaded view
|

Jenkins installation freeze at install plugin page and unable to continue

BTH

I've installed native Jenkins 2.263.3 (latest stable Debian package ) and Java openJDK 8. The installation was successful.

However, once the installation came to the step "Customize Jenkins" and there were options to either choose Install suggested plugins or Select plugins to install. Both give the same result.

Jenkins UI will freeze for about a couple of seconds and then the error page shows as pictured below.

image.png

I tried restarting, re-install (same version) unfortunately, it doesn't change.

The error messages in /var/log/jenkins/jenkins.log

Running from: /usr/share/jenkins/jenkins.war
2021-02-04 09:28:14.105+0000 [id=1] WARNING o.e.j.s.handler.ContextHandler#setContextPath: Empty contextPath

2021-02-04 09:33:05.096+0000 [id=16]    WARNING h.i.i.InstallUncaughtExceptionHandler#handleException
java.util.concurrent.TimeoutException: Idle timeout expired: 5000/5000 ms

Caused: java.io.IOException
    at org.eclipse.jetty.util.SharedBlockingCallback$Blocker.block(SharedBlockingCallback.java:234)

And here is an information of my system

Ubuntu 20.04.2 LTS
5.4.0-65-generic

$ free -mh
              total        used        free      shared  buff/cache   available
Mem:          6.6Gi       1.0Gi       3.8Gi       1.0Mi       1.9Gi       5.3Gi
Swap:            0B          0B          0B

Java

openjdk version "1.8.0_275"
OpenJDK Runtime Environment (build 1.8.0_275-8u275-b01-0ubuntu1~20.04-b01)
OpenJDK 64-Bit Server VM (build 25.275-b01, mixed mode)

Jenkins

● jenkins.service - LSB: Start Jenkins at boot time
     Loaded: loaded (/etc/init.d/jenkins; generated)
     Active: active (exited) since Thu 2021-02-04 12:18:28 CET; 10min ago
       Docs: man:systemd-sysv-generator(8)
    Process: 15678 ExecStart=/etc/init.d/jenkins start (code=exited, status=0/SUCCESS)

Feb 04 12:18:27 jenkins-master.com systemd[1]: Starting LSB: Start Jenkins at boot time...
Feb 04 12:18:27 jenkins-master.com jenkins[15678]: Correct java version found
Feb 04 12:18:27 jenkins-master.com jenkins[15678]:  * Starting Jenkins Automation Server jenkins
Feb 04 12:18:27 jenkins-master.com su[15713]: (to jenkins) root on none
Feb 04 12:18:27 jenkins-master.com su[15713]: pam_unix(su-l:session): session opened for user jenkins by (uid=0)
Feb 04 12:18:27 jenkins-master.com su[15713]: pam_unix(su-l:session): session closed for user jenkins
Feb 04 12:18:28 jenkins-master.com jenkins[15678]:    ...done.
Feb 04 12:18:28 jenkins-master.com systemd[1]: Started LSB: Start Jenkins at boot time.


Jenkins User

$ groups jenkins
jenkins : jenkins root
Has anyone faced the same issue ? 

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CAEaEQiKqcrYx_gkaDOUc0YXYGEavB2i6K%3DqgGCV3YWjVsqMmWw%40mail.gmail.com.