Jenkins pipeline prematurely kills docker container

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Jenkins pipeline prematurely kills docker container

xstourac
Hi all,

I am currently dealing with very weird behaviour of my Jenkins instance. I want to use docker containers via pipeline to build my app. But everytime I tried even something simple like this:

node() {
  stage('Build') {
    docker.image('debian:stretch').inside() {
  sh 'sleep 20'
}
  }
}

Jenkins kills the container after less than 1 second without any explanaition anywhere (see attached stretch.log). But what is interesting, when I change docker image to debian:jessie (oldstable), everything is working correctly (see attached jessie.log). I also tried executing same code on jessie and stretch nodes, but it was exactly the same.

Can you please help me or at least give some hints/links? I am really stucked and out of ideas. I am using Jenkins 2.73.1 with all plugins updated (today) running directly on Debian Jessie host.

Thank you in advance,
Jan Stourac.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/1e65b831-72fc-41b8-b38e-0f1afebbc046%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

jessie.log (1K) Download Attachment
stretch.log (1K) Download Attachment