Jenkins with Spring issue

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Jenkins with Spring issue

Ritesh Ranjan

Hi folks,

We are using jenkins (2.60.1) version and it contains spring libraries of version 2.X.X.

Now, we are trying to build our jenkins plugin which internally uses Spring 4.0.2 RELEASE and uses AOP heavily.

The problem we are facing is that upon triggering the plugin, it reports an error saying :- "AnnotationAwareAspectJAutoProxyCreator is only available on Java 1.5 and higher" , even though my version is 1.8.

Looks like it is using old spring libraries which jenkins has packaged instead of my spring libraries . How do we get around this problem and make jenkins use our spring libraries? Any help would be highly appreciated.

Thanks

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/72a786d8-eeab-41b8-b9db-27f0ee3d1b69%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.