.NET 4.8.x and win 2016 Failure to install slave as service -> Possible Bug?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

.NET 4.8.x and win 2016 Failure to install slave as service -> Possible Bug?

Dan zaWhite
Hi All,

Here is a fuzzy bug (maybe) for ya.

- Just installed a fresh Win 2016 Server.
- Installed java latest
- Set up a new jenkins slave in my Jenkins Master
- I get this error when trying to install as a service:
".NET Framework 2.0 or later is required for this feature"
- I go and install latest .NET sdk 4.8.x
- I try again to install as a service and i get the same error again

Did any of you encounter this weird behavior?

P.S> Multiple windows restarts also done, just in case: )

Thank you,
Dan 

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/9804343c-3bfd-46e5-a73f-da174a592628n%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: .NET 4.8.x and win 2016 Failure to install slave as service -> Possible Bug?

christop...@googlemail.com
Maybe Framework != SDK
Have a look:
https://www.microsoft.com/de-de/download/details.aspx?id=6523

Regards,
Christoph

[hidden email] schrieb am Donnerstag, 27. August 2020 um 16:21:56 UTC+2:
Hi All,

Here is a fuzzy bug (maybe) for ya.

- Just installed a fresh Win 2016 Server.
- Installed java latest
- Set up a new jenkins slave in my Jenkins Master
- I get this error when trying to install as a service:
".NET Framework 2.0 or later is required for this feature"
- I go and install latest .NET sdk 4.8.x
- I try again to install as a service and i get the same error again

Did any of you encounter this weird behavior?

P.S> Multiple windows restarts also done, just in case: )

Thank you,
Dan 

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/8282d35d-fcaa-41eb-b6ad-d91bd242a8cen%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: .NET 4.8.x and win 2016 Failure to install slave as service -> Possible Bug?

Mark Waite-2
Refer to  https://issues.jenkins-ci.org/browse/JENKINS-63223 where it suggests that you may need to edit a configuration file in the agent directory to remove the line that refers to Microsoft.NET 2.x.

If that is the issue in your case, it would be great to have a comment on that issue that says you've seen it as well.

On Thu, Aug 27, 2020 at 8:30 AM '[hidden email]' via Jenkins Users <[hidden email]> wrote:
Maybe Framework != SDK
Have a look:

Regards,
Christoph

[hidden email] schrieb am Donnerstag, 27. August 2020 um 16:21:56 UTC+2:
Hi All,

Here is a fuzzy bug (maybe) for ya.

- Just installed a fresh Win 2016 Server.
- Installed java latest
- Set up a new jenkins slave in my Jenkins Master
- I get this error when trying to install as a service:
".NET Framework 2.0 or later is required for this feature"
- I go and install latest .NET sdk 4.8.x
- I try again to install as a service and i get the same error again

Did any of you encounter this weird behavior?

P.S> Multiple windows restarts also done, just in case: )

Thank you,
Dan 

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/8282d35d-fcaa-41eb-b6ad-d91bd242a8cen%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CAO49JtFbsPwc0cHzrwfA_3Jqv8kKQSiyf4ZbsjYm4gf%2B87hjXw%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: .NET 4.8.x and win 2016 Failure to install slave as service -> Possible Bug?

Dan zaWhite
@Christoph: I installed the framework, as  i normally do
@Mark: I will upgrade jenkins this weekend and I will see if i encounter any issues. Until then i will quickly spin up another win 20016 and install .NET 4.6 and see if that works (the same as existing windows slaves)

On Thu, Aug 27, 2020 at 5:35 PM Mark Waite <[hidden email]> wrote:
Refer to  https://issues.jenkins-ci.org/browse/JENKINS-63223 where it suggests that you may need to edit a configuration file in the agent directory to remove the line that refers to Microsoft.NET 2.x.

If that is the issue in your case, it would be great to have a comment on that issue that says you've seen it as well.

On Thu, Aug 27, 2020 at 8:30 AM '[hidden email]' via Jenkins Users <[hidden email]> wrote:
Maybe Framework != SDK
Have a look:

Regards,
Christoph

[hidden email] schrieb am Donnerstag, 27. August 2020 um 16:21:56 UTC+2:
Hi All,

Here is a fuzzy bug (maybe) for ya.

- Just installed a fresh Win 2016 Server.
- Installed java latest
- Set up a new jenkins slave in my Jenkins Master
- I get this error when trying to install as a service:
".NET Framework 2.0 or later is required for this feature"
- I go and install latest .NET sdk 4.8.x
- I try again to install as a service and i get the same error again

Did any of you encounter this weird behavior?

P.S> Multiple windows restarts also done, just in case: )

Thank you,
Dan 

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/8282d35d-fcaa-41eb-b6ad-d91bd242a8cen%40googlegroups.com.

--
You received this message because you are subscribed to a topic in the Google Groups "Jenkins Users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/jenkinsci-users/SUQzkOvdzSA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CAO49JtFbsPwc0cHzrwfA_3Jqv8kKQSiyf4ZbsjYm4gf%2B87hjXw%40mail.gmail.com.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CAMn9Bd4XjOkcaFGzZwC_XUctJAGSPWfb1GOt90Tv3L7OV%3DFX-Q%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

RE: .NET 4.8.x and win 2016 Failure to install slave as service -> Possible Bug?

BCT Roel de Wildt
In reply to this post by Dan zaWhite

Hi,

 

You need to enable .NET Framework 3.5 for .NET Framework 2.x/3.x support.

 

Kind regards,

Roel

 

Van: [hidden email] <[hidden email]> Namens [hidden email]
Verzonden: donderdag 27 augustus 2020 16:22
Aan: Jenkins Users <[hidden email]>
Onderwerp: .NET 4.8.x and win 2016 Failure to install slave as service -> Possible Bug?

 

Hi All,

 

Here is a fuzzy bug (maybe) for ya.

 

- Just installed a fresh Win 2016 Server.

- Installed java latest

- Set up a new jenkins slave in my Jenkins Master

- I get this error when trying to install as a service:

".NET Framework 2.0 or later is required for this feature"

- I go and install latest .NET sdk 4.8.x

- I try again to install as a service and i get the same error again

 

Did any of you encounter this weird behavior?

 

P.S> Multiple windows restarts also done, just in case: )

 

Thank you,

Dan 

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/9804343c-3bfd-46e5-a73f-da174a592628n%40googlegroups.com.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/199E247AC0B52945AC9C5CA0041D807F39656D80%40EXCH001.bct.local.
Reply | Threaded
Open this post in threaded view
|

Re: .NET 4.8.x and win 2016 Failure to install slave as service -> Possible Bug?

Dan zaWhite
@Roel : Thak you for the feedback. I did exactly that this morning and it seems that was the issue all along :)

On Fri, Aug 28, 2020 at 11:49 AM BCT Roel de Wildt <[hidden email]> wrote:

Hi,

 

You need to enable .NET Framework 3.5 for .NET Framework 2.x/3.x support.

 

Kind regards,

Roel

 

Van: [hidden email] <[hidden email]> Namens [hidden email]
Verzonden: donderdag 27 augustus 2020 16:22
Aan: Jenkins Users <[hidden email]>
Onderwerp: .NET 4.8.x and win 2016 Failure to install slave as service -> Possible Bug?

 

Hi All,

 

Here is a fuzzy bug (maybe) for ya.

 

- Just installed a fresh Win 2016 Server.

- Installed java latest

- Set up a new jenkins slave in my Jenkins Master

- I get this error when trying to install as a service:

".NET Framework 2.0 or later is required for this feature"

- I go and install latest .NET sdk 4.8.x

- I try again to install as a service and i get the same error again

 

Did any of you encounter this weird behavior?

 

P.S> Multiple windows restarts also done, just in case: )

 

Thank you,

Dan 

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/9804343c-3bfd-46e5-a73f-da174a592628n%40googlegroups.com.

--
You received this message because you are subscribed to a topic in the Google Groups "Jenkins Users" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/jenkinsci-users/SUQzkOvdzSA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/199E247AC0B52945AC9C5CA0041D807F39656D80%40EXCH001.bct.local.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/CAMn9Bd40xtRF%2BVNPmvE8WjmiFBMNWi1gN-R1KTy1WabTys6O1Q%40mail.gmail.com.