Need advice for slave use

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Need advice for slave use

Alexandre Gacon-2
Hi all,

Some weeks ago, I had a successfull implementation of a Hudson server using some slaves (all on windows, on vmwares). But I had to move my computer to a new windows domain and since this moment, I am not able to get my slaves working.

So I will take this opportunity to setup a new implementation. I would like to follow the following architecture:

I have a build server (quadcore with 8 gbytes RAM under windows server 2008) on my windows domain. I want to install Hudson on this computer but I won't allow any build on this computer : it just hosts the website and dispatchs works among my slaves).

This same computer will also have a vmware server to host my Hudson slaves. To be able to launch build on these slaves, what do you suggest as windows configuration ? To put the slaves on my windows domain ? To let them outside any windows domain ?

Today, I didn't manage to launch a slave in such an architecture : the master waits for ever that the slave launches the service (it manages to check java version and to copy the slave.jar). Sometimes, after rebooting the slave, the service starts but when I launch a simple build on it, the build never ends (it can not retrieve sources from SUBVERSION, but I manage to do the same thing by hand).

Please help

--
Alexandre Gacon
Reply | Threaded
Open this post in threaded view
|

Re: Need advice for slave use

Sami Tikka
If you want detailed advice, you should begin by providing detailed
information of your setup (types of slaves, how are they started) and
output and log files from both master and slaves.

The only thing I can recommend based on your question is for you to
read http://wiki.hudson-ci.org/display/HUDSON/Distributed+builds

-- Sami

2010/7/27 Alexandre Gacon <[hidden email]>:

> Hi all,
> Some weeks ago, I had a successfull implementation of a Hudson server using
> some slaves (all on windows, on vmwares). But I had to move my computer to a
> new windows domain and since this moment, I am not able to get my slaves
> working.
> So I will take this opportunity to setup a new implementation. I would like
> to follow the following architecture:
> I have a build server (quadcore with 8 gbytes RAM under windows server 2008)
> on my windows domain. I want to install Hudson on this computer but I won't
> allow any build on this computer : it just hosts the website and dispatchs
> works among my slaves).
> This same computer will also have a vmware server to host my Hudson slaves.
> To be able to launch build on these slaves, what do you suggest as windows
> configuration ? To put the slaves on my windows domain ? To let them outside
> any windows domain ?
> Today, I didn't manage to launch a slave in such an architecture : the
> master waits for ever that the slave launches the service (it manages to
> check java version and to copy the slave.jar). Sometimes, after rebooting
> the slave, the service starts but when I launch a simple build on it, the
> build never ends (it can not retrieve sources from SUBVERSION, but I manage
> to do the same thing by hand).
> Please help
>
> --
> Alexandre Gacon
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]