Problems setting up plugin dev environment

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems setting up plugin dev environment

Ilkka Laukkanen
Hi,

It seems I was a little hasty in declaring my development environment
to be up and running: I'm having problems with two specific jars
related to hudson plugin development, namely commons-jelly and svnkit.

With my environment otherwise set up using the maven-hpi-plugin (and a
few lines of code already written) I do a "mvn package", which
complains that three dependencies can't be found: svnkit,
commons-jelly and commons-jelly-tags-define. I promptly found and
downloaded the jars in question from hudson's SCM (via fisheye), but
the binary jars for commons-jelly and svnkit seem to be corrupted for
me: the SHA1 sum for commons-jelly-1.1-hudson-20061106.jar[1] from
fisheye is c17daa7a1f7d3c7c808276668b492dc2f27bc79c, whereas I get
dcf25925db74b03d10bf17a951f6cb60483c7b1d. The jar's not a valid zip
either, naturally. The same goes for svnkit. commons-jelly-tags-define
works just fine, however.

Any help appreciated.

1. http://fisheye5.cenqua.com/browse/~raw,r=1.1/hudson/hudson/main/lib/commons-jelly/jars/commons-jelly-1.1-hudson-20061106.jar.sha1


--
Ilkka Laukkanen
http://ilkankuvat.blogspot.com
"And unto this, Conan;"

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems setting up plugin dev environment

Ilkka Laukkanen
Oh, and the 2007MMDD versions of commons-jelly are fine, incidentally
(i.e. the SHA1 sums are the same when I check 'em).

On 11/5/07, Ilkka Laukkanen <[hidden email]> wrote:

> Hi,
>
> It seems I was a little hasty in declaring my development environment
> to be up and running: I'm having problems with two specific jars
> related to hudson plugin development, namely commons-jelly and svnkit.
>
> With my environment otherwise set up using the maven-hpi-plugin (and a
> few lines of code already written) I do a "mvn package", which
> complains that three dependencies can't be found: svnkit,
> commons-jelly and commons-jelly-tags-define. I promptly found and
> downloaded the jars in question from hudson's SCM (via fisheye), but
> the binary jars for commons-jelly and svnkit seem to be corrupted for
> me: the SHA1 sum for commons-jelly-1.1-hudson-20061106.jar[1] from
> fisheye is c17daa7a1f7d3c7c808276668b492dc2f27bc79c, whereas I get
> dcf25925db74b03d10bf17a951f6cb60483c7b1d. The jar's not a valid zip
> either, naturally. The same goes for svnkit. commons-jelly-tags-define
> works just fine, however.
>
> Any help appreciated.
>
> 1. http://fisheye5.cenqua.com/browse/~raw,r=1.1/hudson/hudson/main/lib/commons-jelly/jars/commons-jelly-1.1-hudson-20061106.jar.sha1
>
>
> --
> Ilkka Laukkanen
> http://ilkankuvat.blogspot.com
> "And unto this, Conan;"
>


--
Ilkka Laukkanen
http://ilkankuvat.blogspot.com
"And unto this, Conan;"

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems setting up plugin dev environment

Ilkka Laukkanen
In reply to this post by Ilkka Laukkanen
Okay, so *now* I take a good long look at my pom.xml and update the
hudson version, and it works. But still, the older jars definitely
seemed to be broken.

On 11/5/07, Ilkka Laukkanen <[hidden email]> wrote:

> Hi,
>
> It seems I was a little hasty in declaring my development environment
> to be up and running: I'm having problems with two specific jars
> related to hudson plugin development, namely commons-jelly and svnkit.
>
> With my environment otherwise set up using the maven-hpi-plugin (and a
> few lines of code already written) I do a "mvn package", which
> complains that three dependencies can't be found: svnkit,
> commons-jelly and commons-jelly-tags-define. I promptly found and
> downloaded the jars in question from hudson's SCM (via fisheye), but
> the binary jars for commons-jelly and svnkit seem to be corrupted for
> me: the SHA1 sum for commons-jelly-1.1-hudson-20061106.jar[1] from
> fisheye is c17daa7a1f7d3c7c808276668b492dc2f27bc79c, whereas I get
> dcf25925db74b03d10bf17a951f6cb60483c7b1d. The jar's not a valid zip
> either, naturally. The same goes for svnkit. commons-jelly-tags-define
> works just fine, however.
>
> Any help appreciated.
>
> 1. http://fisheye5.cenqua.com/browse/~raw,r=1.1/hudson/hudson/main/lib/commons-jelly/jars/commons-jelly-1.1-hudson-20061106.jar.sha1
>
>
> --
> Ilkka Laukkanen
> http://ilkankuvat.blogspot.com
> "And unto this, Conan;"
>


--
Ilkka Laukkanen
http://ilkankuvat.blogspot.com
"And unto this, Conan;"

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Problems setting up plugin dev environment

Kohsuke Kawaguchi
Administrator
Ilkka Laukkanen wrote:
> Okay, so *now* I take a good long look at my pom.xml and update the
> hudson version, and it works. But still, the older jars definitely
> seemed to be broken.

Thanks for the heads up. Perhaps I just need to update maven-hpi-plugin
to start with newer version of Hudson?

That seems easier and more productive than going back and fixing old jars.


> On 11/5/07, Ilkka Laukkanen <[hidden email]> wrote:
>> Hi,
>>
>> It seems I was a little hasty in declaring my development environment
>> to be up and running: I'm having problems with two specific jars
>> related to hudson plugin development, namely commons-jelly and svnkit.
>>
>> With my environment otherwise set up using the maven-hpi-plugin (and a
>> few lines of code already written) I do a "mvn package", which
>> complains that three dependencies can't be found: svnkit,
>> commons-jelly and commons-jelly-tags-define. I promptly found and
>> downloaded the jars in question from hudson's SCM (via fisheye), but
>> the binary jars for commons-jelly and svnkit seem to be corrupted for
>> me: the SHA1 sum for commons-jelly-1.1-hudson-20061106.jar[1] from
>> fisheye is c17daa7a1f7d3c7c808276668b492dc2f27bc79c, whereas I get
>> dcf25925db74b03d10bf17a951f6cb60483c7b1d. The jar's not a valid zip
>> either, naturally. The same goes for svnkit. commons-jelly-tags-define
>> works just fine, however.
>>
>> Any help appreciated.
>>
>> 1. http://fisheye5.cenqua.com/browse/~raw,r=1.1/hudson/hudson/main/lib/commons-jelly/jars/commons-jelly-1.1-hudson-20061106.jar.sha1
>>
>>
>> --
>> Ilkka Laukkanen
>> http://ilkankuvat.blogspot.com
>> "And unto this, Conan;"
>>
>
>

--
Kohsuke Kawaguchi
Sun Microsystems                   [hidden email]

smime.p7s (4K) Download Attachment