Problems with the SSH plugins when running under - mvn hpi:run

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with the SSH plugins when running under - mvn hpi:run

steadyonabix
I'm seeing these errors when starting up Jenkins via the mvn hpi:run task:

Sep 11, 2018 3:20:42 PM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin SSH Credentials Plugin v1.10 (ssh-credentials)
java.io.IOException: SSH Credentials Plugin v1.10 failed to load.
 - Credentials Plugin v1.9.4 is older than required. To fix, install v1.16.1 or later.


 Sep 11, 2018 3:20:42 PM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin Jenkins SSH Slaves plugin v1.8 (ssh-slaves)
java.io.IOException: Jenkins SSH Slaves plugin v1.8 failed to load.
 - SSH Credentials Plugin v1.10 failed to load. Fix this plugin first.

Is anyone aware if this is a known issue? I can't find anything about it online...

I'm nervous of trying to update these as the first time that I ran Jenkins in this fashion, I upgraded a number of plugins and found that Jenkins wouldn't start again. 

So if anyone has seen this and came up with a viable solution I'd be glad to hear about it. Also, any help understanding how this task works its magic with the WAR would be appreciated.

 Cheers

Steady

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/92268150-b06b-45ee-9424-e5c5446c9722%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Problems with the SSH plugins when running under - mvn hpi:run

Ulli Hafner
You need to update some dependencies in you pom. Make sure that you use a compatible set of dependencies. The maven enforcer will assist you with the problems of wrong and old dependencies.

Am 12.09.2018 um 10:26 schrieb steadyonabix <[hidden email]>:

I'm seeing these errors when starting up Jenkins via the mvn hpi:run task:

Sep 11, 2018 3:20:42 PM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin SSH Credentials Plugin v1.10 (ssh-credentials)
java.io.IOException: SSH Credentials Plugin v1.10 failed to load.
 - Credentials Plugin v1.9.4 is older than required. To fix, install v1.16.1 or later.


 Sep 11, 2018 3:20:42 PM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin Jenkins SSH Slaves plugin v1.8 (ssh-slaves)
java.io.IOException: Jenkins SSH Slaves plugin v1.8 failed to load.
 - SSH Credentials Plugin v1.10 failed to load. Fix this plugin first.

Is anyone aware if this is a known issue? I can't find anything about it online...

I'm nervous of trying to update these as the first time that I ran Jenkins in this fashion, I upgraded a number of plugins and found that Jenkins wouldn't start again. 

So if anyone has seen this and came up with a viable solution I'd be glad to hear about it. Also, any help understanding how this task works its magic with the WAR would be appreciated.

 Cheers

Steady

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/92268150-b06b-45ee-9424-e5c5446c9722%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/7D084702-6E9B-4888-AD38-BBF2D7B8CA93%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

signature.asc (540 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Problems with the SSH plugins when running under - mvn hpi:run

steadyonabix
Thanks, you were right.

On Wed, 12 Sep 2018 at 10:27, Ullrich Hafner <[hidden email]> wrote:
You need to update some dependencies in you pom. Make sure that you use a compatible set of dependencies. The maven enforcer will assist you with the problems of wrong and old dependencies.

Am 12.09.2018 um 10:26 schrieb steadyonabix <[hidden email]>:

I'm seeing these errors when starting up Jenkins via the mvn hpi:run task:

Sep 11, 2018 3:20:42 PM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin SSH Credentials Plugin v1.10 (ssh-credentials)
java.io.IOException: SSH Credentials Plugin v1.10 failed to load.
 - Credentials Plugin v1.9.4 is older than required. To fix, install v1.16.1 or later.


 Sep 11, 2018 3:20:42 PM jenkins.InitReactorRunner$1 onTaskFailed
SEVERE: Failed Loading plugin Jenkins SSH Slaves plugin v1.8 (ssh-slaves)
java.io.IOException: Jenkins SSH Slaves plugin v1.8 failed to load.
 - SSH Credentials Plugin v1.10 failed to load. Fix this plugin first.

Is anyone aware if this is a known issue? I can't find anything about it online...

I'm nervous of trying to update these as the first time that I ran Jenkins in this fashion, I upgraded a number of plugins and found that Jenkins wouldn't start again. 

So if anyone has seen this and came up with a viable solution I'd be glad to hear about it. Also, any help understanding how this task works its magic with the WAR would be appreciated.

 Cheers

Steady

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/92268150-b06b-45ee-9424-e5c5446c9722%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "Jenkins Developers" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/jenkinsci-dev/MDYZM3_O-yQ/unsubscribe.
To unsubscribe from this group and all its topics, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/7D084702-6E9B-4888-AD38-BBF2D7B8CA93%40gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/CAAJH18hdrQp3q56oXxo8PhkiBNNdxuazB3g8xHxOUKeXORcKRw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.