RE: NPE with maven 2 build

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

RE: NPE with maven 2 build

tvworks

I get the following if I use the maven 2 integrated build.

 

Parsing POMs
ERROR: Processing failed due to a bug in the code. Please report thus to [hidden email]
java.lang.NullPointerException
        at hudson.maven.PomInfo.<init>(PomInfo.java:93)
        at hudson.maven.MavenModuleSetBuild$PomParser.toPomInfo(MavenModuleSetBuild.java:311)
        at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:295)
        at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:258)
        at hudson.FilePath.act(FilePath.java:239)
        at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:193)
        at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:121)
        at hudson.model.Run.run(Run.java:559)
        at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:132)
        at hudson.model.Executor.run(Executor.java:59)
FATAL: null
java.lang.NullPointerException
        at hudson.maven.PomInfo.<init>(PomInfo.java:93)
        at hudson.maven.MavenModuleSetBuild$PomParser.toPomInfo(MavenModuleSetBuild.java:311)
        at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:295)
        at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:258)
        at hudson.FilePath.act(FilePath.java:239)
        at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:193)
        at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:121)
        at hudson.model.Run.run(Run.java:559)
        at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:132)
        at hudson.model.Executor.run(Executor.java:59)

 

 

Jason Chaffee

Software Architect/Server Team Manager

TVWorks LLC

APPLICATIONS DIVISION

Tel : 415.380.6316

Cell: 415.637.8061

 

 

Reply | Threaded
Open this post in threaded view
|

Re: NPE with maven 2 build

jcblitz
Have you searched https://hudson.dev.java.net/servlets/ProjectIssues to see if anyone else is having the same issue?

On May 7, 2007, at 8:15 PM, Jason Chaffee wrote:

I get the following if I use the maven 2 integrated build.

 

Parsing POMs
ERROR: Processing failed due to a bug in the code. Please report thus to [hidden email]
java.lang.NullPointerException
        at hudson.maven.PomInfo.<init>(PomInfo.java:93)
        at hudson.maven.MavenModuleSetBuild$PomParser.toPomInfo(MavenModuleSetBuild.java:311)
        at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:295)
        at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:258)
        at hudson.FilePath.act(FilePath.java:239)
        at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:193)
        at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:121)
        at hudson.model.Run.run(Run.java:559)
        at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:132)
        at hudson.model.Executor.run(Executor.java:59)
FATAL: null
java.lang.NullPointerException
        at hudson.maven.PomInfo.<init>(PomInfo.java:93)
        at hudson.maven.MavenModuleSetBuild$PomParser.toPomInfo(MavenModuleSetBuild.java:311)
        at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:295)
        at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:258)
        at hudson.FilePath.act(FilePath.java:239)
        at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:193)
        at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:121)
        at hudson.model.Run.run(Run.java:559)
        at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:132)
        at hudson.model.Executor.run(Executor.java:59)

 

 

Jason Chaffee

Software Architect/Server Team Manager

APPLICATIONS DIVISION

Tel : 415.380.6316

Cell: 415.637.8061

 

 



Reply | Threaded
Open this post in threaded view
|

Re: NPE with maven 2 build

Kohsuke Kawaguchi
Administrator
2007/5/7, Jared Blitzstein <[hidden email]>:
> Have you searched
> https://hudson.dev.java.net/servlets/ProjectIssues to see
> if anyone else is having the same issue?

And if no similar issue is found, please report this as an issue,
Jason, so that this won't fall through the crack.

--
Kohsuke Kawaguchi

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

RE: Re: NPE with maven 2 build

tvworks
In reply to this post by jcblitz

I didn’t find anything and I wasn’t able to add one, perhaps I needed to create a java.net account??

 


From: Jared Blitzstein [mailto:[hidden email]]
Sent: Monday, May 07, 2007 8:23 PM
To: [hidden email]
Subject: Re: NPE with maven 2 build

 

Have you searched https://hudson.dev.java.net/servlets/ProjectIssues to see if anyone else is having the same issue?

 

On May 7, 2007, at 8:15 PM, Jason Chaffee wrote:



I get the following if I use the maven 2 integrated build.

 

Parsing POMs
ERROR: Processing failed due to a bug in the code. Please report thus to [hidden email]
java.lang.NullPointerException
        at hudson.maven.PomInfo.<init>(PomInfo.java:93)
        at hudson.maven.MavenModuleSetBuild$PomParser.toPomInfo(MavenModuleSetBuild.java:311)
        at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:295)
        at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:258)
        at hudson.FilePath.act(FilePath.java:239)
        at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:193)
        at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:121)
        at hudson.model.Run.run(Run.java:559)
        at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:132)
        at hudson.model.Executor.run(Executor.java:59)
FATAL: null
java.lang.NullPointerException
        at hudson.maven.PomInfo.<init>(PomInfo.java:93)
        at hudson.maven.MavenModuleSetBuild$PomParser.toPomInfo(MavenModuleSetBuild.java:311)
        at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:295)
        at hudson.maven.MavenModuleSetBuild$PomParser.invoke(MavenModuleSetBuild.java:258)
        at hudson.FilePath.act(FilePath.java:239)
        at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:193)
        at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:121)
        at hudson.model.Run.run(Run.java:559)
        at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:132)
        at hudson.model.Executor.run(Executor.java:59)

 

 

Jason Chaffee

Software Architect/Server Team Manager

APPLICATIONS DIVISION

 

Reply | Threaded
Open this post in threaded view
|

Re: Re: NPE with maven 2 build

Kohsuke Kawaguchi
Administrator
2007/5/8, Jason Chaffee <[hidden email]>:
> I didn't find anything and I wasn't able to add one, perhaps I needed to
> create a java.net account??

Yeah, I think so.

--
Kohsuke Kawaguchi

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]