Re: Need to change API names for general consistency

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Need to change API names for general consistency

Jason Dillon
Sorry for the noise, wrong list... damn mail address auto complete got me again.

--jason


On Jul 25, 2010, at 5:38 PM, Jason Dillon wrote:

> BTW, we eventually need to update the API/Client bits to reflect proper Hudson naming.  Its mixed up at the moment, due to my lack of understanding when I started working on this stuff.
>
> Hudson has the concept of a Job which has Run's.  And it has an job extension of a Project (AbstractProject) which has builds (AbstractBuild).  A project is a job and a build is a run.
>
> ATM, we have exposed jobs and builds, which doesn't make sense.  Probably going to have to change all the *[Jj]ob* bits to *[Pp]roject* to keep the naming sanity.  Not sure if/how we would ever want to expose the lower-level job/run bits.  I need to ping the Hudson dev@ list to see what the point of this separation is, and maybe help drive to a more coherent API... but that will come much later.  For now just to keep things sane I think we should change the names.
>
> --jason


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]