Quantcast

Re: "Hudson" Subversion Tagging Plugin [JENKINS-10857]

classic Classic list List threaded Threaded
1 message Options
jv
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: "Hudson" Subversion Tagging Plugin [JENKINS-10857]

jv
I cc this to dev list hoping to provide some info directly to the Maintainer(s). The problem seems to be related to subversion plugin 1.30.  Please refer to JENKINS-10857 for details.


On 03.09.2011 02:28, John Vacz wrote:
It seems that all build after a certain point of time lost their tag-url field (I have a job, tag-url field for build #5522 [011-08-27 21:43:31] and earlier is ok, for build #5523 [2011-08-27 22:03:14] onward is missing).

I must have upgraded Jenkins and/or some plugins during that period of time. From the timestamp of Jenkins versions, I would guess that I had updated jenkins to 1.427. I pretty much keep Jenkins and plugins up-to-date, so at that time, I should have updated subversion tagging plugin to 1.15 for weeks.

Any thoughts?

Ticket for this issue: https://issues.jenkins-ci.org/browse/JENKINS-10857

On 30.08.2011 10:57, John Vacz wrote:
I've tried downgrading Jenkins (dpkg -i jenkins_1.xxx_all.deb) and subversion tagging plugin, to see which combination works. The following is my test (chronically):
1.427+1.15 no
1.427+1.14 no
1.426+1.14 no
1.425+1.14 no
1.424+1.14 yes
then I try to upgrade subversion tagging plugin again:
1.424+1.15 no (?!)
back again
1.424+1.14 no (??!)

I am confused. Are there other factors interferring with this issue?

I am pretty sure that 1.424 + 1.15 worked.

Any help is appreciated.

regards
--vf

Another thing I noticed, in Jenkins 1.424, plugin manager shows the correct wiki-link (subversion tagging plugin) to wiki.jenkins-ci.org, but in 1.427, the link refers to wiki.hudson-ci.org. Is this a regression?

Am 29.08.2011 16:03, schrieb John Vacz:
Hello,

I just upgraded to 1.427 and the Subversion Tagging plugin does not look like before (see attachment), the Tag-URL input-field is gone.

There is also something wierd in plugin manager, many plugin links are now pointing to hudson-ci.org, including "Hudson Subversion Tagging plugin". I dont know whether this is relevant.

Anyone has the same problem?

regards,
--vf


Jenkins 1.427 on Debian Lenny, native Debian package, upgraded via "apt-get upgrade";
Hudson Subversion Tagging Plugin 1.15



Loading...