Request to be a maintainer for the IvyTrigger Plugin

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Request to be a maintainer for the IvyTrigger Plugin

Bergquist, Brett

https://wiki.jenkins.io/display/JENKINS/IvyTrigger+Plugin

 

I have privately emails Gregory Boissinot about becoming a maintainer but have not heard back.   Here is what I had sent Gregory

 

I am going to be using this plugin and have already figured out how it is mostly designed and working.   I have opened

 

https://issues.jenkins-ci.org/browse/JENKINS-47794

 

and have implemented this locally as I mention in the JIRA.   This also takes care of

 

https://issues.jenkins-ci.org/browse/JENKINS-23429

 

Which was my first stumbling block with the plugin on use with Jenkins running on Solaris 10.

 

I am still learning my way around plugin development, Jenkins architecture, Jelly, etc. so I am not that productive at this point but I have been able to build with my change and install and run and debug.  

 

One of the features that I would like to add is to make this plugin compatible with the new “Pipeline” support of Jenkins 2.x so I am researching what needs to be done for that (and having a little trouble going through all of the bits and pieces of documentation, blogs, etc.)

 

I have done no Jenkins plugin development but am starting to learn my way around and will probably have to ask questions especially in the area of making this plugin Pipeline compatible while maintaining backward compatibility.   But I do think I can contribute to this plug development.

 

My github ID is “bbergquist0930” and my Jenkin infrastructure account is “bbergquist”.

 

 

 



Canoga Perkins
20600 Prairie Street
Chatsworth, CA 91311
(818) 718-6300

This e-mail and any attached document(s) is confidential and is intended only for the review of the party to whom it is addressed. If you have received this transmission in error, please notify the sender immediately and discard the original message and any attachment(s).

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/97EB699F861AD841B5908C7CA9C9565604A104377D3C%40VSERVER1.canoga.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Request to be a maintainer for the IvyTrigger Plugin

Daniel Beck

> On 10. Nov 2017, at 20:16, Bergquist, Brett <[hidden email]> wrote:
>
> https://wiki.jenkins.io/display/JENKINS/IvyTrigger+Plugin
>  
> I have privately emails Gregory Boissinot about becoming a maintainer but have not heard back.   Here is what I had sent Gregory
>  
> …
> I have done no Jenkins plugin development but am starting to learn my way around and will probably have to ask questions especially in the area of making this plugin Pipeline compatible while maintaining backward compatibility.   But I do think I can contribute to this plug development.
>  
> My github ID is “bbergquist0930” and my Jenkin infrastructure account is “bbergquist”.
>

Gregory told me in an email a year or so ago that he no longer has the time to maintain his plugins, and put them all up for adoption. So we can proceed assuming this transfer is fine with him.

Please follow the instructions in https://github.com/jenkins-infra/repository-permissions-updater/ and we'll set you up. Make sure to mention in the PR that you also need commit access, if applicable.

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/B195132D-C41F-4A98-8C6B-7F8CD9E81DDB%40beckweb.net.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Request to be a maintainer for the IvyTrigger Plugin

Oleg Nenashev
Gregory told me in an email a year or so ago that he no longer has the time to maintain his plugins, and put them all up for adoption. So we can proceed assuming this transfer is fine with him

+1, no need to add another timeout

BR, Oleg
 
пятница, 10 ноября 2017 г., 22:12:58 UTC+1 пользователь Daniel Beck написал:

> On 10. Nov 2017, at 20:16, Bergquist, Brett <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="i3nLPs0SCwAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">BBerg...@...> wrote:
>
> <a href="https://wiki.jenkins.io/display/JENKINS/IvyTrigger+Plugin" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwiki.jenkins.io%2Fdisplay%2FJENKINS%2FIvyTrigger%2BPlugin\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGTqfi4iuLoUu2IH2W5yTbPPBmtmQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwiki.jenkins.io%2Fdisplay%2FJENKINS%2FIvyTrigger%2BPlugin\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGTqfi4iuLoUu2IH2W5yTbPPBmtmQ&#39;;return true;">https://wiki.jenkins.io/display/JENKINS/IvyTrigger+Plugin
>  
> I have privately emails Gregory Boissinot about becoming a maintainer but have not heard back.   Here is what I had sent Gregory
>  
> …
> I have done no Jenkins plugin development but am starting to learn my way around and will probably have to ask questions especially in the area of making this plugin Pipeline compatible while maintaining backward compatibility.   But I do think I can contribute to this plug development.
>  
> My github ID is “bbergquist0930” and my Jenkin infrastructure account is “bbergquist”.
>

Gregory told me in an email a year or so ago that he no longer has the time to maintain his plugins, and put them all up for adoption. So we can proceed assuming this transfer is fine with him.

Please follow the instructions in <a href="https://github.com/jenkins-infra/repository-permissions-updater/" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fjenkins-infra%2Frepository-permissions-updater%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFcWVq8KHaUItF9eFurQcXeiQVuGw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fjenkins-infra%2Frepository-permissions-updater%2F\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFcWVq8KHaUItF9eFurQcXeiQVuGw&#39;;return true;">https://github.com/jenkins-infra/repository-permissions-updater/ and we'll set you up. Make sure to mention in the PR that you also need commit access, if applicable.

--
You received this message because you are subscribed to the Google Groups "Jenkins Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-dev/e3b725a7-3712-472e-b7d0-e98ba4442717%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.