Strange behavior

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Strange behavior

daniel.galan
Hi there

after a successful build, the job still is red:

[..snip..]

BUILD SUCCESSFUL
Total time: 0 seconds
/bin/rm: cannot remove `../lastSuccessful': No such file or directory No test report files were found. Configuration error? Test reports were found but none of them are new. Did tests run?

[..snap..]

Something goes wrong after the build has been executed and hudson tries to clean up something.
Note: My other Jobs work as expected.

Greetings
Daniel

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Strange behavior

daniel.galan
Hi there

> after a successful build, the job still is red:
>
> [..snip..]
>
> BUILD SUCCESSFUL
> Total time: 0 seconds
> /bin/rm: cannot remove `../lastSuccessful': No such file or
> directory No test report files were found. Configuration
> error? Test reports were found but none of them are new. Did
> tests run?
>
> [..snap..]
>
> Something goes wrong after the build has been executed and
> hudson tries to clean up something.
> Note: My other Jobs work as expected.

Problem solved, if "publish junit tests" is checked, and there aren't any tests it will fail, even if the build is successful.

Greetings
Daniel

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Strange behavior

Kohsuke Kawaguchi-2
[hidden email] wrote:
>> /bin/rm: cannot remove `../lastSuccessful': No such file or
>> directory No test report files were found. Configuration
>> error? Test reports were found but none of them are new. Did
>> tests run?
>
> Problem solved, if "publish junit tests" is checked, and there aren't any tests it will fail, even if the build is successful.

Yes, this is the expected behavior. The last few error messages are
intended to convey that. If you have any suggestion about making it
easier to understand, that would be greatly appreciated.


--
Kohsuke Kawaguchi
Sun Microsystems                   [hidden email]

smime.p7s (4K) Download Attachment