Triggering SCM polling on post-commit, unable to diagnose silent fail

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Triggering SCM polling on post-commit, unable to diagnose silent fail

hmaclaren

Hi there,

 

I’ve been working on incorporating the new post-commit hook into our current Hudson setup (which is working fine).

 

We have a post-commit script written in C# that used to call the trigger URL for specific projects, so now I’ve reconfigured it to use the POST command shown in the script: http://wiki.hudson-ci.org/display/HUDSON/Subversion+post-commit+hook

 

But now the request seems to be failing silently. I get an ACK back from the server, but after that nothing happens and nothing is recorded in the logs to see why the request is ignored. Is there any more information I can collect other that what is already collected in the default log?

 

Many thanks,

 

Heather

 

 

 

Reply | Threaded
Open this post in threaded view
|

Re: Triggering SCM polling on post-commit, unable to diagnose silent fail

hmaclaren
Update: I have been able to verify that a notify request is received, but cannot see anything happening after that.

Jun 25, 2009 5:46:56 PM hudson.scm.SubversionRepositoryStatus
FINE: Change reported to Subversion repository 0b490fdd-6d02-e842-8655-fd354a742aa5 on [look changed --revision 34124  E:\source`]

I am wondering if anyone has an idea as to what I may be doing incorrectly.

hmaclaren wrote
We have a post-commit script written in C# that used to call the trigger
URL for specific projects, so now I've reconfigured it to use the POST
command shown in the script:
http://wiki.hudson-ci.org/display/HUDSON/Subversion+post-commit+hook

But now the request seems to be failing silently. I get an ACK back from
the server, but after that nothing happens and nothing is recorded in
the logs to see why the request is ignored. Is there any more
information I can collect other that what is already collected in the
default log?
Reply | Threaded
Open this post in threaded view
|

Re: Triggering SCM polling on post-commit, unable to diagnose silent fail

zzyzx-2
I have the same problem.  Hudson responds with "Ok" but nothing ever happens after that.  Nothing is queued.  Here is a related thread:

http://www.nabble.com/Seems-like-an-issue-in-Hudson-1.313---post-commit-hook-doesn%27t-start-the-polling-trigger-td24302820.html#a24302820

--dan

hmaclaren wrote
Update: I have been able to verify that a notify request is received, but cannot see anything happening after that.

Jun 25, 2009 5:46:56 PM hudson.scm.SubversionRepositoryStatus
FINE: Change reported to Subversion repository 0b490fdd-6d02-e842-8655-fd354a742aa5 on [look changed --revision 34124  E:\source`]

I am wondering if anyone has an idea as to what I may be doing incorrectly.

hmaclaren wrote
We have a post-commit script written in C# that used to call the trigger
URL for specific projects, so now I've reconfigured it to use the POST
command shown in the script:
http://wiki.hudson-ci.org/display/HUDSON/Subversion+post-commit+hook

But now the request seems to be failing silently. I get an ACK back from
the server, but after that nothing happens and nothing is recorded in
the logs to see why the request is ignored. Is there any more
information I can collect other that what is already collected in the
default log?
Reply | Threaded
Open this post in threaded view
|

Re: Triggering SCM polling on post-commit, unable to diagnose silent fail

Kohsuke Kawaguchi
Administrator
In reply to this post by hmaclaren

Can you follow http://wiki.hudson-ci.org/display/HUDSON/Logging and
increase the log level for hudson.scm.SubversionRepositoryStatus ?

That should tell us how Hudson handled the notification.

hmaclaren wrote:

> Update: I have been able to verify that a notify request is received, but
> cannot see anything happening after that.
>
> Jun 25, 2009 5:46:56 PM hudson.scm.SubversionRepositoryStatus
> FINE: Change reported to Subversion repository
> 0b490fdd-6d02-e842-8655-fd354a742aa5 on [look changed --revision 34124
> E:\source`]
>
> I am wondering if anyone has an idea as to what I may be doing incorrectly.
>
>
> hmaclaren wrote:
>>
>>
>> We have a post-commit script written in C# that used to call the trigger
>> URL for specific projects, so now I've reconfigured it to use the POST
>> command shown in the script:
>> http://wiki.hudson-ci.org/display/HUDSON/Subversion+post-commit+hook
>>
>> But now the request seems to be failing silently. I get an ACK back from
>> the server, but after that nothing happens and nothing is recorded in
>> the logs to see why the request is ignored. Is there any more
>> information I can collect other that what is already collected in the
>> default log?
>>
>>
>

--
Kohsuke Kawaguchi
Sun Microsystems                   http://weblogs.java.net/blog/kohsuke/

smime.p7s (4K) Download Attachment