Trunk not compiling

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Trunk not compiling

Jesse Glick
Anyone else see these errors?

> /space/src/hudson/main/core/src/main/java/hudson/model/Hudson.java:18: package hudson.node_monitors does not exist
> import hudson.node_monitors.NodeMonitor;
>                            ^
> /space/src/hudson/main/core/src/main/java/hudson/model/Hudson.java:48: cannot find symbol
> symbol  : class ClockDifference
> location: package hudson.util
> import hudson.util.ClockDifference;
>                   ^

-J.

--
[hidden email]  netbeans.org  ant.apache.org  hudson.dev.java.net
             http://google.com/search?q=e%5E%28pi*i%29%2B1

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Trunk not compiling

Kohsuke Kawaguchi
Administrator
Jesse Glick wrote:
> Anyone else see these errors?
>
>> /space/src/hudson/main/core/src/main/java/hudson/model/Hudson.java:18: package hudson.node_monitors does not exist
>> import hudson.node_monitors.NodeMonitor;
>>                            ^
>> /space/src/hudson/main/core/src/main/java/hudson/model/Hudson.java:48: cannot find symbol
>> symbol  : class ClockDifference
>> location: package hudson.util
>> import hudson.util.ClockDifference;

My Hudson on Hudson [1] is building. Have you run with "cvs update -P"?


[1] http://kohsuke.sfbay/hudson/job/hudson/
--
Kohsuke Kawaguchi
Sun Microsystems                   [hidden email]

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trunk not compiling

Jesse Glick
Kohsuke Kawaguchi wrote:
> My Hudson on Hudson [1] is building. Have you run with "cvs update -P"?

Always, it's in my .cvsrc.

Building for me now too; maybe I just caught it at a bad time.

-J.

--
[hidden email]  netbeans.org  ant.apache.org  hudson.dev.java.net
             http://google.com/search?q=e%5E%28pi*i%29%2B1

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Trunk not compiling

Jesse Glick
Jesse Glick wrote:
> Building for me now too; maybe I just caught it at a bad time.

Now again not building:

> [INFO] Building Maven Hudson Plugin
> [INFO]    task-segment: [clean, install]
> [INFO] ----------------------------------------------------------------------------
> [INFO] Ignoring available plugin update: 2.3 as it requires Maven version 2.0.5
> [INFO] [clean:clean]
> [INFO] Deleting directory /space/src/hudson/tools/maven-hpi-plugin/target
> [INFO] Deleting directory /space/src/hudson/tools/maven-hpi-plugin/target/classes
> [INFO] Deleting directory /space/src/hudson/tools/maven-hpi-plugin/target/test-classes
> [INFO] Deleting directory /space/src/hudson/tools/maven-hpi-plugin/target/site
> [INFO] [plugin:descriptor]
> [WARNING] Goal prefix is: hpi; Maven currently expects it to be hpi
> [INFO] Using 2 extractors.
> [INFO] Applying extractor for language: java
> [INFO] Extractor for language: java found 6 mojo descriptors.
> [INFO] Applying extractor for language: bsh
> [INFO] Extractor for language: bsh found 0 mojo descriptors.
> [INFO] [resources:resources]
> [INFO] Using default encoding to copy filtered resources.
> [WARNING] While downloading xerces:xerces:2.2.1
>   This artifact has been relocated to xerces:xercesImpl:2.2.1.
>
>
> Downloading: http://download.java.net/maven/1//org.kohsuke.stapler/poms/maven-stapler-plugin-1.3.pom
> [WARNING] Unable to get resource from repository java.net (http://download.java.net/maven/1/)
> Downloading: http://repo1.maven.org/maven2/org/kohsuke/stapler/maven-stapler-plugin/1.3/maven-stapler-plugin-1.3.pom
> [WARNING] Unable to get resource from repository central (http://repo1.maven.org/maven2)
> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.12:compile' is invalid. It will be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
> Downloading: http://download.java.net/maven/1//org.kohsuke.stapler/jars/maven-stapler-plugin-1.3.jar
> [WARNING] Unable to get resource from repository java.net (http://download.java.net/maven/1/)
> Downloading: http://repo1.maven.org/maven2/org/kohsuke/stapler/maven-stapler-plugin/1.3/maven-stapler-plugin-1.3.jar
> [WARNING] Unable to get resource from repository central (http://repo1.maven.org/maven2)
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
>
> Missing:
> ----------
> 1) org.kohsuke.stapler:maven-stapler-plugin:jar:1.3
>
>   Try downloading the file manually from the project website.
>
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=org.kohsuke.stapler -DartifactId=maven-stapler-plugin \
>           -Dversion=1.3 -Dpackaging=jar -Dfile=/path/to/file
>
>   Path to dependency:
>   1) org.jvnet.hudson.tools:maven-hpi-plugin:maven-plugin:1.12-SNAPSHOT
>   2) org.kohsuke.stapler:maven-stapler-plugin:jar:1.3
>
> ----------
> 1 required artifact is missing.
>
> for artifact:
>   org.jvnet.hudson.tools:maven-hpi-plugin:maven-plugin:1.12-SNAPSHOT
>
> from the specified remote repositories:
>   java.net (http://download.java.net/maven/1/),
>   central (http://repo1.maven.org/maven2)

-J.

--
[hidden email]  netbeans.org  ant.apache.org  hudson.dev.java.net
             http://google.com/search?q=e%5E%28pi*i%29%2B1

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Trunk not compiling

Kohsuke Kawaguchi
Administrator

Over the weekend the daemon that manages
http://download.java.net/maven/2 choked because of the change in
java.net SSL certificate. That was fixed a few hours ago, so now things
should be back to normal.

Jesse Glick wrote:

> Jesse Glick wrote:
>> Building for me now too; maybe I just caught it at a bad time.
>
> Now again not building:
>
>> [INFO] Building Maven Hudson Plugin
>> [INFO]    task-segment: [clean, install]
>> [INFO] ----------------------------------------------------------------------------
>> [INFO] Ignoring available plugin update: 2.3 as it requires Maven version 2.0.5
>> [INFO] [clean:clean]
>> [INFO] Deleting directory /space/src/hudson/tools/maven-hpi-plugin/target
>> [INFO] Deleting directory /space/src/hudson/tools/maven-hpi-plugin/target/classes
>> [INFO] Deleting directory /space/src/hudson/tools/maven-hpi-plugin/target/test-classes
>> [INFO] Deleting directory /space/src/hudson/tools/maven-hpi-plugin/target/site
>> [INFO] [plugin:descriptor]
>> [WARNING] Goal prefix is: hpi; Maven currently expects it to be hpi
>> [INFO] Using 2 extractors.
>> [INFO] Applying extractor for language: java
>> [INFO] Extractor for language: java found 6 mojo descriptors.
>> [INFO] Applying extractor for language: bsh
>> [INFO] Extractor for language: bsh found 0 mojo descriptors.
>> [INFO] [resources:resources]
>> [INFO] Using default encoding to copy filtered resources.
>> [WARNING] While downloading xerces:xerces:2.2.1
>>   This artifact has been relocated to xerces:xercesImpl:2.2.1.
>>
>>
>> Downloading: http://download.java.net/maven/1//org.kohsuke.stapler/poms/maven-stapler-plugin-1.3.pom
>> [WARNING] Unable to get resource from repository java.net (http://download.java.net/maven/1/)
>> Downloading: http://repo1.maven.org/maven2/org/kohsuke/stapler/maven-stapler-plugin/1.3/maven-stapler-plugin-1.3.pom
>> [WARNING] Unable to get resource from repository central (http://repo1.maven.org/maven2)
>> [WARNING] POM for 'javanettasks:javanettasks:pom:1.0.12:compile' is invalid. It will be ignored for artifact resolution. Reason: Not a v4.0.0 POM.
>> Downloading: http://download.java.net/maven/1//org.kohsuke.stapler/jars/maven-stapler-plugin-1.3.jar
>> [WARNING] Unable to get resource from repository java.net (http://download.java.net/maven/1/)
>> Downloading: http://repo1.maven.org/maven2/org/kohsuke/stapler/maven-stapler-plugin/1.3/maven-stapler-plugin-1.3.jar
>> [WARNING] Unable to get resource from repository central (http://repo1.maven.org/maven2)
>> [INFO] ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Failed to resolve artifact.
>>
>> Missing:
>> ----------
>> 1) org.kohsuke.stapler:maven-stapler-plugin:jar:1.3
>>
>>   Try downloading the file manually from the project website.
>>
>>   Then, install it using the command:
>>       mvn install:install-file -DgroupId=org.kohsuke.stapler -DartifactId=maven-stapler-plugin \
>>           -Dversion=1.3 -Dpackaging=jar -Dfile=/path/to/file
>>
>>   Path to dependency:
>>   1) org.jvnet.hudson.tools:maven-hpi-plugin:maven-plugin:1.12-SNAPSHOT
>>   2) org.kohsuke.stapler:maven-stapler-plugin:jar:1.3
>>
>> ----------
>> 1 required artifact is missing.
>>
>> for artifact:
>>   org.jvnet.hudson.tools:maven-hpi-plugin:maven-plugin:1.12-SNAPSHOT
>>
>> from the specified remote repositories:
>>   java.net (http://download.java.net/maven/1/),
>>   central (http://repo1.maven.org/maven2)
>
> -J.
>

--
Kohsuke Kawaguchi
Sun Microsystems                   [hidden email]

smime.p7s (4K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Trunk not compiling

Jesse Glick
In reply to this post by Jesse Glick
Tried to build Hudson from sources again today; no luck:

> Downloading: http://repo1.maven.org/maven2/org/jvnet/hudson/main/hudson-core/1.134/hudson-core-1.134.jar
> [WARNING] Unable to get resource from repository central (http://repo1.maven.org/maven2)
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
>
> Missing:
> ----------
> 1) org.jvnet.hudson.main:hudson-core:jar:1.134
>
>   Try downloading the file manually from the project website.
>
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=org.jvnet.hudson.main -DartifactId=hudson-core \
>           -Dversion=1.134 -Dpackaging=jar -Dfile=/path/to/file
>
>   Path to dependency:
>   1) org.jvnet.hudson.plugins:batch-task:hpi:1.0-SNAPSHOT
>   2) org.jvnet.hudson.main:hudson-core:jar:1.134
>
> ----------
> 1 required artifact is missing.
>
> for artifact:
>   org.jvnet.hudson.plugins:batch-task:hpi:1.0-SNAPSHOT
>
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2),
>   java.net2 (http://download.java.net/maven/2/)

I am just running "mvn clean; cvs up; mvn install" as usual. Am I
missing something here? Does the Hudson project for Hudson itself do
something different, so that such problems are not caught?

I seem to be able to fix it by patching:

> Index: plugins/pom.xml
> ===================================================================
> RCS file: /shared/data/ccvs/repository/hudson/hudson/plugins/pom.xml,v
> retrieving revision 1.74
> diff -u -r1.74 pom.xml
> --- plugins/pom.xml 1 Sep 2007 16:34:28 -0000 1.74
> +++ plugins/pom.xml 2 Sep 2007 20:29:52 -0000
> @@ -28,13 +28,13 @@
>        <groupId>org.jvnet.hudson.main</groupId>
>        <artifactId>hudson-war</artifactId>
>        <type>war</type>
> -      <version>1.134</version>
> +      <version>1.135-SNAPSHOT</version>
>        <scope>test</scope>
>      </dependency>
>      <dependency>
>        <groupId>org.jvnet.hudson.main</groupId>
>        <artifactId>hudson-core</artifactId>
> -      <version>1.134</version>
> +      <version>1.135-SNAPSHOT</version>
>        <scope>provided</scope>
>      </dependency>
>      <dependency>

This should not be necessary, I thought.

-J.

--
[hidden email]  netbeans.org  ant.apache.org  hudson.dev.java.net
             http://google.com/search?q=e%5E%28pi*i%29%2B1

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Trunk not compiling

Kohsuke Kawaguchi
Administrator

It seems like my release script didn't run to the completion for 1.134.
The jar files were not pushed to the maven repository, and hence this error.

I'm just committing them now. Sorry about the trouble.

Jesse Glick wrote:

> Tried to build Hudson from sources again today; no luck:
>
>> Downloading: http://repo1.maven.org/maven2/org/jvnet/hudson/main/hudson-core/1.134/hudson-core-1.134.jar
>> [WARNING] Unable to get resource from repository central (http://repo1.maven.org/maven2)
>> [INFO] ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO] ------------------------------------------------------------------------
>> [INFO] Failed to resolve artifact.
>>
>> Missing:
>> ----------
>> 1) org.jvnet.hudson.main:hudson-core:jar:1.134
>>
>>   Try downloading the file manually from the project website.
>>
>>   Then, install it using the command:
>>       mvn install:install-file -DgroupId=org.jvnet.hudson.main -DartifactId=hudson-core \
>>           -Dversion=1.134 -Dpackaging=jar -Dfile=/path/to/file
>>
>>   Path to dependency:
>>   1) org.jvnet.hudson.plugins:batch-task:hpi:1.0-SNAPSHOT
>>   2) org.jvnet.hudson.main:hudson-core:jar:1.134
>>
>> ----------
>> 1 required artifact is missing.
>>
>> for artifact:
>>   org.jvnet.hudson.plugins:batch-task:hpi:1.0-SNAPSHOT
>>
>> from the specified remote repositories:
>>   central (http://repo1.maven.org/maven2),
>>   java.net2 (http://download.java.net/maven/2/)
>
> I am just running "mvn clean; cvs up; mvn install" as usual. Am I
> missing something here? Does the Hudson project for Hudson itself do
> something different, so that such problems are not caught?
>
> I seem to be able to fix it by patching:
>
>> Index: plugins/pom.xml
>> ===================================================================
>> RCS file: /shared/data/ccvs/repository/hudson/hudson/plugins/pom.xml,v
>> retrieving revision 1.74
>> diff -u -r1.74 pom.xml
>> --- plugins/pom.xml 1 Sep 2007 16:34:28 -0000 1.74
>> +++ plugins/pom.xml 2 Sep 2007 20:29:52 -0000
>> @@ -28,13 +28,13 @@
>>        <groupId>org.jvnet.hudson.main</groupId>
>>        <artifactId>hudson-war</artifactId>
>>        <type>war</type>
>> -      <version>1.134</version>
>> +      <version>1.135-SNAPSHOT</version>
>>        <scope>test</scope>
>>      </dependency>
>>      <dependency>
>>        <groupId>org.jvnet.hudson.main</groupId>
>>        <artifactId>hudson-core</artifactId>
>> -      <version>1.134</version>
>> +      <version>1.135-SNAPSHOT</version>
>>        <scope>provided</scope>
>>      </dependency>
>>      <dependency>
>
> This should not be necessary, I thought.
>
> -J.
>

--
Kohsuke Kawaguchi
Sun Microsystems                   [hidden email]

smime.p7s (4K) Download Attachment