Unable to install or update plugins in jenkins

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to install or update plugins in jenkins

Sivakumar Durairaj
Hi,

I am running jenkins in corporate network, where i am trying to install/update jenkins. (downloading .hpi and then uploading)

But installation  is not happening after succesfull upload and failed with below reason.

Caused: java.io.IOException: Failed to load http://updates.jenkins-ci.org/download/plugins/branch-api/2.0.19/branch-api.hpi to /app/jenkins/taaa-build/plugins/branch-api.jpi.tmp
at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1146)
Caused: java.io.IOException: Failed to download from http://updates.jenkins-ci.org/download/plugins/branch-api/2.0.19/branch-api.hpi
at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1172)
at hudson.model.UpdateCenter$DownloadJob._run(UpdateCenter.java:1677)
at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1874)
at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1651)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110)
at java.lang.Thread.run(Thread.java:748)

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/d3a6a06a-5727-45e9-ad1a-940f7d61968d%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: Unable to install or update plugins in jenkins

Björn Pedersen
Hi,

this looks like a  dependency can not get installled., probably due to jenkins not seeing the update center. So you need to manually upload all dependencie before your plugin.

Björn

Am Donnerstag, 21. Mai 2020 13:07:19 UTC+2 schrieb Sivakumar Durairaj:
Hi,

I am running jenkins in corporate network, where i am trying to install/update jenkins. (downloading .hpi and then uploading)

But installation  is not happening after succesfull upload and failed with below reason.

Caused: java.io.IOException: Failed to load <a href="http://updates.jenkins-ci.org/download/plugins/branch-api/2.0.19/branch-api.hpi" rel="nofollow" style="color:rgb(53,85,100);font-family:-apple-system,BlinkMacSystemFont,&quot;Segoe UI&quot;,Roboto,Oxygen,Ubuntu,&quot;Fira Sans&quot;,&quot;Droid Sans&quot;,&quot;Helvetica Neue&quot;,sans-serif;font-size:14px;background-color:rgb(244,245,247)" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fupdates.jenkins-ci.org%2Fdownload%2Fplugins%2Fbranch-api%2F2.0.19%2Fbranch-api.hpi\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFMGYkHk5IfULTO6JP3R_hT0LFHLw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fupdates.jenkins-ci.org%2Fdownload%2Fplugins%2Fbranch-api%2F2.0.19%2Fbranch-api.hpi\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFMGYkHk5IfULTO6JP3R_hT0LFHLw&#39;;return true;">http://updates.jenkins-ci.org/download/plugins/branch-api/2.0.19/branch-api.hpi to /app/jenkins/taaa-build/plugins/branch-api.jpi.tmp
at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1146)
Caused: java.io.IOException: Failed to download from <a href="http://updates.jenkins-ci.org/download/plugins/branch-api/2.0.19/branch-api.hpi" rel="nofollow" style="color:rgb(53,85,100);font-family:-apple-system,BlinkMacSystemFont,&quot;Segoe UI&quot;,Roboto,Oxygen,Ubuntu,&quot;Fira Sans&quot;,&quot;Droid Sans&quot;,&quot;Helvetica Neue&quot;,sans-serif;font-size:14px;background-color:rgb(244,245,247)" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fupdates.jenkins-ci.org%2Fdownload%2Fplugins%2Fbranch-api%2F2.0.19%2Fbranch-api.hpi\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFMGYkHk5IfULTO6JP3R_hT0LFHLw&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fupdates.jenkins-ci.org%2Fdownload%2Fplugins%2Fbranch-api%2F2.0.19%2Fbranch-api.hpi\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFMGYkHk5IfULTO6JP3R_hT0LFHLw&#39;;return true;">http://updates.jenkins-ci.org/download/plugins/branch-api/2.0.19/branch-api.hpi
at hudson.model.UpdateCenter$UpdateCenterConfiguration.download(UpdateCenter.java:1172)
at hudson.model.UpdateCenter$DownloadJob._run(UpdateCenter.java:1677)
at hudson.model.UpdateCenter$InstallationJob._run(UpdateCenter.java:1874)
at hudson.model.UpdateCenter$DownloadJob.run(UpdateCenter.java:1651)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at hudson.remoting.AtmostOneThreadExecutor$Worker.run(AtmostOneThreadExecutor.java:110)
at java.lang.Thread.run(Thread.java:748)

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/d4aaca30-79c3-40bb-9fa0-3278d5aa0eaa%40googlegroups.com.