Unable to run Nexus 1.3.4 with Glassfishv2ur2 on Aix

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to run Nexus 1.3.4 with Glassfishv2ur2 on Aix

Baptiste MATHUS
Hi all,

I'm currently stuck with this problem. I already read https://docs.sonatype.com/display/NX/Nexus+FAQ#NexusFAQ-Q.Whycan%27tIdeploytheWARintoGlassFishserver%3F and http://www.sonatype.com/books/nexus-book/reference/install-sect-as-a-war.html#d0e829 (which, btw, doesn't say completely the same thing. If you follow the "book" documentation, you get an error saying that the logfile wasn't defined).

Anyway, I guess I did that correctly and I'm now stuck with something bizarre... But I'm quite used to it with Aix JVM...

When I deploy nexus 1.3.4, apart from the fact that "asadmin stop-domain" will become unusable ending with a NPE, I'll only get an *almost* empty page when opening the nexus webapp (see http://imagebin.ca/view/izcLwN7.html to understand what I mean by "almost empty").

Note that when I deploy under windows, it seems like the webapp is accessible (it seems to display nexus interface correctly), but it will just prevent glassfish from stopping properly.

I want to run nexus inside GF for two reasons: I want to run it along the already running hudson webapp (and only using one port for webapps), and because the jsw won't work for AIX (I already had the very same problem with sonar in the past). And I run it on AIX because AIX is our client platform, so we run almost all our server under AIX.

I don't really know where to look. Do you have any idea of what could be going on?

Thanks in advance.
Cheers
Reply | Threaded
Open this post in threaded view
|

Re: Unable to run Nexus 1.3.4 with Glassfishv2ur2 on Aix

Baptiste MATHUS
Please ignore this post. I seem to have f$%@ed up something while wanting to write to nexus-users :-/.
Sorry for the noise.

Baptiste MATHUS wrote
Hi all,

I'm currently stuck with this problem. I already read https://docs.sonatype.com/display/NX/Nexus+FAQ#NexusFAQ-Q.Whycan%27tIdeploytheWARintoGlassFishserver%3F and http://www.sonatype.com/books/nexus-book/reference/install-sect-as-a-war.html#d0e829 (which, btw, doesn't say completely the same thing. If you follow the "book" documentation, you get an error saying that the logfile wasn't defined).

Anyway, I guess I did that correctly and I'm now stuck with something bizarre... But I'm quite used to it with Aix JVM...

When I deploy nexus 1.3.4, apart from the fact that "asadmin stop-domain" will become unusable ending with a NPE, I'll only get an *almost* empty page when opening the nexus webapp (see http://imagebin.ca/view/izcLwN7.html to understand what I mean by "almost empty").

Note that when I deploy under windows, it seems like the webapp is accessible (it seems to display nexus interface correctly), but it will just prevent glassfish from stopping properly.

I want to run nexus inside GF for two reasons: I want to run it along the already running hudson webapp (and only using one port for webapps), and because the jsw won't work for AIX (I already had the very same problem with sonar in the past). And I run it on AIX because AIX is our client platform, so we run almost all our server under AIX.

I don't really know where to look. Do you have any idea of what could be going on?

Thanks in advance.
Cheers