Unable to run Selenium tests on CentOS through Xvfb

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Unable to run Selenium tests on CentOS through Xvfb

Gajanan Mahajan
I'm running Selenium tests on `CentOS 7` machine through Jenkins pipeline hence using `Xvfb`. When use `screen` argument with any valid value like following -

    wrap([$class: 'Xvfb', autoDisplayName: true, screen: '1440x800x8']) { 
       <code to run Selenium test here>
    }

It results into following error -



    [testng] org.openqa.selenium.WebDriverException: chrome not reachable
    
       [testng]   (Session info: chrome=80.0.3987.132)
    
       [testng]   (Driver info: chromedriver=80.0.3987.16 (320f6526c1632ad4f205ebce69b99a062ed78647-refs/branch-heads/3987@{#185}),platform=Linux 3.10.0-862.el7.x86_64 x86_64) (WARNING: The server did not provide any stacktrace information)
    
       [testng] Command duration or timeout: 0 milliseconds
    
       [testng] Build info: version: '3.14.0', revision: 'aacccce0', time: '2018-08-02T20:13:22.693Z'
    


If we run it without `screen` argument it runs successfully.

One more observation - with `screen` argument, it perfectly works on `Ubuntu 18`

Please help me how I can run Selenium tests with `screen` argument on `CentOS 7`.

--
You received this message because you are subscribed to the Google Groups "Jenkins Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/jenkinsci-users/c3ebeb4d-ddfb-4b5c-afdf-1e6bdf59194bo%40googlegroups.com.